Upgrade auf UCS4: PostgreSQL > 9.1 / Bareos Problem

german

#1

Bei einem Upgrade von UCS 3.2.6 auf letztendlich 4.0.2 gibt es ein Problem mit PostgreSQL Upgrade bzw. Bareos Dependency.

-) Beim Upgrade Prozess blieben zuerst die postgresql-9.1 Pakete halb-installiert bzw. mit Fehler zurück.
Laut sdb.univention.de/1220 zwecks manueller Migration machen, was aber (schon abgeändert 8.4 -> 9.1) nicht klappt:

root@metis ~ # pg_upgradecluster 8.4 main Stopping old cluster... Disabling connections to the old cluster during upgrade... Restarting old cluster with restricted connections... Configuring already existing cluster (configuration: /etc/postgresql/9.1/main, data: /var/lib/postgresql/9.1/main, owner: 122:129) Error: move_conffile: required configuration file /var/lib/postgresql/9.1/main/postgresql.conf does not exist Error: Could not create target cluster
MMn lief Bareos vorher auch unter 8.4 da in /etc/ ein entspr. Sub-Ordner ‘8.4’ liegt:

root@metis ~ # la /etc/postgresql/ insgesamt 32 drwxr-xr-x 5 root root 4096 Jul 11 06:21 . drwxr-xr-x 155 root root 12288 Jul 15 10:06 .. drwxr-xr-x 3 root root 4096 Nov 5 2014 7.4 drwxr-xr-x 3 root root 4096 Nov 5 2014 8.3 drwxr-xr-x 3 postgres postgres 4096 Nov 5 2014 8.4 -rw-r----- 1 postgres postgres 646 Jul 11 06:21 pam_ldap.conf
/etc/ Sub-Ordner für 9.1 kommt leider auch nach ‘apt-get install --reinstall postgresql-9.1’ nicht wieder (wurde oben laut sdb.univention.de/1220 ja vorher gelöscht) :frowning:
Nun scheinen postgresql-8.4 sowie auch postgresql-9.1 installiert, wobei nur die 8.4 Instanz läuft, Bareos aber nicht mehr darauf verbinden kann :frowning:

dpkg --audit ergibt nichts.
Wenn ich wieder 9.1 entfernen will, so will auch univention-bareos entfernt werden, obwohl Dependency mit 8.4 erfüllt sein sollte, seltsam?

root@metis ~ # apt-get remove postgresql-9.1 Paketlisten werden gelesen... Fertig Abhängigkeitsbaum wird aufgebaut. Statusinformationen werden eingelesen.... Fertig Die folgenden Pakete werden ENTFERNT: postgresql postgresql-9.1 univention-bareos

root@metis ~ # apt-cache show univention-bareos Package: univention-bareos Priority: optional Section: contrib/admin Installed-Size: 189 Maintainer: Sebastian Lederer <slederer@dass-it.de> Architecture: all Version: 13.2.2ucs4-3 Depends: univention-postgresql, postgresql (>= 8.4), bareos (>= 13.2.2), bareos-database-common, bareos-database-postgresql, dbconfig-common, bareos-database-tools, univention-join (>> 5.0.20-1.436), shell-univention-lib (>> 2.0.17-1.125) Conflicts: univention-bacula

Danke für jeden Tipp, das wieder gerade zu biegen.
Robert


Postgresql Update schlug fehl
Bareos Problem bei Upgrade auf PostgreSQL 9.1
#2

Nachtrag:
Komischerweise habe ich bei den Sourcen noch 3.2-6 Einträge, das scheint mir auch nicht normal:

[code]root@metis ~ # cat /etc/apt/sources.list.d/20_ucs-online-component.list
#Warning: This file is auto-generated and might be overwritten by

univention-config-registry.

Please edit the following file(s) instead:

#Warnung: Diese Datei wurde automatisch generiert und kann durch

univention-config-registry überschrieben werden.

Bitte bearbeiten Sie an Stelle dessen die folgende(n) Datei(en):

/etc/univention/templates/files/etc/apt/sources.list.d/20_ucs-online-component.list

deb http://appcenter.software-univention.de/univention-repository/4.0/maintained/component/ zarafa_20150513/all/
deb http://appcenter.software-univention.de/univention-repository/4.0/maintained/component/ zarafa_20150513/amd64/
deb http://updates.software-univention.de/3.2/maintained/component/ 3.2-6-errata/all/
deb http://updates.software-univention.de/3.2/maintained/component/ 3.2-6-errata/amd64/
deb http://updates.software-univention.de/3.2/unmaintained/component/ 3.2-6-errata/amd64/
deb http://appcenter.software-univention.de/univention-repository/4.0/maintained/component/ bareos_20140209/all/
deb http://appcenter.software-univention.de/univention-repository/4.0/maintained/component/ bareos_20140209/amd64/
deb http://appcenter.software-univention.de/univention-repository/4.0/maintained/component/ z-push_20150505/all/
deb http://updates.software-univention.de/4.0/maintained/component/ 4.0-2-errata/all/
deb http://updates.software-univention.de/4.0/maintained/component/ 4.0-2-errata/amd64/
deb http://updates.software-univention.de/4.0/unmaintained/component/ 4.0-2-errata/all/
deb http://updates.software-univention.de/4.0/unmaintained/component/ 4.0-2-errata/amd64/[/code]


#3

Ich vermute, dass von 9.1 in /var/lib/postgresql bereits Sachen herumliegen, an denen sich das pg_ugpradecluster stört. Daher schlage ich folgendes Vorgehen vor:

[ul][li]Stoppen Sie PostgreSQL 9.1, falls es laufen sollte. Prüfen Sie dieses sinnvollerweise mit »ps auxw | grep postgres« und nicht so etwas wie »/etc/init.d/postgresql-9.1 status«.[/li]
[li]Löschen Sie manuell die Verzeichnisse /etc/postgresql/9.1 und /var/lib/postgresql/9.1, sofern diese existieren (Achtung: /var/lib/postgresql/, nicht /var/lib/postgres/)[/li]
[li]Versuchen Sie ein erneutes Upgrade des 8.4er Clusters mit »pg_upgradecluster 8.4 main«.[/li]
[li]Sofern das klappt: testen Sie von Bareos aus die Verbindung, klappt auch das, so entfernen Sie nun die 8.4er PostgreSQL-Pakete.[/li][/ul]


#4

Hilft Updating from PostgreSQL 8.4 to PostgreSQL 9.1 ?


Fehler bei Update. von UCS 4.0-1 errata146 bis errata160
Fehler bei Update. von UCS 4.0-1 errata146 bis errata160
#5

Danke an Herrn Bunkus & Herrn Petersen!

Nach entfernen von /var/lib/postgresql/9.1/ und Umsetzung der Migrationsanleitung von sdb.univention.de/1220 lief alles wie gehabt.

Danke nochmals für den wirklich prompten & kompetenten Support hier!
Robert