Upgrade auf 3.2 scheitert

german

#1

Hallo,

da das Ende des Supports für UCS 3.1 bevorsteht, habe ich mich endlich an das Upgrade auf 3.2.1 gewagt. Leider war ich damit nicht erfolgreich:

Hier der Releasestand, von dem ich ausgehe:

root@sonne:~# ucr search --brief version repository/mirror/version/end: <empty> repository/mirror/version/start: <empty> repository/online/component/.*/version: <empty> repository/online/component/3.1-0-errata/version: 3.1 repository/online/component/3.1-1-errata/version: 3.1 update/umc/nextversion: true version/erratalevel: 229 version/patchlevel: 1 version/releasename: Findorff version/security-patchlevel: <empty> version/version: 3.1

Hier ein Auszug aus der Log-Datei updater.log :

Custom preupdate script /var/lib/local-preup.sh not found Checking for space on /var/cache/apt/archives: OK Checking for space on /boot: OK Checking for space on /: OK Checking for package status: iF linux-image-3.2.0-ucs28-amd64 3.2.39-2.28.201305151409 Linux 3.2 for 64-bit PCs iF linux-image-3.2.0-ucs31-amd64 3.2.46-1.31.201306180902 Linux 3.2 for 64-bit PCs iU univention-kernel-image 6.0.1-3.38.201306251330 UCS - Linux kernel (standard) failed ERROR: The package state on this system is inconsistent. Please run 'dpkg --configure -a' manually Error: Update aborted by pre-update script of release 3.2-0 exitcode of univention-updater: 1 ERROR: update failed. Please check /var/log/univention/updater.log

Und hier das Resultat von dpkg --configure -a :

root@sonne:/var/log/univention# dpkg --configure -a linux-image-3.2.0-ucs31-amd64 (3.2.46-1.31.201306180902) wird eingerichtet ... Running depmod. vmlinuz(/boot/vmlinuz-3.2.0-ucs31-amd64 ) points to /boot/vmlinuz-3.2.0-ucs31-amd64 (/boot/vmlinuz-3.2.0-ucs31-amd64) -- doing nothing at /var/lib/dpkg/info/linux-image-3.2.0-ucs31-amd64.postinst line 268. The link /initrd.img is a dangling linkto /boot/initrd.img-3.2.0-ucs31-amd64 Running /usr/sbin/update-grub. Generating grub.cfg ... /usr/sbin/grub-probe: error: Couldn't find PV pv1. Check your device.map. User postinst hook script [/usr/sbin/update-grub] exited with value 1 dpkg: Fehler beim Bearbeiten von linux-image-3.2.0-ucs31-amd64 (--configure): Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück linux-image-3.2.0-ucs28-amd64 (3.2.39-2.28.201305151409) wird eingerichtet ... Running depmod. The link /initrd.img is a dangling linkto /boot/initrd.img-3.2.0-ucs31-amd64 Running /usr/sbin/update-grub. Generating grub.cfg ... /usr/sbin/grub-probe: error: Couldn't find PV pv1. Check your device.map. User postinst hook script [/usr/sbin/update-grub] exited with value 1 dpkg: Fehler beim Bearbeiten von linux-image-3.2.0-ucs28-amd64 (--configure): Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück dpkg: Abhängigkeitsprobleme verhindern Konfiguration von univention-kernel-image: univention-kernel-image hängt ab von linux-image-3.2.0-ucs31-amd64; aber: Paket linux-image-3.2.0-ucs31-amd64 ist noch nicht konfiguriert. dpkg: Fehler beim Bearbeiten von univention-kernel-image (--configure): Abhängigkeitsprobleme - verbleibt unkonfiguriert Fehler traten auf beim Bearbeiten von: linux-image-3.2.0-ucs31-amd64 linux-image-3.2.0-ucs28-amd64 univention-kernel-image

zur Vollständigkeit hier noch die Ausgabe von ucr search --brief repository :

root@sonne:/var/log/univention# ucr search --brief repository local/repository: <empty> online/repository/clean: <empty> repository/app_center/server: appcenter.software-univention.de repository/mirror/architectures: <empty> repository/mirror/basepath: /var/lib/univention-repository repository/mirror/httpmethod: <empty> repository/mirror/port: <empty> repository/mirror/prefix: <empty> repository/mirror/recreate_packages: yes repository/mirror/server: <empty> repository/mirror/sources: <empty> repository/mirror/threads: 10 repository/mirror/version/end: <empty> repository/mirror/version/start: <empty> repository/mirror: false repository/online/architectures: <empty> repository/online/component/.*/clean: <empty> repository/online/component/.*/description: <empty> repository/online/component/.*/erratalevel: <empty> repository/online/component/.*/localmirror: <empty> repository/online/component/.*/parts: <empty> repository/online/component/.*/password: <empty> repository/online/component/.*/port: <empty> repository/online/component/.*/prefix: <empty> repository/online/component/.*/server: <empty> repository/online/component/.*/unmaintained: <empty> repository/online/component/.*/username: <empty> repository/online/component/.*/version: <empty> repository/online/component/.*: <empty> repository/online/component/3.1-0-errata/description: Errata updates for UCS 3.1-0 repository/online/component/3.1-0-errata/localmirror: true repository/online/component/3.1-0-errata/version: 3.1 repository/online/component/3.1-0-errata: false repository/online/component/3.1-1-errata/description: Errata updates for UCS 3.1-1 repository/online/component/3.1-1-errata/unmaintained: disabled repository/online/component/3.1-1-errata/version: 3.1 repository/online/component/3.1-1-errata: enabled repository/online/errata/start: <empty> repository/online/hotfixes: no repository/online/httpmethod: <empty> repository/online/maintained: yes repository/online/port: 80 repository/online/prefix: <empty> repository/online/server: updates.software-univention.de repository/online/sources: <empty> repository/online/unmaintained: off repository/online: yes

Wer kann mir einen Hinweis geben, wie ich weiter vorgehen kann? Vielen Dank!


#2

Hallo,

bitte einmal hier schauen: Fehler bei Curl Installation
Ich vermute das ist die gleiche Ursache/Lösung.

Mit freundlichen Grüßen
Janis Meybohm


#3

Das Problem konnte inzwischn dank dieses Hinweises gelöst werden, das Update ist drin. Vielen Dank dafür!

[code]
root@sonne:~# cat /boot/grub/device.map
(hd0) /dev/disk/by-id/ata-VB0250EAVER_Z3T18GHZ

root@sonne:~# grub-mkdevicemap -m -
(hd0) /dev/disk/by-id/ata-VB0250EAVER_Z3T18GHZ
(hd1) /dev/disk/by-id/ata-WDC_WD20EFRX-68AX9N0_WD-WMC300949097

root@sonne:~# grub-mkdevicemap

root@sonne:~# cat /boot/grub/device.map
(hd0) /dev/disk/by-id/ata-VB0250EAVER_Z3T18GHZ
(hd1) /dev/disk/by-id/ata-WDC_WD20EFRX-68AX9N0_WD-WMC300949097[/code]

Ich habe nun den Verdacht, bei der Erweiterung mit eine Zusätzlichen Festplatte noch andere Nacharbeiten vergessen zu haben. Wenn ich konkrete Hinweise darauf finde, werde ich mich wieder melden.

Grüße
ok