Upgrade Apache to > 2.4.30 [old topic: Change Let's encrypt vallidation type]

Hi,

this one adds to Let's encrypt whitout Port 80 , since I came here because my ISP blocks port 80 and therefore I can’t renew my certificates. Changing the ISP is not an option.

So to change Let’s encrypt to use Port 443 I wanted to change the validation type to TLS-ALPN.
I just wonder how this could be done or whether it could be done at all (with or without the lets encrypt app).

I think I need to install mod_md on Apache (https://github.com/icing/mod_md), but I haven’t done yet and worry to just break everything. Has someone already switched the vallidation type on lets encrypt and can give me some advices?

Best
Amerlander

Found out Univention runs Apache 2.4.25, but mod_md was introduced within 2.4.30. The newest version of mod_md actually requires Apache 2.4.41.

So the question now isn’t anymore how to change Let’s encrypt validation type but how to upgrade Apache to > 2.4.30?

Found this topic here, but they didnt ended up in upgrading Apache: Can we upgrade apache to version 2.4.35 or later

As univention works on UCS 5 which will use Debian 10 which include a higher Apache Version I guess there won’t be a non-hacky way to upgrade Apache on UCS 4. Therefore, I just moved the Server physically to a place where we have another ISP.

So UCS 5 might already include mod_md.