Upgrade 4.9 e1277 to 5.0-0 slave with kopano fails

Dear forum,

there are 3 servers I tried to upgrade from 4.9 e1277 to 5.0-0: master, backup and slave. The first thing I did was to update the Kopano Apps in order to be able to upgrade the master and backup. They completed successfully.

The third server (with Kopano Core/Webapp/Z-Push installed) failed on both tries:

The first try went like this
> univention-upgrade --noninteractive --updateto=5.0-0

it went on and on and ended like this:

Processing triggers for initramfs-tools (0.133+deb10u1) ...
**update-initramfs is disabled (system is running in docker configuration).**
Processing triggers for univention-config (15.0.7-8A~ ...
dpkg-query: Kein Paket gefunden, das auf ldapacl_66univention-ldap-server_acl-master-uvmm.acl passt
dpkg-query: Kein Paket gefunden, das auf ldapacl_66univention-appcenter_app.acl passt
dpkg-query: Kein Paket gefunden, das auf ldapacl_58univention-fetchmail-schema.acl passt
dpkg-query: Kein Paket gefunden, das auf ldapacl_62univention-portal.acl passt
dpkg-query: Kein Paket gefunden, das auf ldapacl_62univention-monitoring.acl passt
Processing triggers for libc-bin (2.28-10) ...
Processing triggers for systemd (241-7~deb10u7A~ ...
Processing triggers for libapache2-mod-php7.3 (7.3.27-1~deb10u1) ...
Processing triggers for libgdk-pixbuf2.0-0:amd64 (2.38.1+dfsg-1) ...
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)
Error: Failed to execute "apt-get -o DPkg::Options::=--force-confold -o DPkg::Options::=--force-overwrite -o DPkg::Options::=--force-overwrite-dir --trivial-only=no --assume-yes --quiet=1 -u dist-upgrade"
exitcode of univention-updater: 1
ERROR: update failed. Please check /var/log/univention/updater.log

After that I removed the package php-kopano-smime, and started univention-upgrade again. It finished successfully, but at the end the web ui was not available and after a reboot kernel is not loaded


I reverted to a snapshot and started over.
Second try:
This time I removed php-kopano-smime first, then started upgrade like above. It finished “successfully” - however Apache was not starting, it was missing a php library
Cannot load /usr/lib/apache2/modules/libphp7.3.so
I installed apt install -y libapache2-mod-php7.3
and apache started, but UMC was not available. Tried to reboot - the same result - failed to boot.


I don’t get what and why is it happening … Please help!

Best regards

Yesterday, a fix was released for the Kopano Core App, which should eliminate problems when updating to UCS 5. We saw that many kopano-* and univention-* packages were removed during the update. The issue occured when customers with a Kopano subscription had activated the external Kopano repositories in the App settings.

This should not happen anymore since yesterday. While i do not have the time to look into this thread’s issue individually, i suggest to retry the update.