Upgrade 4.2 - UMC ERR_TOO_MANY_REDIRECTS

umc
ucs-4-2
apache

#1

Hello,
After finishing the upgrade process to UCS 4.2. Univention Management Console became unaccesible. Trying to load the main page throws the message ERR_TOO_MANY_REDIRECTS

thanks,

Rolando Riley


#2

Hi,

the first thing which is usually recommended when this error appears is to clear cookies and the browser cache.
If this doesnt help you should analyze what URL your are actually trying to access and how the UCS setup is dealing with the URL in question. Things like https-rewrites and the configured startsite might be relevant.

Best Regards,
Dirk Ahrnke


#3

Hello,
I am needing help on this. These problem has nothing to do with browsers, so far we have tried from diferent vendors different computers or cellphones. The message is the same. The only thing available is /appsuite /ox6

      Any ideas?

Rolando


#4

Hello,
I am going to answer myself. The main site files are on


root@mail:/etc/apache2/ucs-sites.conf.d# uname -a
Linux mail 4.9.0-ucs103-amd64 #1 SMP Debian 4.9.13-1A~4.2.0.201703091358 (2017-03-09) x86_64 GNU/Linux

root@mail:/etc/apache2/ucs-sites.conf.d# ls
ucs-sites.conf  univention-portal.conf

root@mail:/etc/apache2/ucs-sites.conf.d# cat ucs-sites.conf
RewriteEngine on
RewriteOptions Inherit
ProxyPreserveHost on
ProxyTimeout 600
ocumentRoot /var/www/
CustomLog /var/log/apache2/access.log combined
RedirectMatch ^/$ /ucs-overview/en.html                #  THIS FILE IS MISSING!

root@mail:/etc/apache2/ucs-sites.conf.d# ls /var/www/ucs-overview/en.html
ls: cannot access /var/www/ucs-overview/en.html: No such file or directory

Can anyone hand me this file. Or tell me where I can get it? . If you wonder how this file can be missed, certainly was for an interrupted upgrade to UCS 4.2 . The structure of the website is different.

thanks,

Rolando Riley


#5

I had this kind of problem, when i tried to start the console via http://localhost. Try the Domain-Name, that might help.


#6

In my working install that file is as follows:-

RewriteEngine on
RewriteOptions Inherit
ProxyPreserveHost on
ProxyTimeout 600

DocumentRoot /var/www/
CustomLog /var/log/apache2/access.log combined
RedirectMatch ^/$ /univention/

So perhaps try just removing the “en.html” ?


#7

That might temporarily work around the problem but it would be better to fix the source by adjusting the UCRV .“apache2/startsite”.
On UCS 4.2 set this variable to “univention/”, in earlier versions “ucs-overview”.


#8

Ah… ok. This is often one of the mysteries of UCS for me. Knowing what config files are actually populated by UCR values. It’s probably documented somewhere. But for me if the config file is not commented to say so, I usually assume it isn’t.

All part of the learning and experience :slight_smile:


#9

ucs-sites.conf template is missing @%@UCRWARNING


#10

Hello thanks,
My workaround was changing the redirect to /univention//portal . Didn’t know about that variable either. Thanks,

Rolando