Updating from PostgreSQL 9.4 to PostgreSQL 9.6 does NOT work

postgresql
update
upgrade
ucs-4-3

#1

Hallo,

die in https://help.univention.com/t/updating-from-postgresql-9-4-to-postgresql-9-6/8075 von @requate angegebenen Schritte funktionieren auf meiner Installation nicht:

root@ucs:~# psql --version
psql (PostgreSQL) 9.4.13
root@ucs:~# [ -f /usr/sbin/univention-pkgdb-scan ] && chmod -x /usr/sbin/univention-pkgdb-scan
root@ucs:~# service postgresql stop
Failed to stop postgresql.service: Unit postgresql.service not loaded.
root@ucs:~# service postgresql stop
Failed to stop postgresql.service: Unit postgresql.service not loaded.
root@ucs:~# rm -rf /etc/postgresql/9.6
root@ucs:~# apt-get install --reinstall postgresql-9.6
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
E: Paket postgresql-9.6 kann nicht gefunden werden.
E: Mittels regulärem Ausdruck »postgresql-9.6« konnte kein Paket gefunden werden.
root@ucs:~# apt-get install --reinstall postgresql-9.6
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
E: Paket postgresql-9.6 kann nicht gefunden werden.
E: Mittels regulärem Ausdruck »postgresql-9.6« konnte kein Paket gefunden werden.
root@ucs:~# [ -f /usr/sbin/univention-pkgdb-scan ] && chmod +x /usr/sbin/univention-pkgdb-scan

Ich gehe davon aus, dass es - folgend den Erfahrungen der Vorgängerversionen - auf jeden Fall gut wäre, das Upgrade durchzuführen. Bei den älteren Versionen hat das Upgrade einwandfrei geklappt!

MBG,
TP


#2

Hi,

der von Dir verlinkte Artikel bezieht sich auf 4.3. Nutzt Du das etwa schon? Für 4.2 gibt es hingegen noch kein postgresql-9.6 Paket (“konnte kein Paket gefunden werden”). Wie willst Du also auf ein Paket updaten, das in den UCS- Repositories noch nicht vorhanden ist?

/KNEBB


#3

Hallo,

vollkommen richtig, ich habe 4.3 als 4.2-3 “überlesen”!
Danke für die Aufklärung!

VG,
TP