Updateprobleme UCS 2.4-4

german

#1

Wir haben das Problem, dass bei einem Update eines alten UCS 2.4-4 auf die Version 3.0 das Update mit einer Fehlermeldung abbricht, dass der Vorgang abgeborchen wird weil “Python2.6 - minimal” nicht gefunden werden konnte. Vorher kann der Updater bereits die Repositorys zum Updaten nicht finden, da diese laut Fehlermeldung verschoben wurden:

W: Failed to fetch apt.univention.de/2.2/maintained … 6/Packages 301 Moved Permanently

Gibt es hier einen neuen Pfad zu den Einträgen um das Update durchzuführen?


#2

Der Name apt.univention.de ist nicht mehr der richtige. Das müsste auch schon mit UCS 2.4 so gesetzt werden können:

ucr set repository/online/server='updates.software-univention.de'

#3

Die Repostiorys werden jetzt zwar gefunden, aber das Problem mit Python besteht weiter:

E: Wow, you exceeded the number of versions this APT is capable of.
E: Problem with MergeList /var/lib/apt/lists/updates.software-univention.de_2.3_unmaintained_2.3-0_i386_Packages
E: The package lists or status file could not be parsed or opened.
failed.
ERROR: Failed to upgrade python2.6.
Error: Update aborted by pre-update script of release 3.0-0


#4

Vielleicht hilft es unmaintained zu deaktivieren?

ucr set repository/online/unmaintained='no'