Update von UCS 3.2-3 auf 3.2-4 bricht ab

german

#1

Wir haben versucht, das Update von Version 3.2-3 auf 3.2-4 einzuspielen:
Damit kam es zu folgender Fehlermeldung:

[code]14.11.14 17:17:42.944 DEBUG_INIT

Starting univention-updater with parameter=[’/usr/share/univention-updater/univention-updater’, ‘net’, ‘–updateto’, ‘3.2-4’, ‘–ignoressh’, ‘–ignoreterm’]
Version=3.2
Patchlevel=3
starting net mode
—>DBG:update_available(mode=net, cdrom_mount_point=/cdrom, iso=None)
Checking network repository
Update to = 3.2-4
Downloading scripts at Fri Nov 14 17:17:44 2014
Starting actual update at Fri Nov 14 17:17:45 2014
Running preup.sh script
Fri Nov 14 17:17:45 CET 2014

HINT:
Please check the release notes carefully BEFORE updating to UCS 3.2-4:
English version: http://docs.univention.de/release-notes-3.2-4-en.html
German version: http://docs.univention.de/release-notes-3.2-4-de.html

Please also consider documents of following release updates and
3rd party components.

Do you want to continue [Y/n]?
Custom preupdate script /var/lib/local-preup.sh not found
Checking for space on /var/cache/apt/archives: OK
Checking for space on /boot: OK
Checking for space on /: OK
Checking for package status: iF postgresql-common 113.19.201210011446 PostgreSQL database-cluster manager
failed
ERROR: The package state on this system is inconsistent.
Please run ‘dpkg --configure -a’ manually
Error: Update aborted by pre-update script of release 3.2-4
[/code]

Wir haben das Postgresql Paket niemals angefasst.

Hat jemand eine Idee, was schiefgelaufen ist bzw. wie wir das Problem lösen können ?
Das Kommando “dpkg --configure -a” hat auch nicht weitergeholfen…

postgresql-common (113.19.201210011446) wird eingerichtet ... Starting PostgreSQL 8.4 database server: mainInsecure directory in $ENV{PATH} while running with -T switch at /usr/bin/pg_ctlcluster line 63. ... failed! failed! invoke-rc.d: initscript postgresql, action "start" failed. dpkg: Fehler beim Bearbeiten von postgresql-common (--configure): Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück Fehler traten auf beim Bearbeiten von: postgresql-common

Danke im Voraus,
Stefan Scherer


Update auf 4.0.1 bricht ab
#2

Keine Ahnung wie es dazu gekommen sein kann, aber evtl. hilft das hier? ubuntuforums.org/showthread.php?t=882648

emg


#3

Danke für den Tipp, ich werde es heute nachmittag ausprobieren.


#4

Hallo emg !

Genau das war’s, jetzt läuft mein Server mit 3.2-4.

Nochmals vielen Dank !
Stefan Scherer