Update Owncloud from 9.1 to 10

owncloud

#1

Is it possible to upgrade a 9.1 Owncloud installation to last version 10?
I have a 9.1 working installation of Owncloud (upgraded from 8.2) on Univention 4.2.2 and I’d like to update to the last Owncloud 10 but Software Update doesn’t show me any available updates. I can only see version 10 on App Center.


#2

We are working on an upgrade path from 9 to 10 with data and users.

At this moment you can remove the 9.1 and install the 10 owncloud app, but your data and users will be lost.

We hope to provide the upgrade path soon.


#3

Thanks dmitry for your reply.

I think I’ll wait the upgrade path… hope to see it soon.


#4

Hi Dmitry, any news about upgrade path from 9 to 10?


#5

Yeah, should be out this week


#6

I did the upgrade and now I have Owncloud client desktop that are working very good, but I can’t connect from browser because on login page I have an Internal Server Error message.
I cheked /var/log/apache2/error.log and I can see a lot of lines like this:

[Thu Oct 26 15:03:45.061155 2017] [proxy_http:error] [pid 2290] (103)Software caused connection abort: [client 192.168.0.120:58852] AH01102: error reading status line from remote server 127.0.0.1:40001
[Thu Oct 26 15:03:45.061212 2017] [proxy:error] [pid 2290] [client 192.168.0.120:58852] AH00898: Error reading from remote server returned by /owncloud/status.php


#7

How did you upgrade?


#8

First I did an uninstall of Owncloud 9.1.4, after that I did an Install of Owncloud 10.0.3


#9

very interesting. Did you do that via the web UI or the command line?


#10

I did it via the web UI.
What do you think?
Could I try to uninstall and install again Owncloud 10.0.3? Will this procedure keep my users and data?


#11

That is strange. The Migration from 9.1 to 10.0.3 should be fine, and the data and the users should remain. Did you change anything on the configuration?

If you uninstall the 10.0.3 app and reinstall it - you will have a backup of your database and the data, but it won’t be automatically imported back, you would have to do this on your own.


#12

No absolutely, I didn’t change anything in the configuration.
What do you suggest me?


#13

Could you try another browser to exclude caching problems?

Also, we would need the owncloud.log. You can find this at /var/lib/univention-appcenter/apps/owncloud/data/files/owncloud.log

Edit: did I get it right? You can sync your files with the desktop client but you can’t access the webUI?


#14

I tried with Firefox and I can access the login page, but when I insert user+password I get Internal Server Error.
Yes, desktop clients are working without errors, only webUi login page give Internal Server Error.
I tried to open a public shared link and is working correctly, the webUI in that case is OK
Why remote address is 172.x.x.x class and not 192.x.x.x (my lan addresses)?


#15

172 is the ip of the docker container inside the appliance.

The Appliance is a VM that gets the 192 IP. Inside runs owncloud in a docker container with an 172 IP

You can copy the error code and grep this on the owncloud.log. That should give you the exact error


#16

{“reqId”:“qzVsToBZfNr8Bb5MKL2I”,“level”:3,“time”:“2017-10-26T17:20:12+02:00”,“remoteAddr”:“172.17.42.1”,“user”:“owncloudadmin”,“app”:“index”,“method”:“GET”,“url”:"/owncloud/index.php/apps/files/",“message”:“Exception: {“Exception”:“InvalidArgumentException”,“Message”:”\"\/avatars\" must be relative to \“files\”",“Code”:0,“Trace”:"#0 \/var\/www\/owncloud\/lib\/private\/Files\/View.php(1951): OC\\Files\\View->getPathRelativeToFiles(’\/avatars’)\n#1 \/var\/www\/owncloud\/lib\/private\/Files\/View.php(1117): OC\\Files\\View->changeLock(’\/avatars’, 2)\n#2 \/var\/www\/owncloud\/lib\/private\/Files\/View.php(262): OC\\Files\\View->basicOperation(‘mkdir’, ‘\/avatars’, Array)\n#3 \/var\/www\/owncloud\/lib\/private\/Files\/Node\/Folder.php(156): OC\\Files\\View->mkdir(’\/avatars’)\n#4 \/var\/www\/owncloud\/lib\/private\/AvatarManager.php(99): OC\\Files\\Node\\Folder->newFolder(‘avatars’)\n#5 \/var\/www\/owncloud\/lib\/private\/AvatarManager.php(117): OC\\AvatarManager->getFolder(Object(OC\\Files\\Node\\Root), ‘avatars’)\n#6 \/var\/www\/owncloud\/lib\/private\/AvatarManager.php(91): OC\\AvatarManager->getAvatarFolder(Object(OC\\User\\User))\n#7 \/var\/www\/owncloud\/lib\/private\/TemplateLayout.php(101): OC\\AvatarManager->getAvatar(‘owncloudadmin’)\n#8 \/var\/www\/owncloud\/lib\/private\/legacy\/template.php(232): OC\\TemplateLayout->__construct(‘user’, ‘files’)\n#9 \/var\/www\/owncloud\/lib\/public\/AppFramework\/Http\/TemplateResponse.php(156): OC_Template->fetchPage()\n#10 \/var\/www\/owncloud\/lib\/private\/AppFramework\/Http\/Dispatcher.php(112): OCP\\AppFramework\\Http\\TemplateResponse->render()\n#11 \/var\/www\/owncloud\/lib\/private\/AppFramework\/App.php(98): OC\\AppFramework\\Http\\Dispatcher->dispatch(Object(OCA\\Files\\Controller\\ViewController), ‘index’)\n#12 \/var\/www\/owncloud\/lib\/private\/AppFramework\/Routing\/RouteActionHandler.php(46): OC\\AppFramework\\App::main(‘ViewController’, ‘index’, Object(OC\\AppFramework\\DependencyInjection\\DIContainer), Array)\n#13 [internal function]: OC\\AppFramework\\Routing\\RouteActionHandler->__invoke(Array)\n#14 \/var\/www\/owncloud\/lib\/private\/Route\/Router.php(307): call_user_func(Object(OC\\AppFramework\\Routing\\RouteActionHandler), Array)\n#15 \/var\/www\/owncloud\/lib\/base.php(928): OC\\Route\\Router->match(’\/apps\/files\/’)\n#16 \/var\/www\/owncloud\/index.php(56): OC::handleRequest()\n#17 {main}",“File”:"\/var\/www\/owncloud\/lib\/private\/Files\/View.php",“Line”:2078}"}


#17

can you access the Appliance via ssh?

sorry, dumb question, you can , how else could you have gotten the log.

can you manually create the avatars folder in the same folder that the files folder is located?


#18

I normally created avatars folder from my Mac using desktop client. No errors.
Sorry, maybe I need to create avatars folder in an other position…


#19

try to create it manually and remember to give recursive the ownership to www-data


#20

YESS!
Now I can login and everything is OK!
Thanks a lot dmitry for your precious help!