Update Nextcloud 24.0.6 to 24.0.7 failed

Yesterday (11/11) I ran the update offered in the UCM from Nextcloud 24.0.6 to 24.0.7. It went through without error messages and at the end NC 24.0.7 is marked as installed.
Unfortunately, no devices sync with the running NC instance anymore. When calling the web interface via “Use App” I get the following display. What do I have to enter here to start Nextcloud correctly again?
(The last change to the system was previously the installation of UCS 4.4 erratum 1333: squid3)

Nextcloud updates can go awry if the installed version isn’t updated and maintained from within Nextcloud before updating the app. There are a couple of threads on this that go into more detail. I’d recommend searching through those threads for some info to use in investigating further. There might be some clues in the logs that you could use.

Having had to deal with an update issue on Nextcloud before, my suggestion, if possible, would be to roll back the server to a snapshot from before the update. Then do all updates and suggested maintenance from within the previous working version of Nextcloud, and then reapply the update or wait until others have verified it’s working before updating.

I’ll probably try running updates this weekend sometime myself.

I updated all the apps inside my Nextcloud instance by logging into Nextcloud as Administrator. I then ran the app update in UCS and it worked fine. I also ran the command recommend in the installation notes once it was done, and that was also successful. Not sure it has any relevance, but I am also using UCS 5.

Hello Kevo,

thanks a lot for the info. Yesterday I got Nextcloud working again. I would like to briefly describe what I did to do this:

First with

univention-app shell nextcloud

i changed into the container. Then with

sudo -u www-data php /var/www/html/occ

i realized that NC is not installed! Afterwards i dared to reinstall NC with

sudo -u www-data php /var/www/html/occ app:install

which worked fine.

NC was now running but I could not yet access it via a browser.
In another of your posts about NC, the config.php was mentioned in which there were incorrect entries.
So I looked at it (first outside the container: /var/lib/univention-appcenter/apps/nextcloud/data/integration/config/config.php) and found that for some reason there were very few entries.
I was able to restore the old file from a backup before the update and manually transferred some entries from it to the new one, because I wasn’t sure what was changed correctly by the update. For example, there were missing entries under trusted_domains for the FQDN, the database including user and password, and the trusted_proxies. However, the installed version was correctly included.

I also filled the /var/www/html/config/config.php in the container with the entries.
The concept when under UCS the config.php from outside the container with the config.php in the container is aligned I have not yet understood.
After restarting apache I was able to access NC again from different devices. However, I had to log in again on each device and enable access to NC. Obviously the new installation is slightly different after all. When specifying https://FQDN/nextcloud/ the browser is now redirected to https://FQDN/nextcloud/index.php/ this was not the case before. I could imagine that the behavior has something to do with it.

At this point, thanks again for the steering me in the right direction.

1 Like

I have now also found the behavior with https://FQDN/nextcloud/index.php/.
There was a spelling error in the config.php in the line with ‘overwritewebroot’ => ‘/nextcloud’,

This now also works correctly again. But this had nothing to do with the previously described need to re-enable access to NC on every single device.