Update Member 4.4.7 -> 4.4.8 does not work

Hi@all,

I still have a UCS member with 4.4.7. The master is 4.4.8. When I try to update the member to 4.4.8, the update aborts. In the log file I find:

W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://updates.software-univention.de/4.3/unmaintained 4.3-0/all/ Release: Die folgenden Signaturen waren ungültig: EXPKEYSIG 36602BA86B8BFD3C Univention Corporate Server 4.x <packages@univention.de>
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://updates.software-univention.de/4.3/unmaintained 4.3-0/amd64/ Release: Die folgenden Signaturen waren ungültig: EXPKEYSIG 36602BA86B8BFD3C Univention Corporate Server 4.x <packages@univention.de>
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://updates.software-univention.de/4.3/maintained 4.3-1/all/ Release: Die folgenden Signaturen waren ungültig: EXPKEYSIG 36602BA86B8BFD3C Univention Corporate Server 4.x <packages@univention.de>
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://updates.software-univention.de/4.3/maintained 4.3-1/amd64/ Release: Die folgenden Signaturen waren ungültig: EXPKEYSIG 36602BA86B8BFD3C Univention Corporate Server 4.x <packages@univention.de>
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://updates.software-univention.de/4.3/unmaintained 4.3-1/all/ Release: Die folgenden Signaturen waren ungültig: EXPKEYSIG 36602BA86B8BFD3C Univention Corporate Server 4.x <packages@univention.de>
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://updates.software-univention.de/4.3/unmaintained 4.3-1/amd64/ Release: Die folgenden Signaturen waren ungültig: EXPKEYSIG 36602BA86B8BFD3C Univention Corporate Server 4.x <packages@univention.de>
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://updates.software-univention.de/4.3/maintained 4.3-2/all/ Release: Die folgenden Signaturen waren ungültig: EXPKEYSIG 36602BA86B8BFD3C Univention Corporate Server 4.x <packages@univention.de>
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://updates.software-univention.de/4.3/maintained 4.3-2/amd64/ Release: Die folgenden Signaturen waren ungültig: EXPKEYSIG 36602BA86B8BFD3C Univention Corporate Server 4.x <packages@univention.de>
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://updates.software-univention.de/4.3/unmaintained 4.3-2/all/ Release: Die folgenden Signaturen waren ungültig: EXPKEYSIG 36602BA86B8BFD3C Univention Corporate Server 4.x <packages@univention.de>
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://updates.software-univention.de/4.3/unmaintained 4.3-2/amd64/ Release: Die folgenden Signaturen waren ungültig: EXPKEYSIG 36602BA86B8BFD3C Univention Corporate Server 4.x <packages@univention.de>
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://updates.software-univention.de/4.3/maintained 4.3-3/all/ Release: Die folgenden Signaturen waren ungültig: EXPKEYSIG 36602BA86B8BFD3C Univention Corporate Server 4.x <packages@univention.de>
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://updates.software-univention.de/4.3/maintained 4.3-3/amd64/ Release: Die folgenden Signaturen waren ungültig: EXPKEYSIG 36602BA86B8BFD3C Univention Corporate Server 4.x <packages@univention.de>
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://updates.software-univention.de/4.3/unmaintained 4.3-3/all/ Release: Die folgenden Signaturen waren ungültig: EXPKEYSIG 36602BA86B8BFD3C Univention Corporate Server 4.x <packages@univention.de>
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://updates.software-univention.de/4.3/unmaintained 4.3-3/amd64/ Release: Die folgenden Signaturen waren ungültig: EXPKEYSIG 36602BA86B8BFD3C Univention Corporate Server 4.x <packages@univention.de>
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://updates.software-univention.de/4.3/maintained 4.3-4/all/ Release: Die folgenden Signaturen waren ungültig: EXPKEYSIG 36602BA86B8BFD3C Univention Corporate Server 4.x <packages@univention.de>
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://updates.software-univention.de/4.3/maintained 4.3-4/amd64/ Release: Die folgenden Signaturen waren ungültig: EXPKEYSIG 36602BA86B8BFD3C Univention Corporate Server 4.x <packages@univention.de>
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://updates.software-univention.de/4.3/unmaintained 4.3-4/all/ Release: Die folgenden Signaturen waren ungültig: EXPKEYSIG 36602BA86B8BFD3C Univention Corporate Server 4.x <packages@univention.de>
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://updates.software-univention.de/4.3/unmaintained 4.3-4/amd64/ Release: Die folgenden Signaturen waren ungültig: EXPKEYSIG 36602BA86B8BFD3C Univention Corporate Server 4.x <packages@univention.de>
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://updates.software-univention.de/4.3/maintained 4.3-5/all/ Release: Die folgenden Signaturen waren ungültig: EXPKEYSIG 36602BA86B8BFD3C Univention Corporate Server 4.x <packages@univention.de>
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://updates.software-univention.de/4.3/maintained 4.3-5/amd64/ Release: Die folgenden Signaturen waren ungültig: EXPKEYSIG 36602BA86B8BFD3C Univention Corporate Server 4.x <packages@univention.de>
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://updates.software-univention.de/4.3/unmaintained 4.3-5/all/ Release: Die folgenden Signaturen waren ungültig: EXPKEYSIG 36602BA86B8BFD3C Univention Corporate Server 4.x <packages@univention.de>
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://updates.software-univention.de/4.3/unmaintained 4.3-5/amd64/ Release: Die folgenden Signaturen waren ungültig: EXPKEYSIG 36602BA86B8BFD3C Univention Corporate Server 4.x <packages@univention.de>
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://updates.software-univention.de/4.4/maintained 4.4-0/all/ Release: Die folgenden Signaturen waren ungültig: EXPKEYSIG 36602BA86B8BFD3C Univention Corporate Server 4.x <packages@univention.de>
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://updates.software-univention.de/4.4/maintained 4.4-0/amd64/ Release: Die folgenden Signaturen waren ungültig: EXPKEYSIG 36602BA86B8BFD3C Univention Corporate Server 4.x <packages@univention.de>
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://updates.software-univention.de/4.4/unmaintained 4.4-0/all/ Release: Die folgenden Signaturen waren ungültig: EXPKEYSIG 36602BA86B8BFD3C Univention Corporate Server 4.x <packages@univention.de>
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://updates.software-univention.de/4.4/unmaintained 4.4-0/amd64/ Release: Die folgenden Signaturen waren ungültig: EXPKEYSIG 36602BA86B8BFD3C Univention Corporate Server 4.x <packages@univention.de>
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://updates.software-univention.de/4.4/maintained 4.4-1/all/ Release: Die folgenden Signaturen waren ungültig: EXPKEYSIG 36602BA86B8BFD3C Univention Corporate Server 4.x <packages@univention.de>
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://updates.software-univention.de/4.4/maintained 4.4-1/amd64/ Release: Die folgenden Signaturen waren ungültig: EXPKEYSIG 36602BA86B8BFD3C Univention Corporate Server 4.x <packages@univention.de>
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://updates.software-univention.de/4.4/unmaintained 4.4-1/all/ Release: Die folgenden Signaturen waren ungültig: EXPKEYSIG 36602BA86B8BFD3C Univention Corporate Server 4.x <packages@univention.de>
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://updates.software-univention.de/4.4/unmaintained 4.4-1/amd64/ Release: Die folgenden Signaturen waren ungültig: EXPKEYSIG 36602BA86B8BFD3C Univention Corporate Server 4.x <packages@univention.de>
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://updates.software-univention.de/4.4/maintained 4.4-2/all/ Release: Die folgenden Signaturen waren ungültig: EXPKEYSIG 36602BA86B8BFD3C Univention Corporate Server 4.x <packages@univention.de>
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://updates.software-univention.de/4.4/maintained 4.4-2/amd64/ Release: Die folgenden Signaturen waren ungültig: EXPKEYSIG 36602BA86B8BFD3C Univention Corporate Server 4.x <packages@univention.de>
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://updates.software-univention.de/4.4/unmaintained 4.4-2/all/ Release: Die folgenden Signaturen waren ungültig: EXPKEYSIG 36602BA86B8BFD3C Univention Corporate Server 4.x <packages@univention.de>
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://updates.software-univention.de/4.4/unmaintained 4.4-2/amd64/ Release: Die folgenden Signaturen waren ungültig: EXPKEYSIG 36602BA86B8BFD3C Univention Corporate Server 4.x <packages@univention.de>
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://updates.software-univention.de/4.4/maintained 4.4-3/all/ Release: Die folgenden Signaturen waren ungültig: EXPKEYSIG 36602BA86B8BFD3C Univention Corporate Server 4.x <packages@univention.de>
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://updates.software-univention.de/4.4/maintained 4.4-3/amd64/ Release: Die folgenden Signaturen waren ungültig: EXPKEYSIG 36602BA86B8BFD3C Univention Corporate Server 4.x <packages@univention.de>
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://updates.software-univention.de/4.4/unmaintained 4.4-3/all/ Release: Die folgenden Signaturen waren ungültig: EXPKEYSIG 36602BA86B8BFD3C Univention Corporate Server 4.x <packages@univention.de>
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://updates.software-univention.de/4.4/unmaintained 4.4-3/amd64/ Release: Die folgenden Signaturen waren ungültig: EXPKEYSIG 36602BA86B8BFD3C Univention Corporate Server 4.x <packages@univention.de>

SNIP

W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://updates.software-univention.de/4.4/maintained 4.4-5/all/ Release: Die folgenden Signaturen waren ungültig: EXPKEYSIG 36602BA86B8BFD3C Univention Corporate Server 4.x <packages@univention.de>
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://updates.software-univention.de/4.4/maintained 4.4-5/amd64/ Release: Die folgenden Signaturen waren ungültig: EXPKEYSIG 36602BA86B8BFD3C Univention Corporate Server 4.x <packages@univention.de>
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://updates.software-univention.de/4.4/unmaintained 4.4-5/all/ Release: Die folgenden Signaturen waren ungültig: EXPKEYSIG 36602BA86B8BFD3C Univention Corporate Server 4.x <packages@univention.de>
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://updates.software-univention.de/4.4/unmaintained 4.4-5/amd64/ Release: Die folgenden Signaturen waren ungültig: EXPKEYSIG 36602BA86B8BFD3C Univention Corporate Server 4.x <packages@univention.de>
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://updates.software-univention.de/4.4/maintained 4.4-6/all/ Release: Die folgenden Signaturen waren ungültig: EXPKEYSIG 36602BA86B8BFD3C Univention Corporate Server 4.x <packages@univention.de>
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://updates.software-univention.de/4.4/maintained 4.4-6/amd64/ Release: Die folgenden Signaturen waren ungültig: EXPKEYSIG 36602BA86B8BFD3C Univention Corporate Server 4.x <packages@univention.de>
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://updates.software-univention.de/4.4/unmaintained 4.4-6/all/ Release: Die folgenden Signaturen waren ungültig: EXPKEYSIG 36602BA86B8BFD3C Univention Corporate Server 4.x <packages@univention.de>
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://updates.software-univention.de/4.4/unmaintained 4.4-6/amd64/ Release: Die folgenden Signaturen waren ungültig: EXPKEYSIG 36602BA86B8BFD3C Univention Corporate Server 4.x <packages@univention.de>
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://updates.software-univention.de/4.4/maintained 4.4-7/all/ Release: Die folgenden Signaturen waren ungültig: EXPKEYSIG 36602BA86B8BFD3C Univention Corporate Server 4.x <packages@univention.de>
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://updates.software-univention.de/4.4/maintained 4.4-7/amd64/ Release: Die folgenden Signaturen waren ungültig: EXPKEYSIG 36602BA86B8BFD3C Univention Corporate Server 4.x <packages@univention.de>
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://updates.software-univention.de/4.4/unmaintained 4.4-7/all/ Release: Die folgenden Signaturen waren ungültig: EXPKEYSIG 36602BA86B8BFD3C Univention Corporate Server 4.x <packages@univention.de>
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://updates.software-univention.de/4.4/unmaintained 4.4-7/amd64/ Release: Die folgenden Signaturen waren ungültig: EXPKEYSIG 36602BA86B8BFD3C Univention Corporate Server 4.x <packages@univention.de>
W: GPG-Fehler: https://updates.software-univention.de/4.4/maintained 4.4-8/all/ Release: Die folgenden Signaturen waren ungültig: EXPKEYSIG 36602BA86B8BFD3C Univention Corporate Server 4.x <packages@univention.de>
E: The repository 'https://updates.software-univention.de/4.4/maintained 4.4-8/all/ Release' is not signed.
W: GPG-Fehler: https://updates.software-univention.de/4.4/maintained 4.4-8/amd64/ Release: Die folgenden Signaturen waren ungültig: EXPKEYSIG 36602BA86B8BFD3C Univention Corporate Server 4.x <packages@univention.de>
E: The repository 'https://updates.software-univention.de/4.4/maintained 4.4-8/amd64/ Release' is not signed.
W: GPG-Fehler: https://updates.software-univention.de/4.4/unmaintained 4.4-8/all/ Release: Die folgenden Signaturen waren ungültig: EXPKEYSIG 36602BA86B8BFD3C Univention Corporate Server 4.x <packages@univention.de>
E: The repository 'https://updates.software-univention.de/4.4/unmaintained 4.4-8/all/ Release' is not signed.
W: GPG-Fehler: https://updates.software-univention.de/4.4/unmaintained 4.4-8/amd64/ Release: Die folgenden Signaturen waren ungültig: EXPKEYSIG 36602BA86B8BFD3C Univention Corporate Server 4.x <packages@univention.de>
E: The repository 'https://updates.software-univention.de/4.4/unmaintained 4.4-8/amd64/ Release' is not signed.
W: Target Packages (Packages) is configured multiple times in /etc/apt/sources.list.d/00_ucs_temporary_installation.list:5 and /etc/apt/sources.list.d/20_ucs-online-component.list:11
W: Target Packages (Packages) is configured multiple times in /etc/apt/sources.list.d/00_ucs_temporary_installation.list:6 and /etc/apt/sources.list.d/20_ucs-online-component.list:12
W: Target Packages (Packages) is configured multiple times in /etc/apt/sources.list.d/00_ucs_temporary_installation.list:7 and /etc/apt/sources.list.d/20_ucs-online-component.list:13
W: Target Packages (Packages) is configured multiple times in /etc/apt/sources.list.d/00_ucs_temporary_installation.list:8 and /etc/apt/sources.list.d/20_ucs-online-component.list:14
W: Target Packages (Packages) is configured multiple times in /etc/apt/sources.list.d/00_ucs_temporary_installation.list:9 and /etc/apt/sources.list.d/20_ucs-online-component.list:15

Does anyone have an idea what this could be?

wit best
sven

I have the same error when running apt update

Output of apt-list keys:

[...]
/etc/apt/trusted.gpg.d/univention-archive-key-ucs-3x.gpg
--------------------------------------------------------
pub   dsa1024 2011-10-05 [SC] [expired: 2018-10-03]
      3550 FB4C C61F DB88 D334  E31A 1DD6 7AFB 2CBD A4B0
uid           [ expired] Univention Corporate Server 3.x Archive Key <packages@univention.de>

/etc/apt/trusted.gpg.d/univention-archive-key-ucs-4x.gpg
--------------------------------------------------------
pub   rsa4096 2014-06-30 [SC] [expired: 2021-06-28]
      6B6E 7E32 59A9 F44F 1452  D1BE 3660 2BA8 6B8B FD3C
uid           [ expired] Univention Corporate Server 4.x <packages@univention.de>

/etc/apt/trusted.gpg.d/univention-archive-key-ucs-5x.gpg
--------------------------------------------------------
pub   rsa4096 2020-05-08 [SC] [expires: 2027-05-07]
      8321 745B B32A 82C7 5BBD  4BC2 D293 E501 A055 F562
uid           [ unknown] Univention Corporate Server 5.x <packages@univention.de>
[...]

Output of apt show univention-archive-key:


Package: univention-archive-key
Status: install ok installed
Priority: optional
Section: univention
Installed-Size: 31
Maintainer: Univention GmbH <packages@univention.de>
Architecture: all
Version: 10.0.0-2A~5.0.0.202009211852
Conffiles:
 /etc/apt/trusted.gpg.d/univention-archive-key-ucs-3x.gpg 60b9e4a51b1f7f1049cae5253bb7aafd
 /etc/apt/trusted.gpg.d/univention-archive-key-ucs-4x.gpg ded26d7afdf2856d49c135fae376cd6c
 /etc/apt/trusted.gpg.d/univention-archive-key-ucs-5x.gpg cf8f37d2fefaa532300d5952859656df
Description: UCS - Archive signature key
 This package contains the archive signing key for Univention
 Corporate Server 3.x, 4.x and 5.x.
 .
 This package is part of Univention Corporate Server (UCS),
 an integrated, directory driven solution for managing
 corporate environments. For more information about UCS,
 refer to: https://www.univention.de/
Administrator@nextcloudappl:~$ apt show univention-archive-key
Package: univention-archive-key
Version: 10.0.0-2A~5.0.0.202009211852
Status: install ok installed
Priority: optional
Section: univention
Maintainer: Univention GmbH <packages@univention.de>
Installed-Size: 31,7 kB
Download-Size: unbekannt
APT-Manual-Installed: yes
APT-Sources: /var/lib/dpkg/status
Description: UCS - Archive signature key
 This package contains the archive signing key for Univention
 Corporate Server 3.x, 4.x and 5.x.
 .
 This package is part of Univention Corporate Server (UCS),
 an integrated, directory driven solution for managing
 corporate environments. For more information about UCS,
 refer to: https://www.univention.de/
1 Like

Does anyone know if this problem has already been fixed?

The problem has been fixed, please refer to the article linked above, it has been updated with the latest information.
Administrators whose UCS systems are below version 4.4-4 errata 605 have to manually install the correct signing key on their servers, as described in the article.

Thank you very much. The update has worked