Update for UCS from 4.4 to 5.0.5 failed

First of all: hey guys. I have read and learned a lot in this forum. But currently I have problems upgrading the UCS and cannot find (enopugh) solutions to solve all of them. Thats the reason why I am writing here.

The following log is printed after i started the upgrade.

09.12.23 09:29:19.845  DEBUG_INIT
**** Starting univention-updater with parameter=['/usr/share/univention-updater/univention-updater', 'net', '--updateto', '5.0-5', '--ignoressh', '--ignoreterm']
starting net mode
--->DBG:update_available(mode=net, cdrom_mount_point=/media/cdrom, iso=None)
Checking network repository
Update to = 5.0-0
**** Downloading scripts at Sat Dec  9 09:29:23 2023
**** Starting actual update at Sat Dec  9 09:29:27 2023

Starting /tmp/tmpyvOqzs/preupaMNE8x.sh (Sa 9. Dez 09:29:27 CET 2023):

Please check the release notes carefully BEFORE updating to UCS 5.0-0:
 English version: https://docs.software-univention.de/release-notes-5.0-0-en.html
 German version:  https://docs.software-univention.de/release-notes-5.0-0-de.html

Please also consider documents of following release updates and
3rd party components.

Do you want to continue [Y/n]?
Custom preupdate script /var/lib/local-preup.sh not found
Checking adc_mapping ...                          OK
Checking adc_multiinstance_mapping ...            OK
Checking architecture ...                         OK
Checking blocking_apps ...                        Unable to cache apps
Unable to cache apps
Checking default_master_packages ...              OK
Checking disk_space ...                           OK
Checking failed_ldif ...                          OK
Checking for_postgresql94 ...                     FAIL
Checking hold_packages ...                        OK
Checking kernel ...                               OK
Checking kolab_schema ...                         OK
Checking ldap_connection ...                      OK
Checking ldap_schema ...                          65742575 /etc/ldap/slapd.conf: line 254: rootdn is always granted unlimited privileges.
65742575 /etc/ldap/slapd.conf: line 262: rootdn is always granted unlimited privileges.
# (65) Object class violation: unrecognized objectClass 'univentionVirtualMachineCloudType'
dn: cn=OpenStack,cn=CloudType,cn=Virtual Machine Manager,dc=home-domain,dc=intranet

Checking legacy_objects ...                       OK
Checking master_version ...                       OK
Checking md5_signature_is_used ...                OK
Checking min_version ...                          OK
Checking minimum_ucs_version_of_all_systems_in_domain ... FAIL
Checking old_packages ...                         FAIL
Checking overwritten_umc_templates ...            OK
Checking ox_schema ...                            OK
Checking package_status ...                       OK
Checking python_ucr_template_compatibility ...    FAIL
Checking python_ucsschool_hooks_compatibility ... OK
Checking rabbitmq_server_custom_configuration ... /tmp/tmpyvOqzs/preupaMNE8x.sh: Zeile 1173: rabbitmqctl: Kommando nicht gefunden.
Checking role_package_removed ...                 OK
Checking samba_server_schannel ...                OK
Checking samba_tdb_size ...                       OK
Checking sha1_signature_is_used ...               OK
Checking slapd_on_member ...                      OK
Checking ssh ...                                  OK
Checking system_date_too_old ...                  OK
Checking system_role ...                          OK
Checking term ...                                 OK
Checking tls_public_key_size ...                  OK
Checking tls_public_key_size_ucs-sso ...          OK
Checking ucsschool_computerroom_compatibility ... OK
Checking usr_mountpoint ...                       OK
Checking valid_machine_credentials ...            OK

The system can not be updated to UCS 5.0 due to the following reasons:

The following UCR templates are not compatible with Python 3:
See <https://help.univention.com/t/17948> for information on how to proceed with each template.

The update to 5.0 is currently not possible,
because the following Apps are not available for UCS 5.0:
 * Network monitoring (Nagios)

WARNING: PostgreSQL-9.4 is no longer supported by UCS-5.0 and must be migrated to
         a newer version of PostgreSQL. See https://help.univention.com/t/8075 for
         more details.

	This check can be disabled by setting the UCR variable 'update50/ignore_postgresql94' to 'yes'.
	But be aware that this is not recommended!

WARNING: The following packages from UCS-4 are still installed, which are no longer supported with UCS-5:

Use "univention-remove --purge" with the packages as following arguments to remove them

The following extensions are incompatible with UCS 5.0:
	cn=66oxforucs,cn=ldapacl,cn=univention,dc=home-domain,dc=intranet: [unspecified..unspecified)
	cn=50_ox,cn=udm_syntax,cn=univention,dc=home-domain,dc=intranet: [unspecified..unspecified)
	cn=oxAccess,cn=udm_hook,cn=univention,dc=home-domain,dc=intranet: [unspecified..unspecified)
	cn=oxGroupHook,cn=udm_hook,cn=univention,dc=home-domain,dc=intranet: [unspecified..unspecified)
	cn=oxUserDefaults,cn=udm_hook,cn=univention,dc=home-domain,dc=intranet: [unspecified..unspecified)
	cn=oxmail/oxcontext,cn=udm_module,cn=univention,dc=home-domain,dc=intranet: [unspecified..unspecified)
	cn=oxmail/oxdomain,cn=udm_module,cn=univention,dc=home-domain,dc=intranet: [unspecified..unspecified)
	cn=oxmail/oxfetchmailmulti,cn=udm_module,cn=univention,dc=home-domain,dc=intranet: [unspecified..unspecified)
	cn=oxmail/oxfetchmailsingle,cn=udm_module,cn=univention,dc=home-domain,dc=intranet: [unspecified..unspecified)
	cn=oxmail/oxfolder,cn=udm_module,cn=univention,dc=home-domain,dc=intranet: [unspecified..unspecified)
	cn=oxmail/oxlists,cn=udm_module,cn=univention,dc=home-domain,dc=intranet: [unspecified..unspecified)
	cn=oxmail/oxmail,cn=udm_module,cn=univention,dc=home-domain,dc=intranet: [unspecified..unspecified)
	cn=oxresources/oxresources,cn=udm_module,cn=univention,dc=home-domain,dc=intranet: [unspecified..unspecified)

Error: Update aborted by pre-update script of release 5.0-0

Once I tried the OXMail, which probably leads to one of the problems. But I was not able to delete those yet. Maybe you guys can help me with that?

I already tried installing a new system and doing a domain takeover but that failed and due to that reason i am trying to do the upgrade (again).

So do you guys have any idea how i can solve (all) those problems?

Thanks in adavance.

If you do not need OXMail anymore and there are leftovers, have a look at this thread: Upgrade 5.0 fails due to leftovers from uninstalled ox-appsuite - #2 by Best

Thanks for your response. I already executed that, but that did not change much. Still the same error. Any other ways i can get rid of those entrys?

Anyone else some ideas?