Update auf v4.1-0 funktioniert nicht

german

#1

Ich versuche über die Weboberfläche das UCS-Update auf v4.1-0 (von v4.0-4 errate 385) durchzuführen.
Es schlägt jedoch wiederholt fehl.

27.01.16 11:12:18.529 DEBUG_INIT
**** Starting univention-updater with parameter=[’/usr/share/univention-updater/univention-updater’, ‘net’, ‘–updateto’, ‘4.1-0’, ‘–ignoressh’, ‘–ignoreterm’]
Version=4.0
Patchlevel=4
starting net mode
—>DBG:update_available(mode=net, cdrom_mount_point=/cdrom, iso=None)
Checking network repository
Update to = 4.1-0
**** Downloading scripts at Wed Jan 27 11:12:19 2016
**** Starting actual update at Wed Jan 27 11:12:21 2016
Running preup.sh script
Wed Jan 27 11:12:21 CET 2016

HINT:
Please check the release notes carefully BEFORE updating to UCS 4.1-0:
English version: docs.software-univention.de/rel … -0-en.html
German version: docs.software-univention.de/rel … -0-de.html

Please also consider documents of following release updates and
3rd party components.

Do you want to continue [Y/n]?
Custom preupdate script /var/lib/local-preup.sh not found
WARNING: PostgreSQL-8.4 is no longer supported by UCS-4.1 and must be migrated to
a newer version of PostgreSQL. See sdb.univention.de/1292 for
more details.
Error: Update aborted by pre-update script of release 4.1-0

Das Upgrade habe ich durchgeführt (sdb.univention.de/1292)

Kann jemand helfen? Vielen Dank.


Postgresql startet nicht mehr
#2

Was ist die Ausgabe von

dpkg-query -W -f '${Status}' postgresql-8.4

#3

Die Ausgabe ist: install ok installed

Ich habe dpkg -P postgresql-8.4 noch nicht ausgeführt.

service postgresql status bringt folgende Ausgabe:
Running clusters: 9.1/main


#4

Dann muß das natürlich vorher ausgeführt werden. Alternativ kann natürlich auch die UCR-Variable update41/ignore_postgresql84 auf true gesetzt werden. Das würde ich aber nicht empfehlen.


#5

Dankeschön, nach Ausführung von
dpkg -P postgresql-8.4
und einem Neustart startet das Update.

Ich war der irrigen Ansicht, das es optional ist obigen Befehl auszuführen.