Update auf 4.2-2 nicht möglich

ucs-4-1
upgrade

#1

Ich möchte meine Domäne heute auf 4.2-2 upgraten. Aktuell ist auf dem DC 4.1-5 485 drauf.

Zusätzlich ist noch Kopano und KVM installiert. Den Guest im KVM habe ich angehalten, damit es zu keiner LIVE-Aktuallisierung kommt.

Leider wird aber das Update nicht ausgeführt. Eine Fehlermeldung ist nicht erkennbar für mich. Hier der Log-Bereich:

22.11.17 14:34:28.364 DEBUG_INIT
**** Starting univention-updater with parameter=['/usr/share/univention-updater/univention-updater', 'net', '--updateto', '4.2-2', '--ignoressh', '--ignoreterm']
Version=4.1
Patchlevel=5
starting net mode
--->DBG:update_available(mode=net, cdrom_mount_point=/media/cdrom, iso=None)
Checking network repository
Update to = 4.2-0
**** Downloading scripts at Wed Nov 22 14:34:34 2017
**** Starting actual update at Wed Nov 22 14:34:38 2017
Running preup.sh script
Mi 22. Nov 14:34:38 CET 2017

HINT:
Please check the release notes carefully BEFORE updating to UCS 4.2-0:
English version: https://docs.software-univention.de/release-notes-4.2-0-en.html
German version: https://docs.software-univention.de/release-notes-4.2-0-de.html

Please also consider documents of following release updates and
3rd party components.

Do you want to continue [Y/n]?
Trying to detect if migration to dependency based boot will fail:
WARNING: Removed, but configured, package zarafa-dagent left /etc/init.d/zarafa-dagent behind
WARNING: Removed, but configured, package zarafa-gateway left /etc/init.d/zarafa-gateway behind
WARNING: Removed, but configured, package zarafa-ical left /etc/init.d/zarafa-ical behind
WARNING: Removed, but configured, package zarafa-licensed left /etc/init.d/zarafa-licensed behind
WARNING: Removed, but configured, package zarafa-monitor left /etc/init.d/zarafa-monitor behind
WARNING: Removed, but configured, package zarafa-presence left /etc/init.d/zarafa-presence behind
WARNING: Removed, but configured, package zarafa-server left /etc/init.d/zarafa-server behind
WARNING: Removed, but configured, package zarafa-spooler left /etc/init.d/zarafa-spooler behind
WARNING: Removed, but configured, package zarafa-webmeetings left /etc/init.d/zarafa-webmeetings behind
insserv: warning: script 'K93univention-system-setup-boot' missing LSB tags and overrides
insserv: warning: script 'univention-system-setup-boot-prepare' missing LSB tags and overrides
insserv: warning: script 'univention-system-setup-boot' missing LSB tags and overrides
insserv: warning: script 'klogd' missing LSB tags and overrides
insserv: remove service /etc/init.d/../rc0.d/K20kopano-spooler
insserv: enable service ../init.d/kopano-spooler -> /etc/init.d/../rc0.d/K01kopano-spooler
insserv: remove service /etc/init.d/../rc0.d/S30rsyslog
....
insserv: remove service /etc/init.d/../rcS.d/S20qemu-kvm
insserv: enable service ../init.d/qemu-kvm -> /etc/init.d/../rcS.d/S03qemu-kvm
insserv: dryrun, not creating .depend.boot, .depend.start, and .depend.stop
insserv --dryrun: OK
Aborting, because the update would likely fail.
Please check and fix the aforementioned issues.
(To ignore, set the UCRV variable update42/ignore_insserv to yes)
Error: Update aborted by pre-update script of release 4.2-0

Was ich merkwürdig finde, dass er bei den anfänglichen WARNINGS von ZARAFA spricht - ich aber definitiv Kopano benutze (Zarafa wurde nach Kopano migriert, nachdem die Scripte für UCS vorhanden waren)


Update UCS 4.1-5 -> UCS 4.2-x / Zarafa
#2

Hallo,

da die Initskripte für Zarafa unter /etc/ liegen, werden sie bei einer normalen Deinstallation von Paketen nicht mit entfernt. Sie sollten nun sicherstellen, dass keine Zarafa Pakete mehr installiert sind, bzw. dass sie als deinstalliert (rc) markiert sind, zum Beispiel so

dpkg -l | grep zarafa
rc  zarafa-server ...
...

Dann können die übrig gebliebenen Initskripte unter /etc/init.d/, die in Ihrer Ausgabe mit WARNING: genannt werden, gelöscht werden. Das UCS Update sollte an der Stelle dann nicht mehr abbrechen.


#3

Vielen Dank für die schnelle Rückinfo. Hier die Ausgabe des dpkg:

root@ucs002090:~# dpkg -l | grep zarafa
ii  kopano4ucs-migrate-zarafa                           1.2.11                                       all
ii  libgsoap-zarafa-2-8                                 2.8.22-26.1                                  amd64        Runtime libraries for gSOAP
ii  libical-zarafa1                                     1.0.1-1                                      amd64        iCalendar library implementation in C (runtime)
ii  libvmime-zarafa7-0                                  0.9.1+svn603-17.1                            amd64        a C++ mail library (runtime library)
ii  libzarafa-archiver-core0                            7.2.4.29-99.1                                amd64        Library with shared ZCP archiver functionality
ii  libzarafa-archiver0                                 7.2.4.29-99.1                                amd64        Library with shared ZCP archiver functionality
ii  libzarafa-server0                                   7.2.4.29-99.1                                amd64        Zarafa Server component library
ii  libzarafa-soapclient0                               7.2.4.29-99.1                                amd64        Zarafa component library for SOAP server-side handlers
ii  libzarafa-soapserver0                               7.2.4.29-99.1                                amd64        Zarafa component library for SOAP client-side handlers
ii  libzarafasync0                                      7.2.4.29-99.1                                amd64        Routines for synchronization in ZCP
ii  python-zarafa                                       7.2.4.29-99.1                                all          Zarafa bindings for Python
rc  zarafa-backup                                       7.2.4.1                                      amd64        Brick-level backup and restore tools for the Zarafa Collaboration Platform
rc  zarafa-backup-plus                                  7.2.4.29-99.1                                amd64        Utility to back up and restore Zarafa stores
rc  zarafa-client                                       7.2.4.29-99.1                                amd64        Zarafa client library
rc  zarafa-common                                       7.2.4.29-99.1                                amd64        Shared files between ZCP services.
rc  zarafa-contacts                                     7.2.4.29-99.1                                amd64        MAPI provider adding contact folders in the addressbook
rc  zarafa-dagent                                       7.2.4.29-99.1                                amd64        E-Mail Delivery Agent for the Zarafa Collaboration Platform
rc  zarafa-gateway                                      7.2.4.29-99.1                                amd64        POP3 and IMAP Gateway for the Zarafa Collaboration Platform
rc  zarafa-ical                                         7.2.4.29-99.1                                amd64        ICal and CalDAV Gateway for the Zarafa Collaboration Platform
ii  zarafa-lang                                         7.2.4.29-99.1                                all          Translations for Zarafa components
rc  zarafa-libarchiver                                  7.1.14-51822                                 amd64        Library with shared ZCP archiver functionality
rc  zarafa-libs                                         7.1.14-51822                                 amd64        Conversion libraries between Open Standards and MAPI
rc  zarafa-licensed                                     7.2.4.1                                      amd64        License Daemon for the Zarafa Collaboration Platform
rc  zarafa-monitor                                      7.2.4.29-99.1                                amd64        Quota Monitor for the Zarafa Collaboration Platform
rc  zarafa-presence                                     7.2.4.29-99.1                                amd64        zarafa presence daemon
rc  zarafa-search                                       7.1.14-51822                                 amd64        Indexed search engine for the Zarafa Collaboration Platform
ii  zarafa-search-plus                                  7.2.4.29-99.1                                amd64        Zarafa indexer
rc  zarafa-server                                       7.2.4.29-99.1                                amd64        Server component for the Zarafa Collaboration Platform
rc  zarafa-spooler                                      7.2.4.29-99.1                                amd64        E-mail Spooler for the Zarafa Collaboration Platform
rc  zarafa-utils                                        7.2.4.29-99.1                                amd64        Admin command-line utils for the Zarafa Collaboration Platform
rc  zarafa-webaccess                                    7.1.14-51822                                 all          A web interface for the Zarafa Collaboration Platform
rc  zarafa-webapp                                       2.2.1.43-199.1                               all          New and improved WebApp for the Zarafa Collaboration Platform
rc  zarafa-webapp-desktopnotifications                  1.0.31-28.2                                  all          Zarafa WebApp Desktop notifications plugin
rc  zarafa-webapp-files                                 2.2.1.43-199.1                               all          Zarafa WebApp files plugin
rc  zarafa-webapp-plugins-delayeddelivery               1.0.22-70.1                                  all          Zarafa WebApp Delayed delivery plugin
rc  zarafa-webapp-plugins-filepreviewer                 1.0.30-59.2                                  all          Zarafa File previewer plugin
rc  zarafa-webapp-plugins-mdm                           1.1.0-49.1                                   all          Zarafa WebApp MDM plugin
rc  zarafa-webapp-plugins-meetings                      1.3.1457008627.ed0b3ea                       all          Zarafa WebApp Meetings Plugin
rc  zarafa-webapp-plugins-smime                         1.0                                          all          Zarafa WebApp S/MIME plugin
rc  zarafa-webapp-plugins-spell                         1.0.22-32.1                                  all          Zarafa WebApp Spellchecker plugin
rc  zarafa-webapp-titlecounter                          2.2.1.43-199.1                               all          Zarafa WebApp Titlecounter plugin
rc  zarafa-webmeetings                                  0.24.13-1                                    amd64        Zaraf Webmeetings audio/video call and
rc  zarafa4ucs                                          7.2.1000-11.114.201606081402                 all          Zarafa4ucs integration package for Univention Corporate Server
ii  zarafa4ucs-lib                                      7.2.1000-12.115.201607121638                 all          Library package for common Zarafa4ucs functions
ii  zarafa4ucs-schema                                   7.2.1000-11.114.201606081402                 all          LDAP schema for the Zarafa4ucs integration
ii  zarafa4ucs-udm                                      7.2.1000-11.114.201606081402                 all          UDM extensions for the Zarafa4ucs integration
rc  zarafa4ucs-webapp                                   7.2.1000-12.115.201607121638                 all          Zarafa4ucs zarafa-webapp integration package for Univention Corporate Server

D.h., dass ich dann die ganzen Pakete, die mit “ii” gekennzeichnet sind, erstmal deinstallieren muss/kann?


Update UCS 4.1-5 -> UCS 4.2-x / Zarafa
#4

Zarafa scheint an der Stelle korrekt deinstalliert zu sein, auch wenn noch ein paar Bibliotheken übrig geblieben sind. Die könnte man jetzt vermutlich deinstallierenDie wichtigen Dienste sind jedenfalls deinstalliert, wie man am rc am Anfang der Zeile sieht. Bei den Zarafa (und Kopano) Paketen kann zum Glück recht einfach eine Zuordnung von Iniitskript und Dienst/Paket vorgenommen werden.
Ich würde jetzt die Zarafa Initskripte aus /etc/init.d entfernen, Snapshot/Backup erstellen, und dann das UCS 4.2 Update starten.


#5

Vielen Dank. Irgendwie will es nicht werden :wink:

ERROR: An external repository for the Kopano Apps is currently configured.
There are known issues when updating to UCS 4.2 and using software
from the Kopano software repository.
The update is blocked while Kopano and Univention are working
on a solution.
Error: Update aborted by pre-update script of release 4.2-0

Wahrscheinlich lass ich die Umstellung dann einfach doch :frowning:


#6

Hallo,
nachdem ja Version 4.1-4 nicht mehr unterstützt wird und sich weder 4.1-5 (404er vom Kopano Server, da Verzeichnis 4.0 nicht existiert) noch 4.2-x (nicht unterstützt, da Kopano Repo verwendet), frage ich mich tatsächlich, ob diese ehemals Standard-Konfiguration seitens UCS und Kopano überhaupt noch gepflegt wird.
Es muss doch möglich sein, ein Upgrade ohne eine derartige Akrobatik durchführen zu können.
BG,
TP


#7

Ja, das würde ich mir jetzt auch wünschen. Denn so eine Vorgehensweise ist sehr fehlerträchtig und kann zu unvorhersehbaren Konstellationen führe, die dann das System unbrauchbar machen. Wenn die User dann keine Mails mehr haben oder auf unbestimmt Zeit drauf warten müssen, dann ist das für mich ein Grund, noch etwas zu warten, ob es einen “sicheren Weg” gibt :wink:


#8

Der Vollständigkeit halber erwähne ich die Antwort aus dem anderen Thread hier auch noch einmal: