Update auf 3.1-1 (ct-Edition): Kein php5-sqlite mehr ?!?

german

#1

Hallo,

habe eben das Update und anschließend einen Neustart durchgeführt. Hat soweit alles geklappt, nur wurde das Paket php5-sqlite entfernt. Ich kann es auch nicht mehr installieren:

[code]apt-get install php5-sqlite
Paketlisten werden gelesen… Fertig
Abhängigkeitsbaum wird aufgebaut
Statusinformationen werden eingelesen… Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
php5-sqlite : Hängt ab von: php5-common (= 5.3.3-7.176.201211121028) aber 5.3.3-7.177.201303141147 soll install
iert werden
E: Beschädigte Pakete[/code]

Zusätzlich kommt noch folgender Fehler von Cron:

PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20090626/pdo_sqlite.so' - /usr/lib/php5/20090626/pdo_sqlite.so: cannot open shared object file: No such file or directory in Unknown on line 0 PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20090626/sqlite.so' - /usr/lib/php5/20090626/sqlite.so: cannot open shared object file: No such file or directory in Unknown on line 0 PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20090626/sqlite3.so' - /usr/lib/php5/20090626/sqlite3.so: cannot open shared object file: No such file or directory in Unknown on line 0

Diese sqlite-Sachen gibts natürlich auch nicht mehr weil das Paket entfernt wurde. Wie kann ich das beheben?

Markus


#2

Hallo,

hast du das Paket evtl. ursprünglich aus dem unmaintained Bereich installiert und den nicht mehr aktiviert? Das würde die Abhängigkeit zu einer älteren php5-common Version erklären.

emg


#3

[quote=“emg”]Hallo,

hast du das Paket evtl. ursprünglich aus dem unmaintained Bereich installiert und den nicht mehr aktiviert? Das würde die Abhängigkeit zu einer älteren php5-common Version erklären.

emg[/quote]

Exakt, der unmaintained Bereich ist aber nach wie vor aktiviert. Das war erst auch meine Vermutung, dass dass Repo rausgefallen wäre durch das Update.


#4

In der Übersicht zu den Repository-Einstellungen steht folgendes drin:


Mich macht der Status stutzig: “Nicht gefunden”! Das ist doch bestimmt nicht richtig. In den Einstellungen ist folgendes drin:


Kann da mal jemand bei sicht schauen ob das so richtig ist? Denke mal nicht, dass das richtig ist.

Markus


#5

Keiner da, der mal schnell in die Repsoitory-Einstellungen bei sich kucken kann?


#6

Hallo,

die Einstellungen sind so korrekt - es wird momentan kein 3.1-1-errata Repository gefunden, da noch kein 3.1-1-errata existiert.
Bezüglich Ihres eigentlichen Problems:
Prüfen Sie bitte einmal, ob die Datei /etc/apt/sources.list.d/15_ucs-online-version.list entsprechende Einträge für 3.1-1 Unmaintained enthält.

Mit freundlichen Grüßen,
Tim Petersen


#7

Hallo,

es sind keine Einträge für ein 3.1-1er Unmaintained Repository vorhanden. Auf dem Server (updates.software-univention.de) finde ich dazu auch gar kein entsprechendes Repo. Also gibts für diesen Zweig (3.1-1) auch kein unmaintained Repo, was wiederum mein Abhängigkeitsproblem erklärt.

Und nu?


#8

Hallo,

kam es hier unter Umständen eventuell zu temporären Problemen? Momentan kann ich das geschilderte Verhalten nicht nachvollziehen und kann das Repository erreichen.
Bitte führen Sie einmal die folgenden Schritte aus:

ucr commit /etc/apt/sources.list.d/* apt-get update

und prüfen die Quelldateien bzw. die Installation anschließend erneut.

Mit freundlichen Grüßen,
Tim Petersen


#9

Hallo Herr Petersen,

das hat geholfen. Wieso versteh ich zwar nicht, ich hatte das Kommando heut schon mal ausgeführt und da hatte es nichts gebracht.

Hauptsache es geht wieder, vielen Dank für Ihre Hilfe.

MfG