Updarde Fehler Kopano WebApp 3.5.5.2276 --> 3.5.14.2539

Hallo - ich habe den UCS Server auf die aktuelle Version gepatched (4.4-4 errata602) und wollte anschließend auch die Kopano WebApp auf den neusten Stand bringen.

Folgende Meldung habe ich erhalten (Update via Web-Interface im UCS):

grafik

grafik

Wenn ich die Meldung richtig verstehe, dann ist das Paket kopano4ucs-webapp der Grund warum sich die Software nicht aktualisieren lässt.

Ist der Fehler bereits bekannt?

Freue mich auf das Feedback.

Stay Save

Hallo @Pepe,

ich kann den Fehler hier auf einem älteren Testsystem (welches ursprünglich mit 4.3.x installiert wurde) leider nicht reproduzieren:

root@ucs ~
$ dpkg -l | grep gettext
ii  gettext-base                                        0.19.8.1-2+deb9u1                                                   amd64        GNU Internationalization utilities for the base system
ii  liblocale-gettext-perl                              1.07-3+b1                                                           amd64        module using libc functions for internationalization in Perl
ii  python-polib                                        1.0.8-1                                                             all          Python library to parse and manage gettext catalogs

root@ucs ~
$ dpkg -l | grep kopano4ucs
ii  kopano4ucs                                          1.6.2                                                               all          Kopano4ucs integration package for Univention Corporate Server
ii  kopano4ucs-app                                      1.6.2                                                               all          Package for UCS app specific logic            
ii  kopano4ucs-lib                                      1.6.6                                                               all          Library package for common Kopano4ucs functions
ii  kopano4ucs-schema                                   1.6.2                                                               all          LDAP schema for the Kopano4ucs integration
ii  kopano4ucs-udm                                      1.6.2                                                               all          UDM extensions for the Kopano4ucs integration
ii  kopano4ucs-webapp                                   1.6.6                                                               all          Kopano4ucs kopano-webapp integration package for Univention Corporate Server
ii  kopano4ucs-z-push                                   1.6.2                                                               all          Meta package for Z-Push installation          

root@ucs ~
$ dpkg -l | grep kopano4ucs-webapp                                                                                                                                                     
ii  kopano4ucs-webapp                                   1.6.6                                                               all          Kopano4ucs kopano-webapp integration package for Univention Corporate Server
root@ucs ~
$ dpkg -l | grep gettext
ii  gettext-base                                        0.19.8.1-2+deb9u1                                                   amd64        GNU Internationalization utilities for the base system
ii  liblocale-gettext-perl                              1.07-3+b1                                                           amd64        module using libc functions for internationalization in Perl
ii  python-polib                                        1.0.8-1                                                             all          Python library to parse and manage gettext catalogs

root@ucs ~
$ univention-app info
UCS: 4.4-4 errata602
Installed: kopano-core=8.7.1.0-1 kopano-webapp=3.5.14.2539 kopano-webmeetings=3.0.1.100 letsencrypt=1.2.2-8 self-service=4.0 self-service-backend=4.0 z-push-kopano=2.4.5 4.3/kopano-meet=2.1.0_0-3 4.3/openid-connect-provider=2.0-konnect-0.33

Vielen Dank für die Rückmeldung. Ich habe gestern auch noch einmal die letzten Updates von UCS nachgezogen - also von der 602 auf die 613. Das Ergebnis bleibt jedoch unverändert. Wenn man via Web einen System-Check macht, erhält man keine Fehlermeldungen.

Ich habe die oben abgesetzten Befehle ebenfalls auf meinem System gestartet. Hier die Ergebnisse:

# dpkg -l | grep gettext
ii  gettext-base                                        0.19.8.1-2+deb9u1                                                   amd64        GNU Internationalization utilities for the base system
ii  liblocale-gettext-perl                              1.07-3+b1                                                           amd64        module using libc functions for internationalization in Perl
ii  php-gettext                                         1.0.12-0.1                                                          all          transitional dummy package for php-php-gettext
ii  php-php-gettext                                     1.0.12-0.1                                                          all          read gettext MO files directly, without requiring anything other than PHP
ii  python-polib                                        1.0.8-1                                                             all          Python library to parse and manage gettext catalogs
# dpkg -l | grep kopano4ucs
ii  kopano4ucs-lib                                      1.5.33                                                              all          Library package for common Kopano4ucs functions
ii  kopano4ucs-webapp                                   1.5.33                                                              all          Kopano4ucs kopano-webapp integration package for Univention Corporate Server
# dpkg -l | grep kopano4ucs-webapp
ii  kopano4ucs-webapp                                   1.5.33                                                              all          Kopano4ucs kopano-webapp integration package for Univention Corporate Server
# dpkg -l | grep gettext
ii  gettext-base                                        0.19.8.1-2+deb9u1                                                   amd64        GNU Internationalization utilities for the base system
ii  liblocale-gettext-perl                              1.07-3+b1                                                           amd64        module using libc functions for internationalization in Perl
ii  php-gettext                                         1.0.12-0.1                                                          all          transitional dummy package for php-php-gettext
ii  php-php-gettext                                     1.0.12-0.1                                                          all          read gettext MO files directly, without requiring anything other than PHP
ii  python-polib                                        1.0.8-1                                                             all          Python library to parse and manage gettext catalogs
# univention-app info
UCS: 4.4-4 errata613
Installed: kopano-webapp=3.5.5.2276
Upgradable: kopano-webapp

Tja - was kann ich tun, damit auch ich die WebApp auf den aktuelleren Stand bekomme.

PS: Das System ist Standard ausgesetzt worden und wird auch nur über die angebotenen Patche via Web-Management aktualisiert. Der Kopano-Server (Core) selber, läuft auf einem anderen Server (Patch-Level ebenfalls 602).

Vielen Dank vorab

Hallo @Pepe,

sofern eine Subskription vorhanden ist empfehle ich das Kontaktieren von entweder des Kopano oder Univention Supports.

Ein beliebter Vorschlag hier im Forum ist eine App zu deinstallieren und dann erneut zu installieren. Alternativ könnte im appcenter.log für eine Aussagekräftigere Fehlermeldung gesucht werden oder mittels Debian bordmitteln die Abhängigkeitskette untersucht werden. Dierek von gettext scheint die derzeit installierte Version von kopano4ucs-webapp jedenfalls nicht abzuhängen.

Irgendwas muss aber anders sein, sonst hätten hier noch andere das Problem.