Unix extension löschen

german

#1

Hallo,
Ich möchte nicht die “unix Erweiterungen” benutzen. Sie sind öfter mehr ein Problem als eine Lösung.
Man musst nicht direk die Datei «smb.conf» arbeiten. Wo musst man den Parameter «unix extensions=no» einstellen?

Zwei Dateien “/etc/samba/local.conf” und “/etc/samba/local.config.conf” scheint benutzbar. Ist est möglich eine
dieser Datei zu benutzen?

Vielen Danken für ihre Hilfe,

Freundliche Grüsse,

rhino64


#2

Sehr geehrter Herr Aubord,

wie in dem Supportticket beschrieben die wichtigsten Informationen:

Prüfung der Werte (an einem Beispiel in meiner Testumgebung):

root@ucs-411-master:~# testparm -s -v | grep unix\ extens
Load smb config files from /etc/samba/smb.conf
rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
Processing section “[netlogon]”
Processing section “[sysvol]”
Processing section “[homes]”
Processing section “[printers]”
Processing section “[print$]”
Processing section “[Admintest]”
Loaded services file OK.
‘winbind separator = +’ might cause problems with group membership.

Server role: ROLE_ACTIVE_DIRECTORY_DC

unix extensions = Yes

Setzen der Extensions:

root@ucs-411-master:~# ucr set “samba/global/options/unix extensions”=no

Prüfung der Werte:

root@ucs-411-master:~# testparm -s -v | grep unix\ extens
Load smb config files from /etc/samba/smb.conf
rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
Processing section “[netlogon]”
Processing section “[sysvol]”
Processing section “[homes]”
Processing section “[printers]”
Processing section “[print$]”
Processing section “[Admintest]”
Loaded services file OK.
‘winbind separator = +’ might cause problems with group membership.

Server role: ROLE_ACTIVE_DIRECTORY_DC

unix extensions = No

Mit freundlichem Gruß,
Jens Thorp-Hansen