Univention-upgrade

german

#1

Update auf VErsion ucs 4.1.2 schlägt fehl.
Folgendes steht im Logfile:

ustom preupdate script /var/lib/local-preup.sh not found
Purging old kernel… Purging old kernel… dpkg: Warnung: Version »2.6.32-45~ucs1.64.201206011416
Config-2.6.32-45~ucs1.64.201206011416« hat falsche Syntax: ungültiges Zeichen in Versionsnummer
done
done
Checking for space on /var/cache/apt/archives: OK
Checking for space on /boot: failed
ERROR: Not enough space in /boot, need at least 50 MB.
This may interrupt the update and result in an inconsistent system!
If neccessary you can skip this check by setting the value of the
config registry variable update41/checkfilesystems to “no”.
But be aware that this is not recommended!

Error: Update aborted by pre-update script of release 4.1-2
exitcode of univention-updater: 1
ERROR: update failed. Please check /var/log/univention/updater.log

Starting univention-upgrade. Current UCS version is 4.1-1 errata158

die pruneoldkernel variablen habe ich gesetzt!

in meinem bootverzeichnis stehen folgende kernel:

rwxr-xr-x 32 root root 4096 Okt 24 06:13 …/
-rw-r–r-- 1 root root 318 Okt 21 06:24 boot.msg
-rw-r–r-- 1 root root 146785 Feb 15 2016 config-3.10.0-ucs175-amd64
-rw-r–r-- 1 root root 158137 Mai 30 15:45 config-3.16.0-ucs195-amd64
-rw-r–r-- 1 root root 155845 Dez 16 2014 config-3.16-ucs109-amd64
-rw-r–r-- 1 root root 129103 Mai 13 2014 config-3.2.0-ucs61-amd64
-rw-r–r-- 1 root root 167319 Okt 27 2015 config-4.1.0-ucs153-amd64
-rw-r–r-- 1 root root 167319 Feb 11 2016 config-4.1.0-ucs174-amd64
drwxr-xr-x 5 root root 7168 Okt 24 06:18 grub/
-rw-r–r-- 1 root root 17626754 Aug 17 2015 initrd.img-2.6.32-ucs64-amd64
-rw-r–r-- 1 root root 24063950 Okt 20 06:38 initrd.img-3.10.0-ucs175-amd64
-rw-r–r-- 1 root root 29038054 Okt 21 06:26 initrd.img-3.16.0-ucs195-amd64
-rw-r–r-- 1 root root 28937745 Okt 21 05:29 initrd.img-3.16-ucs109-amd64
-rw-r–r-- 1 root root 19746857 Aug 17 2015 initrd.img-3.2.0-ucs61-amd64
-rw-r–r-- 1 root root 29149944 Okt 21 06:32 initrd.img-4.1.0-ucs153-amd64
-rw-r–r-- 1 root root 28509272 Okt 24 06:20 initrd.img-4.1.0-ucs174-amd64
drwx------ 2 root root 12288 Apr 30 2013 lost+found/
-rw-r–r-- 1 root root 176764 Feb 27 2015 memtest86+.bin
-rw-r–r-- 1 root root 178944 Feb 27 2015 memtest86+_multiboot.bin
-rw-r–r-- 1 root root 2318144 Feb 15 2016 System.map-3.10.0-ucs175-amd64
-rw-r–r-- 1 root root 2693513 Mai 30 15:45 System.map-3.16.0-ucs195-amd64
-rw-r–r-- 1 root root 2682560 Dez 16 2014 System.map-3.16-ucs109-amd64
-rw-r–r-- 1 root root 2081055 Mai 13 2014 System.map-3.2.0-ucs61-amd64
-rw-r–r-- 1 root root 2851250 Okt 27 2015 System.map-4.1.0-ucs153-amd64
-rw-r–r-- 1 root root 2851820 Feb 11 2016 System.map-4.1.0-ucs174-amd64
-rw-r–r-- 1 root root 3278400 Feb 15 2016 vmlinuz-3.10.0-ucs175-amd64
-rw-r–r-- 1 root root 4158528 Mai 30 15:43 vmlinuz-3.16.0-ucs195-amd64
-rw-r–r-- 1 root root 4162448 Mai 31 11:46 vmlinuz-3.16.0-ucs195-amd64.efi.signed
-rw-r–r-- 1 root root 4132400 Dez 16 2014 vmlinuz-3.16-ucs109-amd64
-rw-r–r-- 1 root root 4136320 Dez 17 2014 vmlinuz-3.16-ucs109-amd64.efi.signed
-rw-r–r-- 1 root root 2961136 Mai 13 2014 vmlinuz-3.2.0-ucs61-amd64
-rw-r–r-- 1 root root 4365360 Okt 27 2015 vmlinuz-4.1.0-ucs153-amd64
-rw-r–r-- 1 root root 4369280 Okt 27 2015 vmlinuz-4.1.0-ucs153-amd64.efi.signed
-rw-r–r-- 1 root root 4367536 Feb 11 2016 vmlinuz-4.1.0-ucs174-amd64
-rw-r–r-- 1 root root 4371456 Feb 11 2016 vmlinuz-4.1.0-ucs174-amd64.efi.signed

wie kann ich jetzt platz schaffen??

Gruß Henry


#2

Das sieht für mich auf den ersten Blick so aus, als hätte jemand mal den 2.6.32-45 manuell gelöscht. Also nur die Dateien in /boot. Das System denkt noch, dass das Paket installiert ist.
Kann das sein?


#3

Kann ich nicht nachvollziehen. Das liegt vor meiner Zeit.
Es muss aber doch möglich sein trotzdem Platz wieder freizugeben. Oder?


#4

Ja, Sie können die nicht benötigten Kernel mit “apt-get remove --purge …” entfernen.
Das preup.sh Skript macht bei gesetzter pruneoldkernel-Variable im Prinzip auch nichts anderes.

Die Inkonsistenz sollte man aber beheben. Das Problem wird kaum von selbst verschwinden. Wie, hängt vom Paketzustand ab.