Univention Upgrade from 4.2-5 errata631 fails (OX LDAP)

I tried to Upgrade Univention over command line, so i can check the logs and why it always fails.
So here some information:

univention-app info
UCS: 4.2-5 errata631
App Center compatibility: 4
Installed: adconnector=11.0 cups=1.7.5 mailserver=11 open-xchange-text=7.8.4-ucs1 oxseforucs=7.8.4-ucs12 radius=4.0 samba-memberserver=4.6
Upgradable:

After continuing this Question:
grafik

The error in the /var/log/univention/updater.log says:
ERROR: The OX Appsuite LDAP schema registration is incorrect.

OX-AppSuite seems to be version 7.8.4

Found some issue in the community forum with the number 9440 (Update to OX App Suite 7.10.0 for UCS 4.3).
There is a point which says that “the domain controller master must be updated to version UCS 4.3-1”, but there is no USC-Domain-Master, the server is just a normal mailserver which is ad-connected to a samba-ad-domain.

Can anybody maybe help me with this issue?

Hi,
even if installed as a member in an AD domain the UCS-specific system role is (or behaves like) a domain conteroller master.
Looking at the therade you mentioned I can not see that the steps described there shouldnt work.

Best Regards,
Dirk

Ok thank you, but i am not sure how i should upgrade a normal Samba-DC (which is the master of the domain) to Univention 4.3 as mentioned in this thread:

grafik

There is only on univention server which is more or less a domain-slave…

I also checked if the correct LDAP schemes are registered.
The Output of the two commands:

udm settings/ldapschema list --filter=“cn=oxforucs*” | egrep ‘DN:|active’
= TRUE

and

udm settings/ldapschema list --filter=“cn=oxforucs*” | egrep ‘DN:|active’
= yes

Or is the last possibility backup and force:
grafik

What is the server role the OX Server is installed on? ucr get server/role

Did you check that everything is working as expected as mentioned in the All available updates are installed, I checked the LDAP schemes and they are ok, but the update to UCS 4.3-0 is still blocked section`?

The command gives out:
ucr get server/role
domaincontroller_master

Interesting, I did not know about this variable…but I also know that there are only two DCs in this network, which are both with samba!

The command:
ucr get ox/master/42/registered_ldap_acls
yes

Yesterday I tried to force upgrade, but I also didn’t work…
The last output in the log was a dpkg-error:
grafik

During the installation I just saw a few times that the apache2-server failed to start!

Nobody has any idea?
I think I tried everything from:

It seems the forced upgrade was able to download and install at least some UCS 4.3 packages (univention-config 13.0.0-4… is from 4.3), but fails for the collectd package. Without the complete updater log it is unclear what happened. Maybe it is enough to remove and reinstall the package, or trying to fix the package status with apt-get -f install

Sorry for the late answer, I did not have the time for the upgrade.
So here is a TXT of the Updater-Log from the last try.
Can anybody tell me what I might do? I have really no idea left…
Thank you very much!

updaterLog13072020_ignorssh.txt (2.5 MB)

if i force install, after removing collectd, this is the output:
Bildschirmfoto vom 2020-07-13 15-06-34