Univention Upgrade 4.3-3 zu 4.4-4 - bind9 Fehler

Hallo Leute,

wenn ich einen Univention Server Upgrade, bekomme ich gerade immer folgenden Fehler:
Starting univention-upgrade. Current UCS version is 4.3-3 errata504

Checking for local repository: none
Checking for package updates: none
Checking for app updates: none
Checking for release updates: found: UCS 4.3-4
Starting update to UCS version 4.3-4

HINT:
Please check the release notes carefully BEFORE updating to UCS 4.3-4:
English version: https://docs.software-univention.de/release-notes-4.3-4-en.html
German version: https://docs.software-univention.de/release-notes-4.3-4-de.html

Please also consider documents of following release updates and
3rd party components.

Update will wait here for 60 seconds…
Press CTRL-c to abort or press ENTER to continue

Checking for space on /var/cache/apt/archives: OK
Checking for space on /boot: OK
Checking for space on /: OK
Checking for package status: failed
ERROR: The package state on this system is inconsistent.
Please run ‘dpkg --configure -a’ manually
Error: Please check “/var/log/univention/updater.log” for details.
ERROR: update failed. Please check /var/log/univention/updater.log

root@mail:/var/lib/univention-ldap/ldap# dpkg --configure -a
bind9 (1:9.10.3.dfsg.P4-12.3+deb9u5A~4.3.0.201905131409) wird eingerichtet …
insserv: Service samba-ad-dc has to be enabled to start service bind9
insserv: exiting now!
update-rc.d: error: insserv rejected the script header
dpkg: Fehler beim Bearbeiten des Paketes bind9 (–configure):
Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück
Fehler traten auf beim Bearbeiten von:
bind9

root@mail:/var/lib/univention-ldap/ldap# ucr get server/role
domaincontroller_slave

root@mail:/var/lib/univention-ldap/ldap# ucr get dns/backend
ldap

Was kann ich tun?

Hello @mrothmund,

we like to have post in English, so that the non-German community can better understand existing questions.

A quick summay of you topic in English: when updating the package bind9, the update stops and gives an error message back.

This is a known bug which is currently heavily worked on. If you want to stay updated on this issue you can follow the bug in our bug tracker: https://forge.univention.org/bugzilla/show_bug.cgi?id=49440

Cheers,
Timo

1 Like

Is this related to what we observe with latest update?

May 20 10:23:39 ucs named[1771]: samba_dlz: starting configure
May 20 10:23:39 ucs named[1771]: samba_dlz: trying partition 'CN=MicrosoftDNS,DC=DomainDnsZones,DC=company,DC=intranet'
May 20 10:23:39 ucs named[1771]: dns_rdata_fromtext: buffer-0x7f1e21979e90:1: near 'ucs..': empty label
May 20 10:23:39 ucs named[1771]: Failed to put rr
May 20 10:23:39 ucs named[1771]: zone 2.168.192.in-addr.arpa/NONE: could not find NS and/or SOA records
May 20 10:23:39 ucs named[1771]: zone 2.168.192.in-addr.arpa/NONE: has 0 SOA records
May 20 10:23:39 ucs named[1771]: zone 2.168.192.in-addr.arpa/NONE: has no NS records
May 20 10:23:39 ucs named[1771]: samba_dlz: Failed to configure zone '2.168.192.in-addr.arpa'
May 20 10:23:39 ucs named[1771]: loading configuration: bad zone

We fixed it with ucr set dns/backend=“ldap” and restarted bind.

Is this acceptable or will lead to other trouble (using samba with windows clients / domain logon)