Univention-updater Fehler bei offline Update auf UCS 2.4-3

german

#1

Hallo,

ich bekomme auf zwei getesteten UCS Systemen folgenden Fehler beim Versuch ein Update von UCS 2.4-2 auf UCS 2.4-3 durchzuführen.

Auf einem 32bit System bekomme ich mit dem 32bit Update den gleichen Fehler,
wie hier auf einem 64bit System:

[vorher habe ich 2.4-1 und 2.4-2 auf die gleiche weise problemfrei einspielen können]

jetziger Systemstand 2.4-2-4

univention-updater cdrom --iso ucs_update_2.4-2_-_2.4-3-20110913-dvd-amd64.iso

Mounting the ISO image ucs_update_2.4-2_-_2.4-3-20110913-dvd-amd64.iso
Update to = 2.4-3
Traceback (most recent call last):
  File "/usr/sbin/univention-updater", line 556, in ?
    main()
  File "/usr/sbin/univention-updater", line 450, in main
    temporary_sources_list = updater.release_update_temporary_sources_list(nextversion)
UnboundLocalError: local variable 'updater' referenced before assignment

#2

Hallo,

dieses Problem wurde uns bereits gemeldet und ist in unserem Bugtracking System unter [bug]23948[/bug] dokumentiert.
Als Workaround können Sie das Update über den Befehl univention-repository-update in das lokale Repository einspielen und anschließend aus dem Repository mittels univention-updater local installieren.

Mit freundlichen Grüßen
Janis Meybohm


#3

Fehler ist auch wieder im Update auf 2.4-4 vorhanden

root@server:/# univention-updater cdrom --iso ucs_update_2.4-3_-_2.4-4-20111223081307-dvd-amd64.iso Mounting the ISO image ucs_update_2.4-3_-_2.4-4-20111223081307-dvd-amd64.iso Update to = 2.4-4 Traceback (most recent call last): File "/usr/sbin/univention-updater", line 565, in ? main() File "/usr/sbin/univention-updater", line 456, in main temporary_sources_list = updater.release_update_temporary_sources_list(nextversion) UnboundLocalError: local variable 'updater' referenced before assignment


#4

Hallo,

der hierzu angelegte [bug]23948[/bug] wurde erst mit UCS 2.4-4 behoben, daher trtitt er beim Update auf 2.4-4 noch einmal auf. Der bereits beschriebene Workaround sollte aber auch bei diesem Update funktionieren.

Mit freundlichen Grüßen
Janis Meybohm