Univention Update - Owncloud keine SMB Freigaben mehr

german
owncloud

#1

Hallo Univention Help Forum,

ich habe ein kleines Problem mit meiner Univention Appliance und würde mich freuen, wenn mir hier jemand helfen könnte.
Ich habe zu Hause seit einiger Zeit eine Univention Appliance laufen und die letzten Updates haben auch immer ohne Probleme funktioniert. Vorgestern habe ich die Appliance auf die Version 4.3-3 errata411 geupdatet und zusätzlich meine Owncloud Version auf 10.0.10.4. Seit diesem Zeitpunkt kann ich in der Owncloud nicht mehr auf meine Freigaben auf der QNAP zugreifen. Er zeigt mir nur diesen typischen “roten Punkt” in der Übersicht.

Konfiguration UCS:

  • Version 4.3-3 errata411
  • Owncloud Applikation
  • Nextcloud Applikation (nur zu Testzwecken)

Was ich bereits probiert habe:

  • UCS Appliance neugestartet nach dem erfolgreichen Update
  • QNAP aktuelle Firmware installiert und neugestartet
  • Credentials auf der QNAP zurückgesetzt und in der Owncloud neu eingetragen
  • Freigabe auf einem Centos Server gemounted und Zugriff getestet, okay
  • Freigabe via MacBook getestet, okay
  • Nextcloud zusätzlich zur Owncloud installiert, Freigabe eingerichtet -> gleicher Fehler (und das hätte ich nun gar nicht erwartet…)
  • php smbclient versucht nachzuinstallieren im owncloud docker (owncloud) (wie hier beschrieben Kein zugtriff auf SMB Freigaben mit Nextcloud )

Hat einer eine Idee? Die Konfiguration der Owncloud ist nicht riesig und zur Not kann ich diese in einer neuen Appliance neu konfigurieren, aber den Fehler würde ich trotzdem gerne finden.
Vorab vielen Dank!


#2

Hello,

for our international users a translation of the question:

Subject: Univention Update - Owncloud no more SMB shares

Hello Univention Help Forum,

I have a small problem with my Univention Appliance and would be happy if someone could help me here.
I have been running a Univention Appliance at home for some time now and the latest updates have always worked without problems. The day before yesterday I updated the appliance to version 4.3-3 errata411 and additionally updated my Owncloud version to 10.0.10.4. Since then I can no longer access my QNAP shares in the Owncloud. He only shows me this typical “red dot” in the overview.

Configuration UCS:

  • Version 4.3-3 errata411
  • Owncloud application
  • Nextcloud application (for testing purposes only)

What I’ve already tried:

  • UCS Appliance restarted after successful update
  • QNAP current firmware installed and restarted
  • Credentials reset on QNAP and newly entered in the Owncloud
  • Shares mounted on a Centos server and access tested, okay
  • Shares via MacBook tested, okay
  • Nextcloud installed in addition to Owncloud, share set up -> same error (and I wouldn’t have expected that now…)
  • php smbclient tries to reinstall in owncloud docker (owncloud) (as described here Kein zugtriff auf SMB Freigaben mit Nextcloud)

Anybody got an idea? The configuration of the Owncloud is not huge and if necessary I can reconfigure it in a new appliance, but I would still like to find the error.
Many thanks in advance!


#3

Hey,

one important recent change that comes to mind regarding Samba on Linux is that the client libraries also use a higher protocol version by default now. It’s possible the QNAP doesn’t like that.

Can you try mounting a share from another server that isn’t a QNAP device, e.g. from the UCS appliance itself?

Next thing you should try is to use the smbclient program inside the containers in order to access the share on the QNAP (you only said you tried to install it, not that you tried using it, too). The command would look something like this:

smbclient //qnap-hostname/sharename -U username

If the connection succeeds, you should get a prompt such as this one:

smb: \>

If it doesn’t work, you can try lowering the maximum protocol version the client tries to use by adding a parameter:

smbclient //qnap-hostname/sharename -U username --max-protocol=NT1

If that fails, too, add --debuglevel=4, try again and post the output here, please.

m.


#4

@gulden thanks for translating my post.

@Moritz_Bunkus
The protocol version can be a solution. I will check this on evening.
I mounted the shares on a centos server already (cifs-utils) and this works fine for all the shares.

I will test your ideas on evening and let you know the result.


#5

Hey,

What I meant was to create a share on a different server (e.g. on your UCS server) and mount that share from Owncloud/Nextcloud — in order to verify if there’s a general problem mounting SMB shares or if it’s the combination of the *cloud containers and the QNAP server.

m.


#6

Hello Moritz,
sorry for the misunderstanding.
I will try to connect another share form another source to exclude a fault between USC and the QNAP.


#7

Hey

@Moritz_Bunkus I found a solution.
First I checked and tested with different accepted SMB protocol versions on my QNAP, but this was the false path.
Second I tried to connect to another SMB Share on a Windows VM, but this wasn’t working too.Then I tried to modify the username from “testuser” to “testuser@x.x.x.x(hostname/IP)” and the connection was established.
I modified the other credentials, and all connections are established now.
I don’t know why I had to modify all credentials, because it was working until the update, but now it is working again.

My Owncloud client on my Windows Notebook has a problem (allegedly all files were deleted from the server and the client asks me if I will delete all my files too, or keep them and upload to the server again) but this is no big problem for me. I stopped the synchronization for this profile and set up a new profile (with the same user account), started a new synchronization and when this is complete, I will delete the old profile.

Thank you very much for your help.