Univention Stopped Working - Low Space


I have quite the problem with Univention and I hope soemone can help me.

I have a virtual server with 80GB of virtual hdd running versione 4.4.9 and SuiteCrm.
Today it stopped working becoming unresponsive and/or unreachable.

I did some checks and it seems that it’s somehow out of space since while trying to update it i was getting with the no space available" error.


At this point I have 3 options:

  • Free some space to solve the problem
  • Expand it (I have increased the virtual hdd and expanded the partitions while booting gparted but no results)
  • Migrate suitecrm to a new univention installation

Any suggestion is welcome.

How many space is under the local UCS Backupfolder?

du -sh  /var/univention-backup


I already tried deleting the backup but it dind’t solve the issue.

du -sh /var/univention-backup
174M /var/univention-backup

No, that wasn’t much either. If this is not limited, the directory can be very large.

You can only analyse your vmspace:

du -sh /*

Then switch to the next Subdirectory where there is the most data or where you think there might be data to delete.
You also can do an “apt autoremove --purge” but with care, and an “apt clean”.

You enlarged the PHY partition, then the VG, then the LV and finally the filesystem? How exactly did you do that?

I checked with du -sh but the only folder “big” is /usr which is only 2.2GB

In any case I am probably a noob but I don’t understand:
df -h say that I have 59GB free but if I run univention-upgrade it fails for no space and then everyhting fails.
Same if I try sudo apt-get update or upgrade.

The Expand was an otion. I am trying to expand it but due to lack of knowledge I am unable to execute it.
I can expand the disk, enlarge the partition but then the VM still report the old size. Googling is not helping since I am hitting multiple solutions and or errors.

Ah sorry, my fault, i’ve overseen that 100% is only on inodes on your screenshot…

A way is to create a new partition an move the CRM to it. This is where most of the files will be hidden. But otherwise here are some instructions for enlarging your LVM.

1 Like


Many , many thanks for the second link. It worked.

I just did a couple of changes.
I extended the virtual HDD from my hypervisor when the VM was off.
Then I booted into Gparted to create an ext4 partition and rebooted.
I followed the second link but instead of xfs_growfs i used resize2fs since my partition are ext4.
Another reboot and finally df -i show 80% of usage.
Now SuiteCRM is working again.

Next move is to move away from UCS since during this journey I discovered that SuiteCRM is not supported anymore.

1 Like