UNIVENTION_S4CONNECTOR: Warning

german

#1

Ich bekomme folgenden Reject wenn ich einen bestimmten Rechner (H240) einschalte:

[code]root@ucs:~# univention-s4connector-list-rejected

UCS rejected

S4 rejected

1:    S4 DN: CN=H240,CN=Computers,DC=friedrichnet,DC=de
     UCS DN: cn=h240,cn=computers,dc=friedrichnet,dc=de

    last synced USN: 24307

root@ucs:~#
[/code]

Was muss ich tun?

PS: Wenn ich das am anderen DC ausführe bekomme ich einen Fehler:

root@ucsbak:~# univention-s4connector-list-rejected Traceback (most recent call last): File "/usr/sbin/univention-s4connector-list-rejected", line 73, in <module> import mapping ImportError: No module named mapping root@ucsbak:~#


#2

sdb.univention.de/content/6/294/ … jects.html


#3

Hab Rechner neu angelegt in Domäne…

Was ist das Problem am Slave DC das ein modul fehlt?


#4

Hm keine Ahnung. Es sollte AFAIK unproblematisch sein. Aber du könntest mal folgendes probieren:

univention-install --reinstall python-univention-connector-s4

#5

Das hat leider nichts geholfen, auf dem Backup DC geht das Kommando nach wie vor mit dieser Fehlermeldung nicht.
Systeme habe alle den gleichen aktuellen Stand.


#6

Welche Version wird eingesetzt? Ich habe die Meldung gerade auf einem 4.1-3 sehen können, aber in den aktuellen Versionen 4.1-4 nicht mehr.


#7

Alle Server sind 4.1.4-371


#8

Der Befehl “univention-s4connector-list-rejected” erfordert die sqlite Datenbank und die Picklefiles der rejects. Diese liegen jedoch nur auf dem Server, bei dem auch der S4Connector aktiv läuft (in einer Domäne ist das nur ein Server). Installiert ist der Connector vermutlich auch auf dem backup, aktiv läuft er aber nur auf dem master. Der Befehl funktioniert daher nur auf dem master.


#9

Dise Fehlermeldung sollte aber AFAIK trotzdem nicht kommen. Bei mir kommt zumindest eine Ausgabe. Die Werte sind aber natürlich alle auf 0.


#10

hmm… ich kann das gerade konstant bestätigen. Überall da wo der S4 Connector installiert ist aber nicht aktiv läuft kommt die Meldung.