Univention oxappsuite synchronisiert nicht mit iphone

mail
german

#1

Hat jemand vielleicht eine Lösung dafür.

Wenn ich dir variable apache2/force_https auf yes setze, können iphones keine Mail und kalenderdaten mehr synchronisieren

unsere Umgebung
univention version 4.1-2 errata202
oxappsuite version 7.8.1-7ucs1

Gruß
Henry Otten


#2

Vermutlich muß zumindest die UCS-CA hinterlegt werden.


#3

Das Zertifikat ist installiert.
Über den Browser wird korrekt auf die https-Seite umgelenkt.


#4

Hast du vielleicht einen Tip in welchem logfile ich nachsehen kann ob es Probleme mit dem Zertifikat geben könnte??
Ich bin da etwas ratlos am stochern.
Gruß
Henry


#5

Nein mit iPhones kenne ich mich nicht aus und ich denke, daß du eher dort fündig werden solltest. Funktionieren andere Clients (Android etc.)?

Du kannst natürlich trotzdem mal serverseitig unter /var/log/apache2/ gucken. Vielleicht findest du ja doch dort etwas, was weiterhilft.


#6

Klingt für mich ein bisschen so, als ob die iPhones in Schleife laufen und nach der Umleitung auf https wieder zurück auf http gehen um erneut umgeleitet zu werden…

Ich würde mich der Analyse über die Konfiguration eines extra rewrite.logs nähern - da erkennt man das (z.B. über ein live ‘tail -f /var/log/apache2/rewrite.log’) wesentlich schneller!

http://httpd.apache.org/docs/current/mod/mod_rewrite.html#rewriteloglevel

RewriteEngine on RewriteLog /var/log/apache2/rewrite.log RewriteLogLevel debug
debug → http://httpd.apache.org/docs/current/mod/core.html#loglevel; wenn das nicht reicht kann man von trace1 bis trace8 noch richtig ins Eingemachte gehen.


#7

So das Problem ist gelöst,
es war eine schwere Geburt!

Die Ursache dafür ist, daß bei force_https auch Verbindungen von localhost auf https gezwungen werden, dies verursacht aber Probleme mit dem OX USM Modul, da dieses sich über http an localhost verbindet was nun aber nicht mehr möglich ist. Ein Workaround dafür besteht darin im Apache eine Ausnahme für localhost einzufügen:

Zuerst force_https einschalten.In die Datei /etc/apache2/mods-enabled/ssl.conf im unteren Abschnitt vor der Zeile:
RewriteRule ^/?(.*) https://%{SERVER_NAME}/$1 [R=301,L]

die folgende Zeile einfügen:
RewriteCond %{HTTP_HOST} !=localhost

Der Abschnitt sollte dann so aussehen:

RewriteEngine on
RewriteCond %{HTTPS} off
RewriteCond %{REQUEST_URI} !=/server-status
RewriteCond %{HTTP_HOST} !=localhost
RewriteRule ^/?(.*) https://%{SERVER_NAME}/$1 [R=301,L]

Dann klappt es mit den Verbindungen!


Open Exchange Exchange verbindung und Mobile Apps funktionieren nicht
#8

Kann man OX USM nicht dazu bringen, sich über den FQDN zu verbinden?