Univention Office365 not syncing the users


#1

Tried the office 365, but the sync is not happening. Could you please have a look on this logs

ty02.11.17 09:43:45.804  LISTENER    ( ERROR   ) : o365(I): azure_handler._create_object:278  Creating user with properties: {'passwordProfile': {'password': '******', 'forceChangePasswordNextLogin': False}, 'accountEnabled': True, 'surname': 'test', 'mailNickname': 'test', 'userPrincipalName': 'test@devopsin.com', 'immutableId': 'NWZjYzM0OGEtNTQxYi0xMDM3LTgzOWMtMmRkMDJhZTA4ZDBl', 'otherMails': ['test@devops.in'], 'displayName': 'test', 'usageLocation': 'US'}
02.11.17 09:43:45.805  LISTENER    ( ERROR   ) : o365(D): azure_auth.get_access_token:341  Loading token from disk...
02.11.17 09:43:45.806  LISTENER    ( ERROR   ) : o365(D): azure_auth.get_access_token:346  Token expired, retrieving now one from azure...
02.11.17 09:43:45.854  LISTENER    ( ERROR   ) : o365(D): azure_auth.retrieve_access_token:502  POST to URL='https://login.microsoftonline.com/71f78fec-7013-49a4-aba0-747f99e381ec/oauth2/token' with data={'resource': 'https://graph.windows.net', 'client_assertion_type': 'urn:ietf:params:oauth:client-assertion-type:jwt-bearer', 'redirect_uri': u'http://10.10.10.133/univention/command/office365/authorize', 'client_assertion': 'eyJ4NXQiOiAiKzlwN3ZGcFpvd2RrTUN0elQ2bURZcHkrOEk4PSIsICJhbGciOiAiUlMyNTYifQ.eyJhdWQiOiAiaHR0cHM6Ly9sb2dpbi5taWNyb3NvZnRvbmxpbmUuY29tLzcxZjc4ZmVjLTcwMTMtNDlhNC1hYmEwLTc0N2Y5OWUzODFlYy9vYXV0aDIvdG9rZW4iLCAiaXNzIjogIjQyY2IxNzBkLTkwNTMtNDIyYi1hNjdiLWFiZGY5ZDE5NGUyMiIsICJqdGkiOiAiMjdjNjQzNTEtMTk2Mi00YjkxLThjYTctNDc0NGQyNDZiZjJlIiwgImV4cCI6IDE1MDk2MzA4MjUsICJuYmYiOiAxNTA5NjI5OTI1LCAic3ViIjogIjQyY2IxNzBkLTkwNTMtNDIyYi1hNjdiLWFiZGY5ZDE5NGUyMiJ9.ZlvHJkc64xOE32kmy3uZlj_TltY5AtsQzKjZ43jjpgMWAjB5VkFL2gtdw3oM0PDGero6TTSAP5WU3AscT34IDjCBZa8ZKhjZEMRdcO--xm7X4Pyz93rdohL3_v37RS5PtUNDm6DnoLIspzEVFWXq6iPa-SnqIyjWP3Td3cTEpfJj2732MKG3c9mkipQBEs6Kf5Q0cKN33SWsPlGsEykZHTrCWU37gvwT5OQSB1Dl_1J_bg6xmbNg99MhxEJUASp_D4G9E1h_Lmq0D1n6TkyFOA2r67_8NRBIM5B4i_IbSasQfNTdM6JzYPHaDx3PnXBvpAthHUX9kUvscfHHWlsFew', 'client_id': u'42cb170d-9053-422b-a67b-abdf9d194e22', 'scope': ['Directory.ReadWrite.All'], 'grant_type': 'client_credentials'}
02.11.17 09:43:46.297  LISTENER    ( ERROR   ) : o365(E): azure_auth.retrieve_access_token:506  Error retrieving token (status 401), response: {'cookies': <RequestsCookieJar[Cookie(version=0, name='esctx', value='AQABAAAAAABHh4kmS_aKT5XrjzxRAtHzHN_5BXUz3zk1Z39Rwg8a1dAnLJs2UmLcvNhZVyKsRGtCQT5L4u3O8FzIJyZ3jLlFmzSiozq5mk_Z96ZfdDRbtQVKhfJd_bB1DbpcsGsDenOvtsU5-s8tpeM4CIzpeR-lxBXxNej_fYxgybHVqH1kr8GkqY4ZWMWnTc7nfh3rSPsgAA', port=None, port_specified=False, domain='.login.microsoftonline.com', domain_specified=True, domain_initial_dot=True, path='/', path_specified=True, secure=True, expires=None, discard=True, comment=None, comment_url=None, rest={'HttpOnly': None}, rfc2109=False), Cookie(version=0, name='stsservicecookie', value='ests', port=None, port_specified=False, domain='login.microsoftonline.com', domain_specified=False, domain_initial_dot=False, path='/', path_specified=True, secure=True, expires=None, discard=True, comment=None, comment_url=None, rest={'HttpOnly': None}, rfc2109=False), Cookie(version=0, name='x-ms-gateway-slice', value='008', port=None, port_specified=False, domain='login.microsoftonline.com', domain_specified=False, domain_initial_dot=False, path='/', path_specified=True, secure=True, expires=None, discard=True, comment=None, comment_url=None, rest={'HttpOnly': None}, rfc2109=False)]>, '_content': '{"error":"invalid_client","error_description":"AADSTS70002: Error validating credentials. AADSTS50012: Client assertion contains an invalid signature. [Reason - The key was not found., Thumbprint of key used by client: \'FBDA7BBC5A59A30764302B734FA983629CBEF08F\', Configured keys: []]\\r\\nTrace ID: 9c809997-7c0c-4fb4-b9b1-ff45aa957700\\r\\nCorrelation ID: 3e71c413-514b-4cf1-8d36-b2bca99e8d9d\\r\\nTimestamp: 2017-11-02 13:43:48Z","error_codes":[70002,50012],"timestamp":"2017-11-02 13:43:48Z","trace_id":"9c809997-7c0c-4fb4-b9b1-ff45aa957700","correlation_id":"3e71c413-514b-4cf1-8d36-b2bca99e8d9d"}', 'headers': {'content-length': '595', 'expires': '-1', 'x-content-type-options': 'nosniff', 'x-powered-by': 'ASP.NET', 'set-cookie': 'esctx=AQABAAAAAABHh4kmS_aKT5XrjzxRAtHzHN_5BXUz3zk1Z39Rwg8a1dAnLJs2UmLcvNhZVyKsRGtCQT5L4u3O8FzIJyZ3jLlFmzSiozq5mk_Z96ZfdDRbtQVKhfJd_bB1DbpcsGsDenOvtsU5-s8tpeM4CIzpeR-lxBXxNej_fYxgybHVqH1kr8GkqY4ZWMWnTc7nfh3rSPsgAA; domain=.login.microsoftonline.com; path=/; secure; HttpOnly, x-ms-gateway-slice=008; path=/; secure; HttpOnly, stsservicecookie=ests; path=/; secure; HttpOnly', 'x-ms-request-id': '9c809997-7c0c-4fb4-b9b1-ff45aa957700', 'strict-transport-security': 'max-age=31536000; includeSubDomains', 'server': 'Microsoft-IIS/8.5', 'pragma': 'no-cache', 'cache-control': 'no-cache, no-store', 'date': 'Thu, 02 Nov 2017 13:43:48 GMT', 'p3p': 'CP="DSP CUR OTPi IND OTRi ONL FIN"', 'content-type': 'application/json; charset=utf-8'}, 'url': u'https://login.microsoftonline.com/71f78fec-7013-49a4-aba0-747f99e381ec/oauth2/token', 'status_code': 401, '_content_consumed': True, 'encoding': 'utf-8', 'request': <PreparedRequest [POST]>, 'connection': <requests.adapters.HTTPAdapter object at 0x7f1858042d90>, 'elapsed': datetime.timedelta(0, 0, 380440), 'raw': <urllib3.response.HTTPResponse object at 0x7f1858049f10>, 'reason': 'Unauthorized', 'history': []}
None
pe or paste code here

#2

The connection has not been authenticated.
Did the configuration wizard run through successfully?


#3

It ended up on authentication token error eventhough the steps were followed


#4

Could you please list out the possibilities why that happens eventhough the same steps are followed.


#5

Error retrieving authentication token from Azure. Getting like this when trying to setup


#6

Good afternoon augustineca,

sorry I have no idea on how to solve this problem. Maybe the support team can help you. Below is a link to the channel:

Regards

Anna Takang