Univention Firewall / Packetfilter aktiv?

german

#1

Ich prüfe gerade den Einsatz von Syncthing auf meinen UCS 4.1 für den Abgleich kleinerer Shares.

Syncthing läuft (Installation ist schnell gemacht), und lauscht auch auf Port 8384 für das Webfrontend (listen port 0.0.0.0:8384, so dass ein Zugriff von anderen Clients möglich ist).

Lokal bekomme ich auch einen Connect:

[code]# telnet 127.0.0.1 8384
Trying 127.0.0.1…
Connected to 127.0.0.1.
Escape character is ‘^]’.

telnet 192.168.xxx.xxx 8384

Trying 192.168.xxx.xxx…
Connected to 192.168.xxx.xxx.
Escape character is ‘^]’.[/code]

Allerdings keinerlei Connection von einem Client (im gleichen Subnetz).

Meine Vermutung, daher, dass der Packetfilter die Verbindung blockt, aber auch das Setzen der Variable

security/packetfilter/tcp/8384/all ACCEPT

bringt keine Änderung im Verhalten.
Ist es korrekt, dass der Packetfilter per default aktiv ist? Ich würde ihn zum Testen gerne mal komplett deaktivieren, wie prüfe ich den tatsächlichen Status?

IPv6 habe ich per

grub/append ipv6.disable=1

im Kernel bereits deaktiviert (und rebootet), da es hier auch auf Seite syncthing Hinweise gibt, dass ggf. IPv6 präferiert wird - ebenfalls ohne Änderung…


#2

Problem hat sich mittlerweile erledigt, zumindest funktioniert der Zugriff nun. :slight_smile:
Frage zum Status des Packetfilters bleibt aber noch bestehen…


#3

Hallo,

der Filter ist per default an, jedenfalls mit diesen Einstellungen:

[code]security/packetfilter/defaultpolicy: REJECT
This variable configures the standard behaviour of Univention Firewall for incoming packets. Possible values: ‘ACCEPT’, ‘REJECT’ and ‘DROP’ (rejecting without notifying the sender).

security/packetfilter/disabled:
If this option is enabled, Univention Firewall isn’t used. If the variable is unset, Univention Firewall is used.

[/code]

Die Änderung, die Sie mit der neuen UCR-Variable eingeführt haben, sollte in /etc/security/packetfilter.d/80_univention-firewall_policy.sh eingetragen werden.
Der Dienst wird allerdings beim Setzen der Variable nicht neu gestartet. Das könnte die Ursache für das beschrieben Verhalten sein.

Viele Grüße,
Dirk Ahrnke