Univention 5.0-4 errata726 + Nextcloud 25.0.8-0 + Onlyoffice 7.4.0.1: Error while downloading the document file to be converted

Hi guys, since I upgraded Onlyoffice from 7.3.3.50 to 7.4.0.1, Onlyoffice no longer works in Nextcloud, in the plugin page I get “Error while downloading the document file to be converted”
Downgrading to 7.3.3.50 works, the problem is that 7.3.3.50 is not compatible with Univention 5.0-4 errata726 and on server reboot it is removed. I tried to install clean 5.0-4 errata726 + Nextcloud 25.0.8-0 + Onlyoffice 7.4.0.1 in a test environment and it gives me the same problem. So I tried to set up a separate debian, installing OnlyOffice via docker and it doesn’t work like that either, same error; however disabling JWT “-e JWT_ENABLED=false” like this works.
I’m at a standstill: what is missing from Univention’s Nextcloud to use Onlyoffice with JWT enabled? And in the Onlyoffice version of univention 7.4.0.1, JWT is enabled while it wasn’t in the past?

Do any of you use NC+OO on Univention and have encountered (and maybe fixed) the same problem?

Thank you!

for me the same combination works without problems on 5 different installations

I installed Univention from scratch, did all the updates, installed Let’s Encrypt, Nextcloud and OnlyOffice, same problem. Did you manually tweak any configuration to make it work?

what did you enter in the onlyopen configuration fields at your nextcloud server ?
i think i saw problem entering the fqdn in the server address field for internal onlyoffice docs so changed this to https://192.168.1.1/nextcloud/

so config in nextcloud looks like this:
Adress of ONLYOFFICE Docs
https://fqdnofonlyofficeserver/onlyoffice-documentserver/
secret
empty
address ONLYOFFICE Docs for internal server requests
empty
serveraddress for internal ONLYOFFICE Docs requests
https://ipaddressofnextcloudserver/nextcloud/

rg
Christian

Thank you, this is my configuration

Immagine 2023-07-13 145925

I tried with IP for internal requests from onlyoffice docs but same result :frowning:

on my end the following fixed it:
shell into the onlyoffice docker container by:
univention-app shell onlyoffice-ds
then edit /etc/onlyoffice/documentserver/local.json to include the following under:
{
“services”: {
“CoAuthoring”: {

"request-filtering-agent": {
"allowPrivateIPAddress": true,
"allowMetaIPAddress": false
},

nano is conveniently available in the onlyoffice-ds docker image.
for a good measure I restart docker container after exiting the shell
with docker restart <containerid>

2 Likes

Great, it works!!!
I would never have gotten there on my own!
Thank you so much, I don’t know how to thank you!!!

Thanks a lot Lleo.

Using IP in the server address for internal requests resolved too but i think that your tip is more conveniently.

Mastodon