UNCHECKED contents in mail

mail
kopano
ucs-4-2

#1

Hi - aus mir bisher nicht nachvollziehbaren Gründen (kein Update oder Config-Change - lediglich ein reboot nach einem Stromausfall) hat sich mein Mailsystem (Kopano) dazu entschieden mir zu jeder eMail gleich noch eine zweite zukommen zu lassen.
Das Subject beginnt imme mit:
Vorformatierter Text "UNCHECKED contents in mail FROM …`

Der Body beginnt immer mit:

Content type: Unchecked
Internal reference code for the message is 28917-01/fTJTaUDNYMsp
First upstream SMTP client IP address:....

Gerne möchte ich natürlich über Probleme infomiet werden - jedoch nicht über jede eMail den am MTA vorbeikommt.

Hat da einer eine Idee?
PS: Bisher habe ich nur einen sehr alten Eintrag im Forum gefunden - ohne Hinweis welche Version verwendet wurde.

Ich verwende derzeit auf dem Mail System
UCS --> 4.2-2 errata231 (Lesum)
Kopano Core --> 8.3.1-35

Vielen Dank vorab
Pepe


#2

Tja - nach einigen Reboots - hörten diese Nachrichten von selber auf - ohne wie zuvor eine Änderung an der Config vorgenommen zu haben.

Wunderheilung?


#3

Hi - habe das Problem nun wieder - mit Version 4.3-2 errata291.

In einem Eintrag habe gelesen, das dies etwas mit ClamAV zu tun haben könnte - also habe ich einfach einmal versucht via SSH “freshclam” zu starten - was erst nach beenden des Services funktioniert hat. Jedoch ging dann gleich das “gemeckere” los (siehe Eintrag aus Log).

Im Log /var/log/clamav/freshclam.log habe ich folgende Fehlermeldung gesehen:

ClamAV update process started at Thu Nov  1 17:42:31 2018
main.cvd is up to date (version: 58, sigs: 4566249, f-level: 60, builder: sigmgr)
Downloading daily-25076.cdiff [100%]
Downloading daily-25077.cdiff [100%]
Downloading daily-25078.cdiff [100%]
Downloading daily-25079.cdiff [100%]
Downloading daily-25080.cdiff [100%]
Downloading daily-25081.cdiff [100%]
WARNING: [LibClamAV] hm_addhash_str: invalid hash 4VMB -- FIXME!
WARNING: [LibClamAV] cli_loadhash: Malformed hash string at line 69444
WARNING: [LibClamAV] cli_loadhash: Problem parsing database at line 69444
WARNING: [LibClamAV] Can't load daily.hdb: Invalid argument passed to function
WARNING: [LibClamAV] cli_tgzload: Can't load daily.hdb
WARNING: [LibClamAV] Can't load /var/lib/clamav/clamav-a78cf7568b53aaebe3ffb82dd437af64.tmp/clamav-24dabe88f77fc7cddf97fc5af23a02ab.cld: Malformed database
ERROR: Failed to load new database: Malformed database
ERROR: During database load : WARNING: [LibClamAV] hm_addhash_str: invalid hash 4VMB -- FIXME! [...] ERROR: Failed to load new database: Malformed database
WARNING: Database load exited with status 55
ERROR: Failed to load new database

Ich habe gesehen, dass UCS einen Patch für ClamAV (292). Die Beschreibung des Fixes geht zwar in einen andere Richtung - aber vielleicht hifts ja auch bei mir.

Melde mich dann gleich nach dem Update noch einmal.

Pepe


#4

Tja - leider hat dieser Fix nichts gebracht.

Wer hat einen Vorschlag?

Beste Grüße
Pepe


#5

hi,

I would try to remove the db and run a new update, seen here https://www.howtoforge.com/community/threads/clamav-database-update-error.76634/

rg
Christian


#6

Danke externa1,
nach dem ich die drei Datenbank-Dateien umbenannt hatte und unter den Systemdiensten den Dienst clamav-freshclam gestoppt hatte, konnte ich zumindest die neuen Datenbanken laden.

ucs3:~# freshclam
ClamAV update process started at Thu Nov  1 22:14:38 2018
Downloading main.cvd [100%]
main.cvd updated (version: 58, sigs: 4566249, f-level: 60, builder: sigmgr)
Downloading daily.cvd [100%]
daily.cvd updated (version: 25081, sigs: 2138379, f-level: 63, builder: neo)
Downloading bytecode.cvd [100%]
bytecode.cvd updated (version: 327, sigs: 91, f-level: 63, builder: neo)
Database updated (6704719 signatures) from db.local.clamav.net (IP: 104.16.187.138)
WARNING: Clamd was NOT notified: Can't connect to clamd through /var/run/clamav/clamd.ctl: No such file or directory

image

Auch nach dem erneuten Starten des Dienst clamav-freshclam gab es im Log kein Hinweis mehr auf “invalid hash”.

Soweit - so gut - leider erhalte ich jedoch auch weiterhin die nervigen eMails:

image

Noch einer ne Idee?

Pepe


#7

Kurzes Update

Nach einem Neustart des gesamten Systems, gab es dann heute morgen (und auch den Tag über) keine dieser eMails mehr.

Somit solft for the moment :wink:

Pepep