Unable to Upgrade Open-Xchange


#1

Server Version: 6.20.7
Distribution: UCS
GUI Version: 3.1-1 errata168
Module: Upgrade
Severity: 1, 2, 3, 4
Product: OXSE
Component: Upgrade

When trying to upgrade system returns with a gree dialog after few minutes : "Notification

An unknown error with status code 502 occurred while connecting to the server, please try again later."

    Please advise on the commands tu run to resolve the problem

Rolando Riley


#2

Hi,

I’d first check if /etc/apt/sources.list.d/20_ucs_online_component.list contains valid sources for all components. As far as I know it is safe to run the OX-Licence module from UMC to check if the OX-license is still valid.

/var/log/univention/updater.log may contain more information about the mentioned error itself, especially to identify what the “502” code is referring to.

Best Regards,
Dirk Ahrnke


#3

Dirk

updater.log doesn’t give any clue about the error posted on the GUI. Actually, that is an additional issue there are no logs of the source of this problem. Licensing is valid and rechecked.

Rolando


#4

Hi,

could you try to run “univention-upgrade” from the command-line and check the output and the changed logs in /var/log/univention?

regards,
Dirk


#5

In Zugriff auf App-Center schlägt fehl we also had a 502 status when trying to access the App Center.
It was caused by proxy settings.

Cheers,
Dirk


#6

Dirk,
Can you be more specific about “it was caused by a proxy setting”. Where ? how? to solve the problem … thanks.

Rolando


#7

Hi Dirk, I am having the same issue.

The currently installed release version is 3.1-1 errata193

Is there anything further I could try,

Thanks,

Peter


#8

Di Dirk,
Here is the output I get:

root@mail:/var/log# univention-upgrade

Starting univention-upgrade. Current UCS version is 3.1-1 errata193

Checking for local repository: none
Checking for release updates: none
Checking for package updates: none
Setting update/available
Module: ox-config
root@mail:/var/log#

Thanks,
Peter


#9

Hi,

in the mentioned case the server was not able to connect to the App Center host with http directly. The system had to go through a proxy which was not possible. I dont have more details and can just guess that the 5xx response was thrown by the proxy. A solution depends on the specific environment.

Something to know about how the OX-Updates:
The file /etc/apt/sources.list.d/20_ucs-online-component.list of a system with OXSE4UCS contains a list of URLs like:

deb http://YOURLDBACCOUNT:YOURLDBPASSWORD@software.open-xchange.com/OX6/OXSEforUCS/3.1/maintained/component/frontend72/ ./ deb http://YOURLDBACCOUNT:YOURLDBPASSWORD@software.open-xchange.com/OX6/OXSEforUCS/3.1/maintained/component/backend72/ ./

It might be worth trying to access the host software.open-xchange.com manually like this:

[code]root@slave1:~# wget -S http://YOURLDBACCOUNT:YOURLDBPASSWORD@software.open-xchange.com/OX6/OXSEforUCS/3.1/maintained/
–2013-10-29 16:14:27-- http://YOURLDBACCOUNT:password@software.open-xchange.com/OX6/OXSEforUCS/3.1/maintained/
Resolving software.open-xchange.com… 46.163.124.88
Connecting to software.open-xchange.com|46.163.124.88|:80… connected.
HTTP request sent, awaiting response…
HTTP/1.1 401 Authorization Required
Date: Tue, 29 Oct 2013 15:14:48 GMT
Server: Apache
WWW-Authenticate: Basic realm=“OpenXchange Update Services”

Reusing existing connection to software.open-xchange.com:80.
HTTP request sent, awaiting response…
HTTP/1.1 200 OK
Date: Tue, 29 Oct 2013 15:14:48 GMT
Server: Apache
Vary: Accept-Encoding
Content-Length: 734
Keep-Alive: timeout=15, max=99
Connection: Keep-Alive
Content-Type: text/html;charset=UTF-8
Length: 734 [text/html]
Saving to: `index.html’

100%[====================================================================================================================================================>] 734 --.-K/s in 0s

2013-10-29 16:14:27 (62.2 MB/s) - `index.html’ saved [734/734]
[/code]
The saved html-file should show entries like the “component” directory and the string “Apache Server at software.open-xchange.com Port 80”.

Best Regards,
Dirk Ahrnke


#10

Hi Community,
Was able to workaround the problem with the following command:
# univention-add-app oxseforucs --latest --all

      From my perspective there are problems with the  GUI online update / upgrade.

SOLVED!

Rolando Riley