Unable to install Windows AD


#1

I am having issues with installing the Windows Compatible Active Directory (Samba4)

the UCM Displays the following when trying to install on the Master/Backup or any Slave:

The following packages will be installed or upgraded:

univention-s4-connector
univention-samba4
univention-samba4-sysvol-sync

This operation causes problems in the following packages that cannot be resolved:

univention-s4-connector
univention-samba4

The log “management-console-module-appcenter.log” has:
Further information regarding this error:
Error: Unable to correct problems, you have held broken packages.
30.06.15 14:07:06.947 MODULE ( PROCESS ) : Finished dry_run for samba4 on localhost
30.06.15 14:07:06.949 MODULE ( PROCESS ) : Problems encountered or confirmation required. Removing component samba4
30.06.15 14:07:43.912 MODULE ( PROCESS ) : Found hosts: [‘ucsmdc’]
30.06.15 14:07:43.936 MODULE ( PROCESS ) : Found hosts: [‘ucsbdc’]
30.06.15 14:07:43.977 MODULE ( PROCESS ) : Found hosts: [‘ucssdc’, ‘ucssdc1’]
30.06.15 14:07:44.067 MODULE ( PROCESS ) : Found hosts: [‘odooerpdev1’, ‘odooerpstg1’, ‘odooerpprd1’, ‘mailprd1a’, ‘nagiosprd1a’]
30.06.15 14:07:44.121 MODULE ( PROCESS ) : Found hosts: [‘ucsmdc’]
30.06.15 14:07:44.143 MODULE ( PROCESS ) : Found hosts: [‘ucsbdc’]
30.06.15 14:07:44.183 MODULE ( PROCESS ) : Found hosts: [‘ucssdc’, ‘ucssdc1’]
30.06.15 14:07:44.272 MODULE ( PROCESS ) : Found hosts: [‘odooerpdev1’, ‘odooerpstg1’, ‘odooerpprd1’, ‘mailprd1a’, ‘nagiosprd1a’]
30.06.15 14:08:39.254 MODULE ( PROCESS ) : Try to install (install) samba4 on ucsbdc. Force? False. Only master packages? False. Prevent installation on other systems? None. Only dry run? True.
30.06.15 14:09:07.424 MODULE ( PROCESS ) : Found hosts: [‘ucsmdc’]
30.06.15 14:09:07.447 MODULE ( PROCESS ) : Found hosts: [‘ucsbdc’]
30.06.15 14:09:07.488 MODULE ( PROCESS ) : Found hosts: [‘ucssdc’, ‘ucssdc1’]
30.06.15 14:09:07.579 MODULE ( PROCESS ) : Found hosts: [‘odooerpdev1’, ‘odooerpstg1’, ‘odooerpprd1’, ‘mailprd1a’, ‘nagiosprd1a’]
30.06.15 14:09:07.633 MODULE ( PROCESS ) : Found hosts: [‘ucsmdc’]
30.06.15 14:09:07.654 MODULE ( PROCESS ) : Found hosts: [‘ucsbdc’]
30.06.15 14:09:07.692 MODULE ( PROCESS ) : Found hosts: [‘ucssdc’, ‘ucssdc1’]
30.06.15 14:09:07.781 MODULE ( PROCESS ) : Found hosts: [‘odooerpdev1’, ‘odooerpstg1’, ‘odooerpprd1’, ‘mailprd1a’, ‘nagiosprd1a’]
30.06.15 14:09:46.574 MODULE ( PROCESS ) : Try to install (install) samba4 on ucsmdc. Force? False. Only master packages? False. Prevent installation on other systems? None. Only dry run? True.
30.06.15 14:09:46.642 MODULE ( PROCESS ) : Starting dry_run for samba4 on localhost
30.06.15 14:09:46.859 MODULE ( WARN ) :
Further information regarding this error:
Error: Unable to correct problems, you have held broken packages.
30.06.15 14:09:47.081 MODULE ( PROCESS ) : Finished dry_run for samba4 on localhost
30.06.15 14:09:47.083 MODULE ( PROCESS ) : Problems encountered or confirmation required. Removing component samba4

I also get this error “/usr/lib/python2.7/dist-packages/debian/deb822.py:200: UnicodeWarning: decoding from utf-8 failed; attempting to detect the true encoding” when running “univention-upgrade” from CLI however it appears to still pull updates just fine.


#2

Never mind, tried it 2 more times and the 3rd time it worked. Not sure what went on there…but I have AD installed now.