Unable to install Let's Encrypt - Error performing the action

I was trying to enable the SAML by following this article and after doing that, my site is no more loading with https, and when I try to install the let’s encrypt again, I am getting an error as shown in the image below.


And when I try to install let’s encrypt from the command line I am getting below errors.


Any help? Thanks in advance.

@fbartels @damrose Sorry for mentioning you here. Do you have any idea how can I fix this problem?

I’d check the current content of your /etc/apt/sources.list.d/15_ucs-online-version.list and /etc/apt/sources.list.d/20_ucs-online-component.list. I see it on my test system from time to time that these are not correctly filled because of an ssl issue. in my case an update-ca-certificates followed by ucr commit /etc/apt/sources.list.d/15_ucs-online-version.list solves it for me.

PS: For error messages out of a console a copy & paste of the text is imho preferred to a screenshot (at least by me) as this makes is way easier to read and also copy & paste error messages for further lookups.

This forum is using markdown for formatting (you could use a code block for this), but there is also a button for this in the editor.

Thanks a lot. This fixed the issue. You are amazing :slight_smile:

1 Like

It seems like the problem is not fully resolved. I am getting an error as “Couldn’t resolve host name” from my application and when I checked in internet I could see that the reason may be because of the mismatch of the common name in the certificate and FQDN. When I was trying to set the SAML I ran some commands which does change the certificate configuration. As the SSL is back now, I would like to revert the changes I have done as part of SAML configuration to default. Can anyone please help me how to do this?

I have fixed that issue. There was an additional entry in the DNS module (univention/management/#module=udm:dns/dns:0:) removing that fixed it.