UMC: Webfrontend-Fehler / kein Login möglich

german

#1

Hallo Forum,

seit kurzem ist auf einem Master UCS kein UMC Login mehr möglich, mind. 2 User versucht.

Exakter Fehler im Browser: Webfrontend-Fehler: Die angegebene Anfrage ist nicht bekannt. Fehlernachricht des Servers: Webfrontend-Fehler: Die angegebene Anfrage ist nicht bekannt.

Obwohl ich bereits UCR umc/server/debug/level sowie umc/module/debug/level auf 4 gesetzt habe, liefern sowohl ~log/univention/management-console-web-server.log als auch ~log/univention/management-console-server.log keinen Hinweis:

~log/univention/management-console-web-server.log

18.07.16 11:35:55.932 DEBUG_INIT 18.07.16 11:35:55.935 MAIN ( PROCESS ) : Stopping UMC web server ... 18.07.16 11:35:55.936 MAIN ( PROCESS ) : Starting UMC web server ... 18.07.16 14:06:36.446 DEBUG_INIT 18.07.16 14:06:36.512 MAIN ( INFO ) : Reloading SAML service provider configuration

~log/univention/management-console-server.log

18.07.16 11:35:48.303 DEBUG_INIT 18.07.16 11:35:48.305 MAIN ( PROCESS ) : Stopping UMC server ... 18.07.16 11:35:48.306 MAIN ( PROCESS ) : The UMC server is still running. Will wait for 5 seconds 18.07.16 11:35:48.306 MAIN ( WARN ) : Shutting down all open connections 18.07.16 11:35:48.807 MAIN ( PROCESS ) : Starting UMC server ... 18.07.16 11:35:49.302 MAIN ( PROCESS ) : Server started

Auch

root@xxxxx ~www/univention-management-console # service univention-management-console-web-server restart Restarting Univention Management Console Web Server. done. root@xxxxx ~www/univention-management-console # service univention-management-console-server restart Restarting Univention Management Console Server. done.

bringt nichts :confused:

Lediglich ~log/apache2/access.log liefert einen Hinweis, dass der POST beim Login auf die URL /univention-management-console/auth mit 404 scheitert:

xxxxx.yyyyyy-main.local:443 10.1.2.1 - - [18/Jul/2016:15:17:41 +0200] "POST /univention-management-console/blank.html HTTP/1.1" 200 855 "https://gate.xxxxxxx.at:10343/univention-management-console/login.html" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Ubuntu Chromium/51.0.2704.79 Chrome/51.0.2704.79 Safari/537.36" xxxxx.yyyyyy-main-main.local:443 10.1.2.1 - - [18/Jul/2016:15:17:41 +0200] "POST /univention-management-console/auth HTTP/1.1" 404 563 "https://gate.xxxxxxx.at:10343/univention-management-console/?lang=de-DE" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Ubuntu Chromium/51.0.2704.79 Chrome/51.0.2704.79 Safari/537.36" xxxxx.yyyyyy-main.local:443 10.1.2.1 - - [18/Jul/2016:15:17:41 +0200] "GET /univention-management-console/login.html HTTP/1.1" 200 899 "https://gate.xxxxxxx.at:10343/univention-management-console/blank.html" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Ubuntu Chromium/51.0.2704.79 Chrome/51.0.2704.79 Safari/537.36"

Soweit ich das verstehe, wird laut

root@xxxxxx ~www/univention-management-console # grep auth /etc/apache2/sites-enabled/univention-management-console ProxyPassMatch /univention-management-console/((set|get|logout|saml|auth|upload|command).*) http://127.0.0.1:8090/$1 retry=0 <LocationMatch "^/univention-management-console/(set|get|logout|saml|auth|upload|command).*">

hier diese ‘auth’ URL auf lokalen “Proxy” 127.0.0.1:8090 umgeleitet. Dort horcht ansch. auch ein Prozess:

root@xxxxx ~www/univention-management-console # netstat -tulpe | grep 8090 tcp 0 0 localhost:8090 *:* LISTEN root 122006 16464/mms

Hmm …?

Da Zarafa Webapp oder OPSI Web-Console Login funktioniert sowie auch Win-Clients keine Probleme beim Login haben (definitiv am Server) würde ich Backend/LDAP Ursachen mal ausschließen.

Danke für jeden Hinweis,
Robert


#2

Hallo nochmal,

nachdem ich das Problem nun ansch. gelöst habe, mache ich jetzt mal die Ingrid :wink:

Ich hätte gestern erwähnen sollen, dass vor einigen Tagen ein “Acronis Backup Cloud Agent” auf dem Host installiert wurde. Dieser bringt einen Service ‘mms’ mit welcher hier nun ebenfalls auf ‘localhost:8090’ horcht und UMC web server verdrängte. UCS Default sitzt hier aber eben UMC web server in Form von ‘python2.7’:

root@xxxxx ~ # netstat -tulpe | grep 8090 tcp 0 0 localhost:8090 *:* LISTEN root 2247443306 32335/python2.7

Im Gegensatz zu Acronis (keine anpassbare Port Konfig gefunden) ist UCS natürlich flexibel und ein simple Änderung des UCR Keys umc/http/port: 8091 inkl. anschließendem Neustart der Services

root@xxxxxxx ~ # service univention-management-console-web-server restart; service univention-management-console-server restart; service apache2 reload

führt nun zu friedlicher Koexistenz:

root@xxxx ~ # netstat -tulpe | egrep '8091|8090' :( tcp 0 0 localhost:8090 *:* LISTEN root 2618036 17786/mms tcp 0 0 localhost:8091 *:* LISTEN root 2637298 19666/python2.7

Jedenfalls Danke fürs Lesen und Mit-Rätseln,
VG Robert