UMC - replace existing widgets, error during user creation


#1

Hi,

I am currently trying to replace the “title” field for the user/users module by using a Dynamic Selection.
The goal is to simplify and standardize the used values.

As far as I can see the replacement works when creating a user object in advanced mode or when modifying existing users.

But using the simplified wizard-style method to create a user an error is thrown (and the list-box is empty)

in management-console-web-server.log I see this:

20.06.17 13:17:07.138  MAIN        ( INFO    ) : CPCommand (192.168.133.1:33894) got new request
20.06.17 13:17:07.138  MAIN        ( INFO    ) : CPCommand (192.168.133.1:33894) pushed request(0x7fa607a68210) to queue(0x7fa607d13290) - waiting for response
20.06.17 13:17:07.236  MAIN        ( INFO    ) : UMCP_Dispatcher: check_queue: new request: 0x7fa607a68210
20.06.17 13:17:07.236  MAIN        ( INFO    ) : SessionClient(0x7fa60788b790): sending request(149795742713861-431)
20.06.17 13:17:07.236  PROTOCOL    ( INFO    ) : Sending UMCP COMMAND REQUEST 149795742713861-431
20.06.17 13:17:07.239  PARSER      ( INFO    ) : UMCP RESPONSE 149795742713861-431 parsed successfully
20.06.17 13:17:07.239  PROTOCOL    ( INFO    ) : Received UMCP RESPONSE 149795742713861-431
20.06.17 13:17:07.239  MAIN        ( INFO    ) : SessionClient(0x7fa60788b790): got response(149795742713861-431): status=422 queue=0x7fa607d13290
20.06.17 13:17:07.239  MAIN        ( INFO    ) : CPCommand (192.168.133.1:33894) got response(0x7fa607a68150) from queue(0x7fa607d13290): status=422
20.06.17 13:17:07.239  MAIN        ( PROCESS ) : CPCommand (192.168.133.1:33894) response status code: 422
20.06.17 13:17:07.239  MAIN        ( PROCESS ) : CPCommand (192.168.133.1:33894) response message: 1 error(s) occurred
20.06.17 13:17:07.239  MAIN        ( PROCESS ) : CPCommand (192.168.133.1:33894) response result: {'syntax': 'Argument required'}

As far as I have seen this happens to me when the name of the extended attribute is equal to the original attribute.

DN: cn=title,cn=custom attributes,cn=univention,dc=mydomain,dc=intranet
ARG: None
  objectClass: organizationalPerson
  groupPosition: None
  module: users/user
  overwritePosition: title
  hook: None
  overwriteTab: None
  shortDescription: Title (custom)
  groupName: None
  version: 2
  valueRequired: None
  CLIName: title
  fullWidth: None
  longDescription: title (e.g. Dr., PD. Dr., Prof. Dr.)
  doNotSearch: None
  tabName: None
  syntax: DS_Title
  tabAdvanced: None
  name: title
  default: None
  mayChange: 1
  multivalue: 0
  ldapMapping: title
  deleteObjectClass: 0
  notEditable: 0
  tabPosition: None
  disableUDMWeb: None

I also tried to define the EA with another name and just defined “overwritePosition: title”. With this I get the same result for existing users but the creation of new users is not possible as the first page of the wizard will not load.

Any ideas what I am doing wrong?

Best Regards,
Dirk


#2

Hi Dirk,

As far as I know, you do not need a custom attribute. Just set your new syntax class and set this syntax via UCR variable (ucr set directory/manager/web/modules/users/user/properties/title/syntax=DS_title).

A bug in UCS 4.1 which is fixed in errata 376 (see https://errata.software-univention.de/ucs/4.1/376.html). It looks like you have UCS 4.2 so this should be fixed.

Could you fill out a bug report for this issue?

Regards,
Tobi


#3

Hi,

thanks for for pointing to the ability using an UCRV to override the syntax. (great thing btw.)

As the reported error occurs also when using this method I have filed Bug 44847 - Validation error when using overwritten syntax class when creating new user as recommended.

Best Regards,
Dirk


#4

The remaining issue was resolved by http://errata.software-univention.de/ucs/4.2/83.html.
The customer is very pleased that the fix was provided so fast