UGS sender-rewriting

mail
german

#1

Hallo,

ich habe ein Problem mit dem UGS und dem Empfangen von E-Mails:
Verschickt, in diesem Fall Mailman (mit Postfix), eine Mail mit dem Absender 'mailman-bounces@example.com’ dort steht. So ist eine Antwort an den ursprünglichen Absender nicht mehr möglich.

Kann ich dieses ‘sender-rewriting’ deaktivieren und wenn ja, wo? Gibt es Gründe dagegen?

Im voraus vielen Dank.


#2

Hallo,

mir ist nicht bekannt das von UGS ein rewrite durchgeführt wird. Evtl. können Sie das Problem umgehen indem Sie eine UGS Mail Domäne für lists.example.com anlegen?

Mit freundlichen Grüßen
Janis Meybohm


#3

Hallo,

Der Mailman befindet sich nicht auf den UGS selbst und ist als IP-Managed-Client eingetragen, als:
Servername: mailman
in der DNS-Zone: lists.example.com. Dort steht der MX-Record auf “10 mailman.lists.example.com.”

In der mail.log vom UGS steht folgendes:

Stelle ich den relayhost des Mailmans auf einen anderen Mailserver, behält der Absender seine Subdomain.

Ich weiß leider nicht, wo ich da am besten ansetzen kann. Ich hatte schon den relay=kolabfilter im Verdacht, jedoch denke ich, das dieser Filter erst “später” durchlaufen wird.

Mit freundlichen Grüßen,
Sven


#4

Hallo,

auf UCS Systemen ist Postfix so Konfiguriert, dass Masquerading auf die eigene Domain, beim Relay von E-Mails angewendet wird. Dieses Verhalten lässt sich über eine Univention Configuration Registry-Variable mit folgendem Befehl ändern:

ucr set postfix/masquerade/domains="\$mydomain lists.\$mydomain"

Nach einem Neustart des Postfix, werden E-Mails von “list.example.com” nicht mehr auf “example.com” umgeschrieben.

Mit freundlichen Grüßen
Tobias Scherer


#5

Vielen Dank für die Hilfe, das war das Problem!

Allerdings muss beachtet werden, dass diese Variable von links nach rechts ausgelesen wird und beim ersten Treffer anschlägt. Daher muss ‘lists.$mydomain’ zuerst eingetragen werden:

ucr set postfix/masquerade/domains="lists.example.com example.com"

Mit freundlichen Grüßen,
Sven