UCS4.2 Tests on VirtualBox Install Problems

virtualization
ucs-4-2
virtualbox

#1

Hello,
I want to test the last version of UCS 4.2 SM in VirtualBox (5.1.8) environment.
The UCS step 2 (UCS configuration : selecting domain setup) freeze
See included file
Can you help me to solve this problem ?
Thanks
Claude from France


#2

There is a release candidate now online - can you check the behaviour with this?


#3

Yes of course
I download this, test and reply
Thanks
Claude


#4

Same result with UCS-4.2 RC. (See attached files)
Has anyone tried to run UCS-4.2 RC under virtualbox?
How to test efficiency if UCS does not work in virtual machine?
First file : Freeze
See preceding file because it is impossible to joint 2 files or more in this forum !

Second file : after 2 or 3mn after page reload

Thanks to help me for help you.

Claude


#5

Hi!

It's not impossible :slight_smile: New users will be granted this permission (and many more) automatically, if they stick around a bit longer. See also https://meta.discourse.org/t/what-do-user-trust-levels-do/4924

Best regards,
Michael Grandjean


#6

Thanks Michael
I see that you are part of the staff of Univention
Do you know who can answer my problem at Univention?
Is the problem known to univention?

Claude


#7

Hi
I would like to relaunch you on this subject because I do not understand very well how we can help you to test while UCS4. 2 does not work in virtual machine.
Is it inevitably necessary to have a physical machine to test this new version?
It is also worrying that there is not specific forum for this new version, I see only few post on UCS4. 2, everything is mixed, no consistent remarks or bugs reports.
Also, as I said, there are too many posts in German it bothers the help which they can bring.
Is UCS only for the Germans people ?
I am very disappointed by this product which seemed to me to be the best in its category
I am also disappointed by the non-replies of the development team on a question nevertheless basic concerning the operation in virtual machine
However, I will continue to be interested in UCS if you answer my questions
Remark : if new version dont work in virtual machine, is it possible to have a docker container for that ?
Regards
Claude


#8

Hello Claude,

I’m sorry we disappointed you. I know it can be frustrating if things don’t work and there are no helpful replies. Let me try to clear things up.

It does. Please note that it is not working in your VirtualBox installation. However, the release candidate of UCS 4.2 is running fine as a virtual machine on common Type-1 hypervisors such as Xen (AWS) and KVM (I’m counting KVM as Type-1 here) - there are automated product tests for this and I verified it myself. VirtualBox is a Type-2 hypervisor and while those are great for testing things, they are not the right choice to run virtual machines in production. So please understand, that support of production relevant features has a higher priority than support for such features that are meant for testing.
That being said, I tried to reproduce your issue with VirtualBox (5.1.18, Windows 10) today, but it’s working just fine for me :confused: I had no freezes. More on that further down.

No :slight_smile: Virtual machines in general are just fine. But there might be a specific problem with VirtualBox.

I don’t understand why there should be an extra forum just for a new minor version, to be honest. Maybe you can write more on that? Always happy to learn.
There is the category for UCS and there are tags for the UCS version. For UCS 4.2 it’s ucs-4-2, but people need to use it. Tags are great for sorting and searching.
The bug tracker is https://forge.univention.org

Of course it’s not. By now, we ask the participants to use english in the posting guidelines.
Please understand that a large part of the userbase is german speaking and since Univention is based in Germany, many people tend to use german. We do understand that this is exclusionary and we try to change this step by step.

It is :slight_smile: I encourage you to try another hypervisor or review your VirtualBox settings.
Don’t get me wrong, this might as well be an issue with your setup and should not make you disappointed by the whole product.

Please understand that this is a community-driven forum. Although Univention staff members participate, there is no guarantee that someone at Univention will personally assist you here in the forum (we do have Enterprise Support for that). But be assured, that all topics on help.univention.com are monitored by Univention and that actual bugs get added to the bug tracker.

That being said, I tried to reproduce your issue. I downloaded the UCS 4.2 RC ISO here:
http://updates-test.software-univention.de/download/UCS-4.2-Preview/
Then I installed the latest VirtualBox (5.1.18) on Windows 10 (amd64) and configured a new virtual machine. I chose ‘Debian (amd64)’ as template. The only default setting I changed was the network settings - I changed that from NAT to Network Bridge. Then I powered up the VM and was able to install UCS 4.2 without problems:

After the installation finished, I was able to access the webinterface:

Best regards,
Michael Grandjean


#9

First of all thank you very much for having answered in a complete and precise way

  • I have a little overdone to provoke a reaction :slight_smile:
    Regarding virtualbox virtual machine operation , I will try again and inform you for results.
    If UCS does not work under VirtualBox then it is better to announce it clearly in the blog for example (in the announcement)
  • i don’t agree with you concerning the 4.2 because its not a minor version for me. Docker application integration, Debian8, Kernel 4.9, … are a major enhancements for me and your work had to be enormous.
  • I understand that it is necessary to take time for everyone to post in English on the forum.
  • I also understand that the priority be given to the business version.
  • For other software, often there is a special category in forums or a sub forum until the candidate version of the software (included).
  • I can not find a tag for ucs4. 2 (in fact ucs4.2 dont appear on search field when you create a new topic. But it appear when you enter ucs in the same search field, in the option you find ucs4.2 … curious)

Thank you so much for taking time to answer me
Friendly
Claude