UCS Update schlägt fehl: 4.04-errata 320 bei Owncloud

german

#1

Hallo,
bin bei UCS 4.04 und die Paketaktualisierungen schlagen beim Owncloud Teil fehl. Anscheinend liegen angeforderte Pakete nicht (mehr) auf den Update Sourcen:
Teillog:

Err http://appcenter.software-univention.de/univention-repository/4.0/maintained/component/ owncloud8_20160105/all/ owncloud 2016.8.0.10-enterprise-0 404 Not Found [IP: 176.9.114.147 80] Err http://appcenter.software-univention.de/univention-repository/4.0/maintained/component/ owncloud8_20160105/all/ owncloud-meta-8.0 8.0 404 Not Found [IP: 176.9.114.147 80] Failed to fetch http://appcenter.software-univention.de/univention-repository/4.0/maintained/component/owncloud8_20161205/all/owncloud_2016.8.0.10-enterprise-0_all.deb 404 Not Found [IP: 176.9.114.147 80] Failed to fetch http://appcenter.software-univention.de/univention-repository/4.0/maintained/component/owncloud8_20161205/all/owncloud-meta-8.0_all.deb 404 Not Found [IP: 176.9.114.147 80]

das gesamte Log:

Starting dist-upgrade at Tue Feb 16 17:47:02 CET 2016
Reading package lists...
Building dependency tree...
Reading state information...
The following NEW packages will be installed:
lockfile-progs python-paramiko
The following packages will be upgraded:
e2fslibs e2fsprogs ldap-utils ldb-tools libapache2-mod-php5 libcomerr2
libcups2 libcupsimage2 libgd2-xpm libgnutls26 libldap-2.4-2 libldb1
libmysqlclient18 libpq5 libsmbclient libss2 libtasn1-3 libwbclient0
mysql-client-5.5 mysql-common mysql-server mysql-server-5.5
mysql-server-core-5.5 ntp ntpdate openssh-client openssh-server owncloud
owncloud-meta-8.0 php-pear php5 php5-cli php5-common php5-curl php5-gd
php5-ldap php5-mapi php5-mysql postgresql-client-9.1 python-ldb python-mapi
python-samba python-univention-appcenter python-univention-connector-s4
python-univention-directory-manager python-univention-directory-manager-cli
python-univention-directory-manager-legacy-ucd-tcs python-univention-lib
rpcbind samba samba-common samba-common-bin samba-dsdb-modules samba-libs
samba-vfs-modules shell-univention-lib slapd smbclient univention-apache
univention-base-files univention-base-packages univention-directory-listener
univention-directory-manager-tools univention-errata-level
univention-management-console-frontend
univention-management-console-frontend-theme
univention-management-console-module-appcenter
univention-management-console-module-apps
univention-management-console-module-diagnostic
univention-management-console-module-lib
univention-management-console-module-udm
univention-management-console-module-updater
univention-management-console-web-server univention-pam
univention-s4-connector univention-samba4 univention-samba4-sysvol-sync
univention-updater winbind z-push zarafa zarafa-backup zarafa-client
zarafa-common zarafa-contacts zarafa-dagent zarafa-gateway zarafa-ical
zarafa-libarchiver zarafa-libs zarafa-licensed zarafa-monitor zarafa-search
zarafa-server zarafa-spooler zarafa-utils zarafa-webaccess
zarafa-webaccess-muc zarafa-webapp zarafa4ucs zarafa4ucs-schema
zarafa4ucs-udm zarafa4ucs-webapp
103 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 29.5 MB/110 MB of archives.
After this operation, 10.6 MB of additional disk space will be used.
Err http://appcenter.software-univention.de/univention-repository/4.0/maintained/component/ owncloud8_20160105/all/ owncloud 2016.8.0.10-enterprise-0
404 Not Found [IP: 176.9.114.147 80]
Err http://appcenter.software-univention.de/univention-repository/4.0/maintained/component/ owncloud8_20160105/all/ owncloud-meta-8.0 8.0
404 Not Found [IP: 176.9.114.147 80]
Failed to fetch http://appcenter.software-univention.de/univention-repository/4.0/maintained/component/owncloud8_20161205/all/owncloud_2016.8.0.10-enterprise-0_all.deb 404 Not Found [IP: 176.9.114.147 80]
Failed to fetch http://appcenter.software-univention.de/univention-repository/4.0/maintained/component/owncloud8_20161205/all/owncloud-meta-8.0_all.deb 404 Not Found [IP: 176.9.114.147 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

ERROR: An error occurred during update. Please check the logfiles.
Tue Feb 16 17:47:02 CET 2016

Starting univention-upgrade. Current UCS version is 4.0-3 errata320

Checking for local repository: skipped
Checking for release updates:
Please rerun command without --check argument to install.

gibt es dafür ein Update oder einen Tipp?

vielen Dank
Gerd


#2

Hallo,

es sieht so aus, als würde dieses Repository, genauer: die Packages einen falschen Pfad (owncloud8_20161205 statt owncloud8_20160105) enthalten. Das kann nur Univention beheben.
Sie könnten temporär dieses Repository deaktivieren (UCRV repository/online/component/owncloud8…). Wenn die App einmal installiert ist, gibts da sowieso nichts neues zu sehen.
Oder Sie gehen gleich auf ownCloud 8.1. Für 8.0 werden wir nach dem letzten Stand keine Updates mehr liefern. Außerdem ist die 8.1 Bedingung für UCS 4.1.

Viele Grüße,
Dirk Ahrnke


#3

Hallo,

ja, das war ein Fehler auf unserer Seite. Entschuldigen Sie bitte die Unannehmlichkeiten. Ich habe die Packages-Datei korrigiert; jetzt sollte die Installation klappen. Falls das Update noch nicht eingespielt ist, kann man nun das App Center aufrufen. Oder (wenn das Repository bereits eingebunden ist) es läuft über das Software Update-Modul.

Viele Grüße
Dirk Wiesenthal


#4

Hallo zusammen,
jetzt hat das Update geklappt, bin jetzt bei 4.04-errata 398.
Vielen Dank für das Update.

Leider wird kein Update auf Owncloud 8.1 angeboten. Dadurch ist wohl auch die Migration auf 4.1 nicht möglich.

Hat dafür auch noch jemand einen Tipp?

danke
Gerd


#5

Es gibt ownCloud 8.1 als separate App. Wenn Sie die installieren, macht die Installationsroutine das Upgrade der bestehenden ownCloud 8.0 Instanz.
Gründe für diese Verfahrensweise hatte ich u.a. in ownCloud 8.0.8 -> 8.1.3 genannt.

Zumindest bei 8.1 / 8.2 bleibt das erstmal so. Leider.

Viele Grüße,
Dirk Ahrnke