UCS Update in stuck

At my actual UCS Server I can´t run Update.UCS. Nothing happen and the last Version is 4.4-4 errata587. On another Server (Test) I´ll got 4.4-4 errata617.

What´s going wrong?

Maybe you have damaged package install

try on cli “apt update” and “apt upgrade” to check if there are some errors there


Hi Christian,

thank you for your reply.
I tried apt upadate with the result:

Paketlisten werden gelesen… Fertig
E: The repository ‘http://repo.z-hub.io/z-push:/final/Univention_4.3 Release’ does no longer have a Release file.
N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

and apt upgrade with:
Paketlisten werden gelesen… Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen… Fertig
Paketaktualisierung (Upgrade) wird berechnet… Fertig
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.

So nothing changed.

Any Idea additionally?

BR Thomas

Solution found: The repository setting “4.4-4-errata” was lost- Recreating the entry has solved the issue.

1 Like

Just as a note - exactly the same happened on some of my servers - update stuck at 4.4-4 errata587. And also the solution for me was the same: just adding the 4.4-4 repositories.

# ucr set repository/online/component/4.4-3-errata=false
# ucr set repository/online/component/4.4-4-errata/description='Errata updates for UCS 4.4-4'
# ucr set repository/online/component/4.4-4-errata/version='4.4'
# ucr set repository/online/component/4.4-4-errata=enabled

### and then, within a screen:
# dpkg --configure -a
# apt --fix-broken install
# univention-upgrade  --ignoressh --noninteractive --ignoreterm

It seems that a former update was not executed properly for unknown reason. After the package “apt-utils” was repaired (happens automatically after you confirm with “Y”) everything went smoth.