UCS update help


#1

Hello!
I am in the process of updating our univention server, but keep running into a dependency error.
Anybody seen this before and got any suggestions on how to fix ?
All the best

Ras

$apt-get -o DPkg::Options::=--force-confold -o DPkg::Options::=--force-overwrite -o DPkg::Options::=--force-overwrite-dir --trivial-only=no --assume-yes --quiet=1 -u dist-upgrade
Reading package lists...
Building dependency tree...
Reading state information...
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 consolekit : Depends: libck-connector0 (= 0.4.5-3.1.12.201409242141) but 0.4.6-5A~4.2.0.201702171811 is installed
 libc-dev-bin : Depends: libc6 (< 2.14)
                Recommends: manpages-dev but it is not installed
 libc6-dev : Depends: libc6 (= 2.13-38.29.201602161811)
 libnih1 : Depends: libc6 (< 2.14)
 libsecret-1-0 : Depends: libglib2.0-0 (>= 2.38.0) but 2.33.12+really2.32.4-5.53.201403140822 is installed
 libudisks2-0 : Depends: libglib2.0-0 (>= 2.37.3) but 2.33.12+really2.32.4-5.53.201403140822 is installed
E: Unmet dependencies. Try using -f.

#2

Some more info geez im going crazy :frowning:
UPDATER :

Checking for space on /var/cache/apt/archives: OK
Checking for space on /boot: OK
Checking for space on /: OK
Checking for package status: rF ifupdown 0.7.53.1 amd64 high level tools to configure network interfaces
iU libsecret-1-0:amd64 0.18-1+b1 amd64 Secret store
iU libudisks2-0:amd64 2.1.3-5 amd64 GObject based library to access udisks2
failed
ERROR: The package state on this system is inconsistent.
Please run 'dpkg --configure -a' manually
Error: Update aborted by pre-update script of release 4.2-0
root@ucs-3:~# dpkg --configure -a
dpkg: dependency problems prevent configuration of libudisks2-0:amd64:
 libudisks2-0:amd64 depends on libglib2.0-0 (>= 2.37.3); however:
  Version of libglib2.0-0:amd64 on system is 2.33.12+really2.32.4-5.53.201403140822.

dpkg: error processing libudisks2-0:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libsecret-1-0:amd64:
 libsecret-1-0:amd64 depends on libglib2.0-0 (>= 2.38.0); however:
  Version of libglib2.0-0:amd64 on system is 2.33.12+really2.32.4-5.53.201403140822.

dpkg: error processing libsecret-1-0:amd64 (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 libudisks2-0:amd64
 libsecret-1-0:amd64
root@ucs-3:~# apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... failed.
The following packages have unmet dependencies:
 consolekit : Depends: libck-connector0 (= 0.4.5-3.1.12.201409242141) but 0.4.6-5A~4.2.0.201702171811 is installed
 libc-dev-bin : Depends: libc6 (< 2.14)
                Recommends: manpages-dev but it is not installed
 libc6-dev : Depends: libc6 (= 2.13-38.29.201602161811)
 libnih1 : Depends: libc6 (< 2.14)
 libsecret-1-0 : Depends: libglib2.0-0 (>= 2.38.0) but 2.33.12+really2.32.4-5.53.201403140822 is installed
 libudisks2-0 : Depends: libglib2.0-0 (>= 2.37.3) but 2.33.12+really2.32.4-5.53.201403140822 is installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies

#3

Hey,

this looks like you’re trying to recover from an upgrade from 4.x to 4.x+1 that aborted somewhere in the middle. Is that correct? Which was the old version, which one is the new one you’re trying to upgrade to?

If you have backups from before starting the upgrade, you should probably restore them and re-attempt the upgrade. If it fails again, post your /var/log/univention/updater.log afterwards so that we can take a look at the issue.

Kind regards,
mosu