UCS - Ubuntu Home Share Problems with various programs - Solved


Hi everyone,

i am working on a proof of concept for a customer.
We are trying to migrate to ubuntu clients.
I joined the client to the domain(with the univentiontool) and i am mounting the home directory via pam.
Everything is working fine, i can login, the home is mounted accordingly and so on.

some programs just do not work properly when the user is logged in and using the home share on the ucs server.
For example, firefox opens really slow and crashes after a while.
Chromium has the same issue.
We are using ubuntu 18.04 for the tests.
Doesnt matter if i use nfs or cifs for home mounting.

I executed the binarys of these programs via strace - but i really got no big clue as to what the problem is.
A few assumption i have are:
it may be connected to how this programs store there database/NSS.
Chromium outputs for example:
Error initializing NSS with a persistent database. NSS Error Code: -8025

Does anyone have any ideas to what this might be connected or where i could look further?

Thanks in advance!


Should be fixed in Firefox 61



thanks for your answer.
I tried the settings suggested in the Bugreport, but it didnt really change that much.
Maybe a little faster, but overall the problems persisted, so I hope this gets fixed with FF61.

But: it seems to me that there is a larger problem behind all this. Since a lot of other applications also dont work as they should, so I guess this is only one part of the puzzle :wink:


There are sometimes issues with NFS-Locks.

Try to mount your NFS-/home with “v4” option.

You can test before if you have an issue with locks. Just cd into a NFS-mounted directory and execute:

touch testfile ; flock ./testfile true && echo ok || echo nok ; rm testfile
flock: ./test: No locks available 

If the output is similar to the above one you have a lock-issue.




in general locking works just fine over NFSv3:

[0 mbunkus@chai-latte /net/kyushu/home/mbunkus] grep '/net/kyushu/home.*vers=.' /proc/mounts
kyushu:/home /net/kyushu/home nfs rw,noatime,vers=3,rsize=1048576,wsize=1048576,namlen=255,hard,proto=tcp,timeo=600,retrans=2,sec=sys,mountaddr=,mountvers=3,mountport=32767,mountproto=tcp,local_lock=none,addr= 0 0
[0 mbunkus@chai-latte /net/kyushu/home/mbunkus] touch testfile
[0 mbunkus@chai-latte /net/kyushu/home/mbunkus] flock testfile true && echo succeeded || echo failed

Meaning: you don’t need NFSv4 for that.

But I agree that verifying that locking works is a valuable step.


That’s absolutely true. I have the experience with UCS 4.3.x locking in NFSv3 not working properly any more. 4.2.x no issues. 4.3.x - locking issues with NFSv3, working fine with NFSv4. I am still investigating the root cause.

Lock issues are very likely seen with Firefox, sometimes LibreOffice. I assume other programs use locks in a different way.


CIFS was the same issue with locking, a test with:

oplocks = no
level2 oplocks = no
locking = no
strict locking = no
share modes = no
blocking locks = no

solved it. So, issue is solved. Thanks for the helpful pointers guys!