UCS-Server mit VMXNET3 unter VMware ESXi 6.7 - Wie?

Hallo,

Im Handbuch steht (https://docs.software-univention.de/handbuch-4.4.html)

2.15. Installation in VMware

Wird UCS als Gast in VMware installiert muss als Gastbetriebssystem die Option Linux -> Anderes Linux-System ausgewählt werden (UCS basiert zwar auf Debian, die Vorlagen für Debian können aber nicht verwendet werden).

Der in UCS verwendete Linux-Kernel bringt alle nötigen Unterstützungstreiber für den Betrieb in VMware direkt mit ( vmw_balloon , vmw_pvsci , vmw_vmci , vmwgfx und vmxnet3 ).

Wenn man jedoch beim Erstellen der VM “Linux -> Other Linux (64-bit)” auswählt, dann ist nur die “E1000” verfügbar, nicht aber die VMXNET3.

"Debian GNU/Linux 10 (64-bit)" auswählen soll man ja nicht, wegen der Vorlagen, die nicht verwendet werden können. Da wäre die “VMXNET3” verfügbar.

Wie kommt man offiziell korrekt zur “VMXNET3”, ohne irgendwelche Seiteneffekte?

MfG

activeExhausted

Anstatt Linux -> Anderes Linux-System Anderes Linux 3.x oder höher auswählen

würde auch empfehlen die open-vm-tools zu installieren (wegen snapshots)
mit apt install open-vm-tools open-vm-tools-dkms

lg
Christian

Hallo Christian,

danke für die Lösung.

Ich habe “Linux -> Other 4.x or later Linux (64-bit)” genommen, da bei “Linux -> Other 3.x Linux (64-bit)” kein "later" mehr dabei steht.

Danke auch für den Tipp mit den open-vm-tools. Beim ucs-dc-master hatte ich das bereits gemacht gehabt bzw. gegoogelt, allerdings ohne die open-vm-tools-dkms.

Beim ucs-mail, d.h. dem Slave-System, das ich einrichten wollte funktioniert das aber nicht, wegen eines Fehlers.

.

Ich weiß nicht…, ich glaube ich gebe auf mit UCS. Seit dem 21.08. also seit ca. 10 Wochen versuche ich abends und an den Wochenenden alleine das Grundsystem d.h. einen DC (erstes System mit neuer Domäne - AD-kompatibler DC, KDE und Softwareinstallationsmonitor) und einen DC-Slave (der mal Mail-Server werden sollte, nur mit KDE, später dann mal OX) mit zum Laufen zu kriegen.

Erst mit 4.5.5, jetzt gleich mit 4.4.6. Irgendwas geht immer nicht nach der nackten Installation. Domäne-Benennungs-Fallstricke, DNS usw. Ich bin nur noch am Suchen und Lesen und probieren. Kann doch nicht sein, dass nach dem ISO-Setup immer was anderes ist. Nun im DC-Master nach der System-Diagnose:

Die folgenden KDCs waren nicht erreichbar: tcp host.org.intranet:88, udp host.org.intranet:88
Füge LO zu Samba/Interfaces Hinzu / Setzte Kerberos/KDC auf 127.0.0.1 zurück

Auf dem DC-Slave:
Warnung: Überprüfe Fehler in den sources.list Dateien
Fehler in ‘/etc/apt/sources.list.d/15_ucs-online-version.list’ gefunden: ConfigurationError: Configuration error: Network is unreachable
Fehler in ‘/etc/apt/sources.list.d/20_ucs-online-component.list’ gefunden: ConfigurationError: Configuration error: Network is unreachable
Überprüfen Sie die Dateien für mehr Details.
Dieser Fehler könnte durch eine erneute Generierung der Source-Listen behoben werden.

Bei letzterem ist auch kein apt-get update möglich bzw. die Installation der open-vm-tools.
Und auch hier habe ich gesucht… https://help.univention.com/t/sources-list-problem/4155/3:

nslookup updates.software-univention.de
ping updates.software-univention.de
ucr commit /etc/apt/sources.list.d/*

funktioniert, bringt aber nichts. Habe gerade auch gesehen, im Softwaremonitor:

|ucs-dc-master|4.4-6 errata787|Domaincontroller Master|2020-11-01 01:57:59|
|ucs-mail|4.4-6 errata750|Domaincontroller Slave|2020-11-01 03:55:11|

D.h. bei der Installation hat es das Slave-System nicht ins I-Net gepackt um die Pakete zu aktualisieren.

Ich bin zu blöd für UCS. Wie soll das erst werden, wenn mal OX oder andere Anwendungen drauf kommen…?

MfG

activeExhausted