UCS Nextcloud Caldav/Carddav Error

german
nextcloud

#1

de
Ich habe die bei dem Univention Corporate Server das Nextcloud plugin installiert. Nachdem ich in der Übersicht nach Fehlermeldungen geschaut habe, bekomme ich dort diese Fehlermeldung. Ich habe im Nextcloud docker unter /var/www/html die .htacces mit dem /nextcloud Pfad angepasst, jedoch erscheint die Fehlermeldung immer noch.


#2

Ich habe die Finger von der .htaccess gelassen.

Statt dessen habe ich folgende Zeilen im Template
/etc/univention/templates/files/etc/apache2/sites-available/ssl.d/10hsts

angefügt:

    Redirect 301 /.well-known/carddav https://ucs.<meineDomain>.de/nextcloud/remote.php/dav
    Redirect 301 /.well-known/caldav https://ucs.<meineDomain>.de/nextcloud/remote.php/dav

(auch auf die Gefahr hin, dass die Datei bei einem Upgrade nicht aktualisiert oder überschrieben wird.)

Ich bin mir nur unsicher, ob ein anschließendes

ucr commit apache2
service apache2 reload

ausreicht, da ich zusätzlich den Wert von “hsts” anpassen musste und danach auf jeden Fall das Template verarbeitet wurde.

Als Ergebnis sollten die beiden Zeilen in der
/etc/apache2/sites-enabled/default-ssl.conf etwas weiter unten zu finden sein:

...
<IfModule mod_headers.c>
Header always set Strict-Transport-Security "max-age=15552000; includeSubDomains"
</IfModule>

    Redirect 301 /.well-known/carddav https://ucs.<meineDomain>.de/nextcloud/remote.php/dav
    Redirect 301 /.well-known/caldav https://ucs.<meineDomain>.de/nextcloud/remote.php/dav

        ProxyPass /nextcloud http://127.0.0.1:40000/nextcloud retry=0
        ProxyPassReverse /nextcloud http://127.0.0.1:40000/nextcloud
</VirtualHost>


#3

image
So?


#4

So habe ich auch gemacht - ganz am Schluss.

Jetzt musst Du nur sehen, ob das Template auch mit den o.a. Befehlen verarbeitet wird (anschließende Kontrolle der /etc/apache2/sites-enabled/default-ssl.conf).


#5

Funktioniert leider nicht. Und die Config wird auch nicht in /etc/apache2/sites-enabled/default-ssl.conf übernommen.


#6

Nicht schlimm - das ändert sich schon noch. Solange kannst Du diese Einträge von Hand in der /etc/apache2/sites-enabled/default-ssl.conf ergänzen.

Dort solltest Du am Ende die des Abschnittes … die Proxy-Einträge für Nextcloud finden.
Trage darüber die beiden Zeilen noch einmal ein, wie oben beschrieben.

Danach

service apache2 reload

Ich vermute, dass ucr commit nur die Konfigurationsdateien neu schreibt, wenn mit “ucr set …” ein Wert in der UCS Registry geändert wurde.


#7

Hab jetzt nochmal die Parameter manuell eingetragen und auch den UCS Server neugestartet, jedoch kommt die Fehlermeldung in der Nextcloud immernoch.


#8

Die beiden Zeilen stehen immer noch in der /etc/apache2/sites-enabled/default-ssl.confunter

<VirtualHost *:443>
...
ProxyPass /nextcloud http://127.0.0.1:40000/nextcloud retry=0
...


#9

Bildschirmfoto%20vom%202019-08-04%2019-36-28
Ja


#10

Tut mir leid, ab hier weiß ich auch nicht weiter :frowning: