UCS Neuinstallation hängt

german

#1

Guten Tag,

wir haben einen UCS als “Domain Controller Master” neu installiert. Während
bzw. nach der Installation ergeben sich für uns folgende zwei Probleme:

Die Installation dauert ungewöhnlich lange, der Fortschritts-Balken verweilt
bei 95,5%. Auf Konsole7 (F7) und nach der Installation im Log-File
/var/log/univention/join.log wird während der langen Wartezeit folgendes
ausgegeben:

Restarting bind9 daemon: . done. Wait for bind9: .Restarting bind9 daemon: . done. .......Restarting bind9 daemon: . done. .......Restarting bind9 daemon: . done.

sowie

[code]Wait for bind9: .Stopping Samba 4 daemon: samba…
Starting Samba 4 daemon: samba.
…Stopping Samba 4 daemon: samba…
Starting Samba 4 daemon: samba.
…Stopping Samba 4 daemon: samba…
Starting Samba 4 daemon: samba.
failed
Setting dns/backend
Restarting bind9 daemon: .
done.


  • ERROR: Failed to configure Samba4 as backend for bind. *
  •    Please check the samba and the s4-connector logfile.*
    

**************************************************************[/code]

Nach der Installation ist in der “Univention Management Console (UMC)” das
Modul “Basis-Einstellungen” nicht benutzbar da nach dem Aufruf nur die “Sanduhr” zu
sehen ist.

Frage: Wie können wir das Problem lösen bzw. was machen wir hier falsch?

Es scheint das vom UCS im Netzwerk bestimmte Ressourcen erwartet, aber nicht
gefunden werden.

Viele Grüße
Holger Scholz


#2

Es scheint ein Problem mit der Initialisierung von Samba 4 während der Installation zu geben. Das einfachste dürfte sein, wenn Sie uns ein Support Info Archiv von diesem System zur Verfügung stellen, dann haben wir alle relevanten Logdateien vorliegen.

In diesem Artikel ist beschrieben, wie Sie dieses Archiv erstellen können: http://sdb.univention.de/1174. Das Archiv können Sie entweder wie im Artikel beschrieben hochladen oder an feedback@univention.de per E-Mail schicken.

Viele Grüße
Stefan Gohmann


#3

Ich habe das gleiche Problem, vollkommen reproduzierbar. Das vorgeschlagene Erstellen des Support Info Archivs geht nicht, da das zu installierende System keine funktionierende DNS-Auflösung hat:

root@ucs30:~# wget -O /tmp/univention-support-info http://download.univention.de/download/scripts/univention-support-info --2012-07-02 13:24:58-- http://download.univention.de/download/scripts/univention-support-info Resolving download.univention.de... failed: Name or service not known. wget: unable to resolve host address “download.univention.de”

Der DNS-Server ist falsch konfiguriert.

[code]root@ucs30:~# cat /etc/resolv.conf

Warning: This file is auto-generated and might be overwritten by

univention-config-registry.

Please edit the following file(s) instead:

Warnung: Diese Datei wurde automatisch generiert und kann durch

univention-config-registry überschrieben werden.

Bitte bearbeiten Sie an Stelle dessen die folgende(n) Datei(en):

/etc/univention/templates/files/etc/resolv.conf

domain kvm.local
nameserver 192.168.122.25
options timeout:2[/code]

192.168.122.25 ist aber das zu installierende System selbst und auf dem läuft bind ja noch nicht, weil er ja nicht gestartet werden kann. Konfiguriert hatte ich im Installer aber 192.168.122.1, und diese IP steht auch am Beginn der Installation noch in der resolv.conf. Irgendein Installationsskript ändert sie und ab da hängt die Installation.

Bei der Paketauswahl hatte ich übrigens Samba 4 DC gewählt, aber nicht die Option DNS-Server.

Beste Grüße,
Christoph Wickert


#4

Sehr geehrter Herr Wickert,

könnten Sie uns bitte einmal die folgenden Dateien nach der Installation zukommen lassen:
/etc/univention/installation_profile
/var/log/univention/installation.log.gz
/var/log/univention/installer.log.gz

Sie können uns die Dateien gern als Anhang an feedback@univention.de senden - ich werde die Informationen dann entsprechend verknüpfen.

Mit freundlichen Grüßen,
Tim Petersen


#5

Vielen Dank, Herr Petersen,

die Daten habe ich eben gesendet, ich habe den ganzen Ordner /var/log/univention (natürlich ohne root-Passwort), die installer_profile und noch einige Screenshoots angehängt.

Ich musste die Installation nach 4 Stunden (davon 3½ bei 95,5%) leider abbrechen. Auch beim nächsten, insgesamt 4. Versuch lief der Installer nicht durch, dieses hakte er schon etwas eher, beim Ausführen des Join-Skripts 97univention-s4-connector.inst Ein Problem mit dem LDAP verhinderte wieder die Konfiguration von bind, aber die Änderung der resolv.conf konnte ich dieses Mal nicht reproduzieren (vermutlich, weil das darauffolgende Join-Skript nicht ausgeführt wurde. Erst als ich Samba 4 DC abgewählt hatte, lief die Installation endlich durch.

Die Umgebung in der ich installiere ist KVM unter Fedora 17 x86_64
kernel-3.4.3-1.fc17.x86_64
qemu-kvm-1.0-17.fc17.x86_64
libvirt-0.9.11.3-1.fc17.x86_64

Ich hatte unter KVM schon mit dem RC Probleme und hatte dazu zwei Bugs aufgemacht (25246 und 25247). Ich hoffe, die Logdateien helfen Ihnen bei der Analyse des Problems.

Beste Grüße,
Christoph Wickert


#6

Sehr geehrter Herr Wickert,

die Ursache für die Verzögerungen und Umstände bei Ihrer Installation eines neuen DC Masters in Version 3.0 in Verbindung mit Samba 4 liegt bei der Wahl der Windows-Domain.
Der Hostname eines Systems sollte nicht der Windows-Domain entsprechen. Daher schlägt der Installer auch standardmäßig nach Angabe des FQDN eine passende Windows-Domain vor.

Ich habe hierzu einen Eintrag in unserem Bugtracking-System erstellt, dass der Installer diesen Fall entsprechend abfängt. Sie können Ihn gern unter [bug]27809[/bug] einsehen.

Mit freundlichen Grüßen,
Tim Petersen