UCS Master, / läuft voll und kein Upgrade möglich


#1

Hallo zusammen,

ich habe ein für mich unverständliches Problem bzw. Probleme mit einem Master. Da ich nicht weiß ob die beiden Probleme zusammenhänge poste ich jetzt das gesamte Krankheitsbild.

Auf einem Master 4.3.1 der als VM auf einem Backup (4.3.1) läuft lief kürzlich die Partition / voll. Diee war 60GB und da Daten und Home auf gesonderten Partitionen liegen sollte dies eigentlich reichen.

Als kürzlich / zu 100% voll war dachte ich dass nach einem UCS-Update einfach mehr Platz notwendig wäre und vergrößerte das Diskimage um 50GB.

Als nun nach knapp einer Woche / wieder voll war wurde ich stuzig. Ich habe dann alle gesonderten Partiotnen ausgehängt und die Größe aller Verzeichnisse mit:

du -hs

geprüft. Das waren auf keinen Fall in Summe 110GB. Habe die VM anschließend beendet und das Diskimage in ein Rescue-System eingebunden. Dort wurde mir die gleiche Belegung angezeigt. Ein fsck.ext4 /dev/vda1 meinte nur es wäre clean.

VM aus Rescue wieder raus und auf dem KVM-Host mit qemu-img resize /var/lib/libvirt/images/tux_disk1.qcow2 +100G vergrößert.

Da ich ja anschließend die im Image enthaltene Partition auch noch vergrößern muss habe ich die Image-Datei wieder in mein Rescue-System (was auch als VM läuft) eingebunden und gestertet. Nun war der Füllstand der Partition plötzlich wieder knapp 10GB was auch der Realität entspricht.

Da ich nun ohnehin schon an der VM zu gange war und die Image-Datei vor jeder der Vergrößerung der letzten Woche gesichert hatte wollte ich nun das Update auf 4.3.2 machen.

Das brach auch der Konsole immer mit der Fehlermeldung:

05.09.18 10:41:13.360  DEBUG_INIT
**** Starting univention-updater with parameter=['/usr/share/univention-updater/univention-updater', 'net', '--updateto', '4.3-2', '--ignoressh', '--ign
oreterm']
Version=4.3
Patchlevel=1
starting net mode
--->DBG:update_available(mode=net, cdrom_mount_point=/media/cdrom, iso=None)
Checking network repository
Update to = 4.3-2
**** Downloading scripts at Wed Sep  5 10:41:19 2018
Error: Update aborted due to verification error:
Verification error: Invalid signature: gpgv: Keine gültigen OpenPGP-Daten gefunden.
gpgv: Die Signatur konnte nicht überprüft werden.
Denken Sie daran, daß die Datei mit der Signatur (.sig oder .asc)
als erste in der Kommandozeile stehen sollte.

This can and should only be disabled temporarily using the UCR
variable 'repository/online/verify'

ab.

Ich habe die Variable auf “disabeld” gesetzt, die VM neu gestartet und es nochmal versucht. Was aber mit dem Fehler:

root@tux:~# univention-upgrade --ignoressh --ignoreterm

Starting univention-upgrade. Current UCS version is 4.3-1 errata229

Checking for local repository:                          none
Checking for package updates:                           none
Checking for app updates:                               none
Checking for release updates:                           found: UCS 4.3-2
Do you want to update to 4.3-2 [Y|n]? Y

Starting update to UCS version 4.3-2
Traceback (most recent call last):
  File "/usr/share/univention-updater/univention-updater", line 606, in <module>
    main()
  File "/usr/share/univention-updater/univention-updater", line 536, in main
    for phase, order in updater.call_sh_files(scripts, LOGNAME, str(new_version)):
  File "/usr/lib/pymodules/python2.7/univention/updater/tools.py", line 1762, in call_sh_files
    if call(script, 'pre', *args) != 0:
  File "/usr/lib/pymodules/python2.7/univention/updater/tools.py", line 1727, in call
    p = subprocess.Popen(cmd, stdout=subprocess.PIPE, stderr=subprocess.STDOUT, shell=False)
  File "/usr/lib/python2.7/subprocess.py", line 390, in __init__
    errread, errwrite)
  File "/usr/lib/python2.7/subprocess.py", line 1024, in _execute_child
    raise child_exception
OSError: [Errno 8] Exec format error
ERROR: update failed. Please check /var/log/univention/updater.log

Hat jemand eine Idee woran dies liegen könnte?

Viele Grüße
Sven


#2

Hi,

due to international users we prefer English here.

So you have a UCS 4.3-1 where the /-filesystem is getting filled up?
And a second issue where the upgrade does not run properly with the posted Python-tracebacks?
They might indeed be related and they might not. We’ll see.

So when you properly boot your UCS, what tells you df -h? Please post your /etc/fstab, too. And the output of du -hs /boot /bin /etc /home /lib* /m* /opt /root /sbin /srv /tmp /usr /var

Regarding the update: what tells you /var/log/univention/updater.log?

/CV


#3

bevor reboot:

root@tux:~# df -h
Dateisystem    Größe Benutzt Verf. Verw% Eingehängt auf
udev             10M       0   10M    0% /dev
tmpfs           1,6G     18M  1,6G    2% /run
/dev/vda1       207G    132G   66G   67% /
tmpfs           4,0G       0  4,0G    0% /dev/shm
tmpfs           5,0M       0  5,0M    0% /run/lock
tmpfs           4,0G       0  4,0G    0% /sys/fs/cgroup
/dev/vdc1       339G    277G   45G   87% /data
/dev/vdb1       339G    244G   79G   76% /home
/dev/vdd1       2,0T    773G  1,1T   42% /video

root@tux:~# du -hs /boot /bin /etc /home /lib* /m* /opt /root /sbin /srv /tmp /usr /var                                                                                                     
232M    /boot                                                                                                                                                                               
12M     /bin                                                                                                                                                                                
16M     /etc                                                                                                                                                                                
244G    /home
1,2G    /lib
4,0K    /lib64
8,0K    /media
4,0K    /mnt
0       /mrtg-l.png
0       /mrtg-m.png
0       /mrtg-r.png
16K     /opt
1,1G    /root
9,2M    /sbin
4,0K    /srv
60K     /tmp
2,0G    /usr
17G     /var

after reboot:

Dateisystem    Größe Benutzt Verf. Verw% Eingehängt auf
udev             10M       0   10M    0% /dev
tmpfs           1,6G     16M  1,6G    1% /run
/dev/vda1       207G     21G  177G   11% /
tmpfs           4,0G       0  4,0G    0% /dev/shm
tmpfs           5,0M       0  5,0M    0% /run/lock
tmpfs           4,0G       0  4,0G    0% /sys/fs/cgroup
/dev/vdc1       339G    277G   45G   87% /data
/dev/vdb1       339G    244G   79G   76% /home
/dev/vdd1       2,0T    773G  1,1T   42% /video

root@tux:~# du -hs /boot /bin /etc /home /lib* /m* /opt /root /sbin /srv /tmp /usr /var
232M    /boot
12M     /bin
16M     /etc
244G    /home
1,2G    /lib
4,0K    /lib64
8,0K    /media
4,0K    /mnt
0       /mrtg-l.png
0       /mrtg-m.png
0       /mrtg-r.png
16K     /opt
1,1G    /root
9,2M    /sbin
4,0K    /srv
44K     /tmp
2,0G    /usr
17G     /var

start tail to /var/log/univention/updater.log an:

root@tux:~# univention-upgrade --ignoressh --ignoreterm

Starting univention-upgrade. Current UCS version is 4.3-1 errata229

Checking for local repository:                          none
Checking for package updates:                           found

The following packages will be upgraded:
 libisc-export95,libdns-export100,libisccfg-export90,libirs-export91,libisc95,libdns100,libisccc90,libisccfg90,libbind9-90,liblwres90,php5-readline,php5-cli,php5-common

Do you want to continue [Y|n]? Y

Starting package upgrade                                done

Starting univention-upgrade. Current UCS version is 4.3-1 errata229

Checking for local repository:                          none
Checking for package updates:                           none
Checking for app updates:                               none
Checking for release updates:                           found: UCS 4.3-2
Do you want to update to 4.3-2 [Y|n]? Y
                                                                                                                                                                                            
Starting update to UCS version 4.3-2                                                                                                                                                        
Traceback (most recent call last):                                                                                                                                                          
  File "/usr/share/univention-updater/univention-updater", line 606, in <module>                                                                                                            
    main()                                                                                                                                                                                  
  File "/usr/share/univention-updater/univention-updater", line 536, in main                                                                                                                
    for phase, order in updater.call_sh_files(scripts, LOGNAME, str(new_version)):                                                                                                          
  File "/usr/lib/pymodules/python2.7/univention/updater/tools.py", line 1762, in call_sh_files                                                                                              
    if call(script, 'pre', *args) != 0:                                                                                                                                                     
  File "/usr/lib/pymodules/python2.7/univention/updater/tools.py", line 1727, in call                                                                                                       
    p = subprocess.Popen(cmd, stdout=subprocess.PIPE, stderr=subprocess.STDOUT, shell=False)                                                                                                
  File "/usr/lib/python2.7/subprocess.py", line 390, in __init__                                                                                                                            
    errread, errwrite)                                                                                                                                                                      
  File "/usr/lib/python2.7/subprocess.py", line 1024, in _execute_child                                                                                                                     
    raise child_exception                                                                                                                                                                   
OSError: [Errno 8] Exec format error                                                                                                                                                        
ERROR: update failed. Please check /var/log/univention/updater.log

the output in the log:

Starting univention-upgrade. Current UCS version is 4.3-1 errata229

Checking for local repository:                          none
Checking for package updates:                           found

The following packages will be upgraded:
 libisc-export95,libdns-export100,libisccfg-export90,libirs-export91,libisc95,libdns100,libisccc90,libisccfg90,libbind9-90,liblwres90,php5-readline,php5-cli,php5-common
Starting dist-update at Sun Sep  9 16:33:22 2018...
Starting package upgrade                               Paketlisten werden gelesen...
Abhängigkeitsbaum wird aufgebaut....
Statusinformationen werden eingelesen....
Paketaktualisierung (Upgrade) wird berechnet...
Die folgenden Pakete werden aktualisiert (Upgrade):
  libbind9-90 libdns-export100 libdns100 libirs-export91 libisc-export95
  libisc95 libisccc90 libisccfg-export90 libisccfg90 liblwres90 php5-cli
  php5-common php5-readline
13 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
Es müssen 4.682 kB an Archiven heruntergeladen werden.
Nach dieser Operation werden 2.093 kB Plattenplatz freigegeben.
Holen:1 https://updates.software-univention.de/4.2/maintained/component 4.2-4-errata/amd64/ libisc-export95 1:9.9.5.dfsg-9+deb8u16A~4.2.4.201809041803 [142 kB]
Holen:2 https://updates.software-univention.de/4.2/maintained/component 4.2-4-errata/amd64/ libdns-export100 1:9.9.5.dfsg-9+deb8u16A~4.2.4.201809041803 [457 kB]
Holen:3 https://updates.software-univention.de/4.2/maintained/component 4.2-4-errata/amd64/ libisccfg-export90 1:9.9.5.dfsg-9+deb8u16A~4.2.4.201809041803 [42,0 kB]
Holen:4 https://updates.software-univention.de/4.2/maintained/component 4.2-4-errata/amd64/ libirs-export91 1:9.9.5.dfsg-9+deb8u16A~4.2.4.201809041803 [39,7 kB]
Holen:5 https://updates.software-univention.de/4.2/maintained/component 4.2-4-errata/amd64/ libisc95 1:9.9.5.dfsg-9+deb8u16A~4.2.4.201809041803 [170 kB]
Holen:6 https://updates.software-univention.de/4.2/maintained/component 4.2-4-errata/amd64/ libdns100 1:9.9.5.dfsg-9+deb8u16A~4.2.4.201809041803 [681 kB]
Holen:7 https://updates.software-univention.de/4.2/maintained/component 4.2-4-errata/amd64/ libisccc90 1:9.9.5.dfsg-9+deb8u16A~4.2.4.201809041803 [37,8 kB]
Holen:8 https://updates.software-univention.de/4.2/maintained/component 4.2-4-errata/amd64/ libisccfg90 1:9.9.5.dfsg-9+deb8u16A~4.2.4.201809041803 [58,4 kB]
Holen:9 https://updates.software-univention.de/4.2/maintained/component 4.2-4-errata/amd64/ libbind9-90 1:9.9.5.dfsg-9+deb8u16A~4.2.4.201809041803 [44,6 kB]
Holen:10 https://updates.software-univention.de/4.2/maintained/component 4.2-4-errata/amd64/ liblwres90 1:9.9.5.dfsg-9+deb8u16A~4.2.4.201809041803 [54,2 kB]
Holen:11 https://updates.software-univention.de/4.2/maintained/component 4.2-4-errata/amd64/ php5-readline 5.6.37+dfsg-0+deb8u1 [12,7 kB]
Holen:12 https://updates.software-univention.de/4.2/maintained/component 4.2-4-errata/amd64/ php5-cli 5.6.37+dfsg-0+deb8u1 [2.199 kB]
Holen:13 https://updates.software-univention.de/4.2/maintained/component 4.2-4-errata/amd64/ php5-common 5.6.37+dfsg-0+deb8u1 [743 kB]
Es wurden 4.682 kB in 1 s geholt (3.213 kB/s).
(Lese Datenbank ... 121698 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../00-libisc-export95_1%3a9.9.5.dfsg-9+deb8u16A~4.2.4.201809041803_amd64.deb ...
Entpacken von libisc-export95 (1:9.9.5.dfsg-9+deb8u16A~4.2.4.201809041803) über (1:9.9.5.dfsg-9+deb8u15A~4.2.3.201802061643) ...
Vorbereitung zum Entpacken von .../01-libdns-export100_1%3a9.9.5.dfsg-9+deb8u16A~4.2.4.201809041803_amd64.deb ...
Entpacken von libdns-export100 (1:9.9.5.dfsg-9+deb8u16A~4.2.4.201809041803) über (1:9.9.5.dfsg-9+deb8u15A~4.2.3.201802061643) ...
Vorbereitung zum Entpacken von .../02-libisccfg-export90_1%3a9.9.5.dfsg-9+deb8u16A~4.2.4.201809041803_amd64.deb ...
Entpacken von libisccfg-export90 (1:9.9.5.dfsg-9+deb8u16A~4.2.4.201809041803) über (1:9.9.5.dfsg-9+deb8u15A~4.2.3.201802061643) ...
Vorbereitung zum Entpacken von .../03-libirs-export91_1%3a9.9.5.dfsg-9+deb8u16A~4.2.4.201809041803_amd64.deb ...
Entpacken von libirs-export91 (1:9.9.5.dfsg-9+deb8u16A~4.2.4.201809041803) über (1:9.9.5.dfsg-9+deb8u15A~4.2.3.201802061643) ...
Vorbereitung zum Entpacken von .../04-libisc95_1%3a9.9.5.dfsg-9+deb8u16A~4.2.4.201809041803_amd64.deb ...
Entpacken von libisc95 (1:9.9.5.dfsg-9+deb8u16A~4.2.4.201809041803) über (1:9.9.5.dfsg-9+deb8u15A~4.2.3.201802061643) ...
Vorbereitung zum Entpacken von .../05-libdns100_1%3a9.9.5.dfsg-9+deb8u16A~4.2.4.201809041803_amd64.deb ...
Entpacken von libdns100 (1:9.9.5.dfsg-9+deb8u16A~4.2.4.201809041803) über (1:9.9.5.dfsg-9+deb8u15A~4.2.3.201802061643) ...
Vorbereitung zum Entpacken von .../06-libisccc90_1%3a9.9.5.dfsg-9+deb8u16A~4.2.4.201809041803_amd64.deb ...
Entpacken von libisccc90 (1:9.9.5.dfsg-9+deb8u16A~4.2.4.201809041803) über (1:9.9.5.dfsg-9+deb8u15A~4.2.3.201802061643) ...
Vorbereitung zum Entpacken von .../07-libisccfg90_1%3a9.9.5.dfsg-9+deb8u16A~4.2.4.201809041803_amd64.deb ...
Entpacken von libisccfg90 (1:9.9.5.dfsg-9+deb8u16A~4.2.4.201809041803) über (1:9.9.5.dfsg-9+deb8u15A~4.2.3.201802061643) ...
Vorbereitung zum Entpacken von .../08-libbind9-90_1%3a9.9.5.dfsg-9+deb8u16A~4.2.4.201809041803_amd64.deb ...
Entpacken von libbind9-90 (1:9.9.5.dfsg-9+deb8u16A~4.2.4.201809041803) über (1:9.9.5.dfsg-9+deb8u15A~4.2.3.201802061643) ...
Vorbereitung zum Entpacken von .../09-liblwres90_1%3a9.9.5.dfsg-9+deb8u16A~4.2.4.201809041803_amd64.deb ...
Entpacken von liblwres90 (1:9.9.5.dfsg-9+deb8u16A~4.2.4.201809041803) über (1:9.9.5.dfsg-9+deb8u15A~4.2.3.201802061643) ...
Vorbereitung zum Entpacken von .../10-php5-readline_5.6.37+dfsg-0+deb8u1_amd64.deb ...
Entpacken von php5-readline (5.6.37+dfsg-0+deb8u1) über (5.6.36+dfsg-0+deb8u1) ...
Vorbereitung zum Entpacken von .../11-php5-cli_5.6.37+dfsg-0+deb8u1_amd64.deb ...
Entpacken von php5-cli (5.6.37+dfsg-0+deb8u1) über (5.6.36+dfsg-0+deb8u1) ...
Vorbereitung zum Entpacken von .../12-php5-common_5.6.37+dfsg-0+deb8u1_amd64.deb ...
Entpacken von php5-common (5.6.37+dfsg-0+deb8u1) über (5.6.36+dfsg-0+deb8u1) ...
libisc95 (1:9.9.5.dfsg-9+deb8u16A~4.2.4.201809041803) wird eingerichtet ...
libisc-export95 (1:9.9.5.dfsg-9+deb8u16A~4.2.4.201809041803) wird eingerichtet ...
liblwres90 (1:9.9.5.dfsg-9+deb8u16A~4.2.4.201809041803) wird eingerichtet ...
Trigger für man-db (2.7.6.1-2) werden verarbeitet ...
php5-common (5.6.37+dfsg-0+deb8u1) wird eingerichtet ...
libdns100 (1:9.9.5.dfsg-9+deb8u16A~4.2.4.201809041803) wird eingerichtet ...
libisccc90 (1:9.9.5.dfsg-9+deb8u16A~4.2.4.201809041803) wird eingerichtet ...
libisccfg-export90 (1:9.9.5.dfsg-9+deb8u16A~4.2.4.201809041803) wird eingerichtet ...
libisccfg90 (1:9.9.5.dfsg-9+deb8u16A~4.2.4.201809041803) wird eingerichtet ...
libdns-export100 (1:9.9.5.dfsg-9+deb8u16A~4.2.4.201809041803) wird eingerichtet ...
libbind9-90 (1:9.9.5.dfsg-9+deb8u16A~4.2.4.201809041803) wird eingerichtet ...
php5-cli (5.6.37+dfsg-0+deb8u1) wird eingerichtet ...
libirs-export91 (1:9.9.5.dfsg-9+deb8u16A~4.2.4.201809041803) wird eingerichtet ...
php5-readline (5.6.37+dfsg-0+deb8u1) wird eingerichtet ...
 dist-update finished at Sun Sep  9 16:33:46 2018...
done
Starting univention-upgrade. Current UCS version is 4.3-1 errata229

Checking for local repository:                          none
Checking for package updates:                           none
Checking for app updates:                               none                                                                                                                                
Checking for release updates:                           found: UCS 4.3-2                                                                                                                    
Starting update to UCS version 4.3-2 at Sun Sep  9 16:34:54 2018...                                                                                                                         
Starting update to UCS version 4.3-2                                                                                                                                                        
09.09.18 16:34:56.262  DEBUG_INIT                                                                                                                                                           
**** Starting univention-updater with parameter=['/usr/share/univention-updater/univention-updater', 'net', '--updateto', '4.3-2', '--silent', '--ignoressh', '--ignoreterm']               
Version=4.3                                                                                                                                                                                 
Patchlevel=1                                                                                                                                                                                
starting net mode                                                                                                                                                                           
--->DBG:update_available(mode=net, cdrom_mount_point=/media/cdrom, iso=None)                                                                                                                
Checking network repository                                                                                                                                                                 
Update to = 4.3-2                                                                                                                                                                           
**** Downloading scripts at Sun Sep  9 16:35:02 2018                                                                                                                                        
**** Starting actual update at Sun Sep  9 16:35:09 2018                                                                                                                                     
                                                                                                                                                                                            
Starting univention-upgrade. Current UCS version is 4.3-1 errata229                                                                                                                         
                                                                                                                                                                                            
exitcode of univention-updater: 1                                                                                                                                                           
ERROR: update failed. Please check /var/log/univention/updater.log

hope that’s help


#4

Currently I would ignore the update issue as long as the usage issue is not fixed. Indeed, looks very strange.

You posted two df -h outputs above. What happened in between? Just a reboot? Nothing else? Do you have some sort of backup running?
Next time when it goes up so fast I would suggest to umount your additonal devices /home, /data/ video and check with du if there are some files “underlying” in these pathes.

Please post mount, too. And I am missing your /etc/fstab.

/CV


#5

Yes I think the same. I started the update again to keep the messages in the logfile.

only reboot. Now ~24h later …

root@tux:~# df -h
Dateisystem    Größe Benutzt Verf. Verw% Eingehängt auf                                                                                                                                     
udev             10M       0   10M    0% /dev                                                                                                                                               
tmpfs           1,6G     18M  1,6G    2% /run
/dev/vda1       207G     43G  155G   22% /
tmpfs           4,0G       0  4,0G    0% /dev/shm
tmpfs           5,0M       0  5,0M    0% /run/lock
tmpfs           4,0G       0  4,0G    0% /sys/fs/cgroup
/dev/vdb1       339G    244G   79G   76% /home
/dev/vdc1       339G    277G   45G   87% /data
/dev/vdd1       969G    773G  147G   85% /video

bareos has been running for some time. the host (tux) is a bareos-client

ok, I can only do that in the evening…

root@tux:~# mount
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
udev on /dev type devtmpfs (rw,relatime,size=10240k,nr_inodes=1016911,mode=755)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
tmpfs on /run type tmpfs (rw,nosuid,relatime,size=1635840k,mode=755)
/dev/vda1 on / type ext4 (rw,relatime,errors=remount-ro,data=ordered)
securityfs on /sys/kernel/security type securityfs (rw,nosuid,nodev,noexec,relatime)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
tmpfs on /run/lock type tmpfs (rw,nosuid,nodev,noexec,relatime,size=5120k)
tmpfs on /sys/fs/cgroup type tmpfs (ro,nosuid,nodev,noexec,mode=755)
cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,xattr,release_agent=/lib/systemd/systemd-cgroups-agent,name=systemd)
pstore on /sys/fs/pstore type pstore (rw,nosuid,nodev,noexec,relatime)
cgroup on /sys/fs/cgroup/pids type cgroup (rw,nosuid,nodev,noexec,relatime,pids)
cgroup on /sys/fs/cgroup/memory type cgroup (rw,nosuid,nodev,noexec,relatime,memory)
cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpu,cpuacct)
cgroup on /sys/fs/cgroup/cpuset type cgroup (rw,nosuid,nodev,noexec,relatime,cpuset)
cgroup on /sys/fs/cgroup/blkio type cgroup (rw,nosuid,nodev,noexec,relatime,blkio)
cgroup on /sys/fs/cgroup/net_cls,net_prio type cgroup (rw,nosuid,nodev,noexec,relatime,net_cls,net_prio)
cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)
cgroup on /sys/fs/cgroup/perf_event type cgroup (rw,nosuid,nodev,noexec,relatime,perf_event)
cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)
systemd-1 on /proc/sys/fs/binfmt_misc type autofs (rw,relatime,fd=27,pgrp=1,timeout=0,minproto=5,maxproto=5,direct,pipe_ino=9917)
debugfs on /sys/kernel/debug type debugfs (rw,relatime)
mqueue on /dev/mqueue type mqueue (rw,relatime)
hugetlbfs on /dev/hugepages type hugetlbfs (rw,relatime)
sunrpc on /run/rpc_pipefs type rpc_pipefs (rw,relatime)
nfsd on /proc/fs/nfsd type nfsd (rw,relatime)
/dev/vdb1 on /home type ext4 (rw,relatime,data=ordered)
/dev/vdc1 on /data type ext4 (rw,relatime,data=ordered)
/dev/vdd1 on /video type ext4 (rw,relatime,data=ordered)
/dev/vda1 on /var/lib/docker/overlay type ext4 (rw,relatime,errors=remount-ro,data=ordered)

/dev/vda1                                       /       ext4    errors=remount-ro,user_xattr    0       1
/dev/vdb1                                       /home   ext4    defaults        0       2
/dev/vdc1                                       /data   ext4    defaults        0       2
/dev/sr0        /media/cdrom0   udf,iso9660     user,noauto     0       0
/dev/vdd1 

#6

I just restarted the master but this time the space in / was not free again:

root@tux:~# df -h
Dateisystem    Größe Benutzt Verf. Verw% Eingehängt auf
udev             10M       0   10M    0% /dev
tmpfs           1,6G     18M  1,6G    2% /run
/dev/vda1       207G     61G  137G   31% /
tmpfs           4,0G       0  4,0G    0% /dev/shm
tmpfs           5,0M       0  5,0M    0% /run/lock
tmpfs           4,0G       0  4,0G    0% /sys/fs/cgroup
/dev/vdb1       339G    244G   79G   76% /home
/dev/vdc1       339G    277G   45G   87% /data
/dev/vdd1       969G    773G  147G   85% /video

I unmount the additional partitions and check there size:

root@tux:~# umount /data /video /home
...
root@tux:~# du -hs /data /video /home
4,0K    /data
4,0K    /video
164K    /home


#7

I found the problem with the growing / … the samba-log. For a other issue:

https://help.univention.com/t/nach-update-altere-clients-kein-zugriff-auf-share/9514/7

I set a higher debug-level and forgot to disable it again :frowning:

The master still has a very high cpu-load (100%) when I look at the UVMM but not in UMC on the master :thinking:

the problem with the upgrade persists


#8

Different topic.
But this can happen. See bug.


#9

This bug refers to xen and not to kvm


#10

have anyone an idea regarding the upgrade error?


#11
File "/usr/lib/python2.7/subprocess.py", line 1024, in _execute_child
    raise child_exception
OSError: [Errno 8] Exec format error
ERROR: update failed. Please check /var/log/univention/updater.log

An “exec command error” usually refers to a missing first line in a script to be executed. Usually, scripts start with a hashpling like this:
#!/bin/python

If this line is missing and no other interpreter can be guessed you will get this error. Now you have to find out WHY this happens. Have you done:
Please check /var/log/univention/updater.log?

And, BTW @KNEBB is right: The bug is the one in question. reading properly and you will see this affects all hypervisors…

/CV


#12

Regarding the upgrade problem I have started again. I have unset the

repository/online/verify = disabled

I also emptied the file updater.log and start the upgrade-process:

root@tux:/var/log/samba# univention-upgrade --ignoressh --ignoreterm

Starting univention-upgrade. Current UCS version is 4.3-1 errata229

Checking for local repository:                          none
Checking for package updates:                           none
Checking for app updates:                               none
Checking for release updates:                           found: UCS 4.3-2
Do you want to update to 4.3-2 [Y|n]? Y

Starting update to UCS version 4.3-2
Traceback (most recent call last):
  File "/usr/share/univention-updater/univention-updater", line 606, in <module>
    main()
  File "/usr/share/univention-updater/univention-updater", line 536, in main
    for phase, order in updater.call_sh_files(scripts, LOGNAME, str(new_version)):
  File "/usr/lib/pymodules/python2.7/univention/updater/tools.py", line 1762, in call_sh_files
    if call(script, 'pre', *args) != 0:
  File "/usr/lib/pymodules/python2.7/univention/updater/tools.py", line 1727, in call
    p = subprocess.Popen(cmd, stdout=subprocess.PIPE, stderr=subprocess.STDOUT, shell=False)
  File "/usr/lib/python2.7/subprocess.py", line 390, in __init__
    errread, errwrite)
  File "/usr/lib/python2.7/subprocess.py", line 1024, in _execute_child
    raise child_exception
OSError: [Errno 8] Exec format error
ERROR: update failed. Please check /var/log/univention/updater.log

The complete /var/log/univention/updater.log:

Starting univention-upgrade. Current UCS version is 4.3-1 errata229

Checking for local repository:                          none
Checking for package updates:                           none
Checking for app updates:                               none
Checking for release updates:                           found: UCS 4.3-2
Starting update to UCS version 4.3-2 at Wed Sep 12 09:49:30 2018...
Starting update to UCS version 4.3-2
12.09.18 09:49:31.916  DEBUG_INIT
**** Starting univention-updater with parameter=['/usr/share/univention-updater/univention-updater', 'net', '--updateto', '4.3-2', '--silent', '--ignoressh$
Version=4.3
Patchlevel=1
starting net mode
--->DBG:update_available(mode=net, cdrom_mount_point=/media/cdrom, iso=None)
Checking network repository
Update to = 4.3-2
**** Downloading scripts at Wed Sep 12 09:49:38 2018
**** Starting actual update at Wed Sep 12 09:49:45 2018

Starting univention-upgrade. Current UCS version is 4.3-1 errata229

exitcode of univention-updater: 1
ERROR: update failed. Please check /var/log/univention/updater.log

#13

I still try to find out why the update fail an exit with error:

root@tux:/var/log/samba# univention-upgrade --ignoressh --ignoreterm

Starting univention-upgrade. Current UCS version is 4.3-1 errata229

Checking for local repository:                          none
Checking for package updates:                           none
Checking for app updates:                               none
Checking for release updates:                           found: UCS 4.3-2
Do you want to update to 4.3-2 [Y|n]? Y

Starting update to UCS version 4.3-2
Traceback (most recent call last):
  File "/usr/share/univention-updater/univention-updater", line 606, in <module>
    main()
  File "/usr/share/univention-updater/univention-updater", line 536, in main
    for phase, order in updater.call_sh_files(scripts, LOGNAME, str(new_version)):
  File "/usr/lib/pymodules/python2.7/univention/updater/tools.py", line 1762, in call_sh_files
    if call(script, 'pre', *args) != 0:
  File "/usr/lib/pymodules/python2.7/univention/updater/tools.py", line 1727, in call
    p = subprocess.Popen(cmd, stdout=subprocess.PIPE, stderr=subprocess.STDOUT, shell=False)
  File "/usr/lib/python2.7/subprocess.py", line 390, in __init__
    errread, errwrite)
  File "/usr/lib/python2.7/subprocess.py", line 1024, in _execute_child
    raise child_exception
OSError: [Errno 8] Exec format error
ERROR: update failed. Please check /var/log/univention/updater.log

but the /var/log/univention/updater.log gives no indication

Starting univention-upgrade. Current UCS version is 4.3-1 errata235

Checking for package updates:                           none
Checking for app updates:                               none
Checking for release updates:                           found: UCS 4.3-2
Please rerun command without --check argument to install.

Starting univention-upgrade. Current UCS version is 4.3-1 errata235

Checking for package updates:                           none
Checking for app updates:                               none
Checking for release updates:                           found: UCS 4.3-2
Please rerun command without --check argument to install.

Starting univention-upgrade. Current UCS version is 4.3-1 errata235

Checking for package updates:                           none
Checking for app updates:                               none
Checking for release updates:                           found: UCS 4.3-2
Please rerun command without --check argument to install.

#14

Well it obviously has not changed. It is not “self-healing”…
Have you checked:

An “exec command error” usually refers to a missing first line in a script to be executed. Usually, scripts start with a hashpling like this:
#!/bin/python
If updater.log does not show any further evidence, take the next step in troubleshooting:

root@master:~# head /usr/lib/pymodules/python2.7/univention/updater/tools.py
#!/usr/bin/python2.7
# -*- coding: utf-8 -*-
"""
Univention Update tools.
"""
# Copyright 2008-2018 Univention GmbH
#
# http://www.univention.de/
#
# All rights reserved.

#15

yes I know that

I look in some python (extension .py) file in /usr/lib/python2.7/… and no file is si beginning with:

#!/bin/python

And I did not know exactly in which files I should look … :frowning:

root@tux:~# head /usr/lib/pymodules/python2.7/univention/updater/tools.py
#!/usr/bin/python2.7
# -*- coding: utf-8 -*-
"""
Univention Update tools.
"""
# Copyright 2008-2018 Univention GmbH
#
# http://www.univention.de/
#
# All rights reserved.

looks good?


#16

Hey,

the traceback shows this error happens not for files you already have installed, but for scripts that are downloaded from the Univention update servers during the upgrade. These scripts are supposed to verify certain conditions are met prior to the upgrade. They also upgrade certain packages first before the rest in order to ensure the upgrade doesn’t run into known dependency problems.

In your case it’s likely the 4.2 pre-upgrade script for which this happens.

The downloaded scripts are then stored in a temporary directory beneath /tmp, made executable and then executed. Something seems to go wrong with that process.

You can try to enable debugging messages for the updater. Unfortunately this cannot be done simply through a UCR variable, it seems. So please edit the following file in a text editor: /usr/share/univention-updater/univention-updater Look for def main(). In that function you should find a call to ud.init(LOGNAME, 0, 0). Directly after this call insert the following lines:

    ud.set_level(ud.NETWORK, ud.ALL)
    ud.set_level(ud.PROCESS, ud.ALL)

Make sure that the lines are indented exactly as deep as the existing call to ud.init as depth of indentation is relevant in Python.

Then re-run the updater. The /var/log/updater.log should now contain a lot more messages about trying to retrieve files and trying to run scripts. Please post that output here.

m.


#17

I found an backup this fil. I can locate ud.init(LOGNAME, 0, 0) but I cant find the lines:

    ud.set_level(ud.NETWORK, ud.ALL)
    ud.set_level(ud.PROCESS, ud.ALL)

directly below. See:

def main():
    # PATH does not contain */sbin when called from cron
    os.putenv('PATH', '/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/bin/X11')

    for cdrom_mount_point in ('/cdrom', '/media/cdrom', '/media/cdrom0'):
        if os.path.isdir(cdrom_mount_point):
            break
    iso = None

    ud.init(LOGNAME, 0, 0)
    fp_debug = open(LOGNAME, 'a+')
    # sys.stdout=fp_debug

    log('**** Starting univention-updater with parameter=%s' % sys.argv)

    if len(sys.argv) < 2:
        usage(sys.stderr)
        fp_debug.close()
        sys.exit(2)

    if sys.argv[1] == 'net':
        command = 'net'
    elif sys.argv[1] == 'cdrom':
        command = 'cdrom'
    elif sys.argv[1] == 'local':
        command = 'local'
    else:
        usage(sys.stderr)
        fp_debug.close()
        sys.exit(2)

    updateto = None
    updateto_args = []
    clean = True
    ignoressh = False
    ignoreterm = False
    ignorereleasenotes = False

I try to search this string n the file … „ud.set_level(ud.NETWORK, ud.ALL)“ nicht gefunden"


#18

Hey,

that’s correct, the lines aren’t present. That’s why I said that you should “insert” them after the existing line.

m.


#19

ok, I modified the file accordingly. The Log:

root@tux:~# tail -f /var/log/univention/updater.log              
Checking network repository
Update to = 4.3-2
**** Downloading scripts at Sat Oct 27 12:51:30 2018
**** Starting actual update at Sat Oct 27 12:51:33 2018

Starting univention-upgrade. Current UCS version is 4.3-1 errata282

exitcode of univention-updater: 1
ERROR: update failed. Please check /var/log/univention/updater.log


Starting univention-upgrade. Current UCS version is 4.3-1 errata282

Checking for local repository:                          none
Checking for package updates:                           none
Checking for app updates:                               none
Checking for release updates:                           found: UCS 4.3-2
Starting update to UCS version 4.3-2 at Sat Oct 27 12:59:17 2018...
Starting update to UCS version 4.3-2
27.10.18 12:59:18.683  DEBUG_INIT
**** Starting univention-updater with parameter=['/usr/share/univention-updater/univention-updater', 'net', '--updateto', '4.3-2', '--silent', '--ignoressh', '--ignoreterm']
Version=4.3
Patchlevel=1
starting net mode
--->DBG:update_available(mode=net, cdrom_mount_point=/media/cdrom, iso=None)
Checking network repository
Update to = 4.3-2
27.10.18 12:59:18.698  NETWORK     ( ALL     ) : updater: HEAD https://updates.software-univention.de/
27.10.18 12:59:18.753  NETWORK     ( ALL     ) : updater: HEAD https://updates.software-univention.de/4.3/maintained/4.3-2/
27.10.18 12:59:18.809  NETWORK     ( ALL     ) : updater: HEAD https://updates.software-univention.de/4.3/
27.10.18 12:59:18.864  NETWORK     ( ALL     ) : updater: HEAD https://updates.software-univention.de/4.3/maintained/4.3-2/
27.10.18 12:59:18.918  NETWORK     ( ALL     ) : updater: HEAD https://updates.software-univention.de/4.3/maintained/4.3-2/all/Packages.gz
27.10.18 12:59:18.972  NETWORK     ( ALL     ) : updater: HEAD https://updates.software-univention.de/4.3/maintained/4.3-2/amd64/Packages.gz
27.10.18 12:59:19.027  NETWORK     ( ALL     ) : updater: HEAD https://updates.software-univention.de/univention-repository/
27.10.18 12:59:19.078  NETWORK     ( ALL     ) : Error downloading https://updates.software-univention.de/univention-repository/: 404
27.10.18 12:59:19.078  NETWORK     ( ALL     ) : updater: HEAD https://updates.software-univention.de/
27.10.18 12:59:19.131  NETWORK     ( ALL     ) : updater: HEAD https://updates.software-univention.de/4.3/
27.10.18 12:59:19.184  NETWORK     ( ALL     ) : updater: HEAD https://updates.software-univention.de/4.3/maintained/component/4.1-5-errata/
27.10.18 12:59:19.236  NETWORK     ( ALL     ) : Error downloading https://updates.software-univention.de/4.3/maintained/component/4.1-5-errata/: 404
27.10.18 12:59:19.237  NETWORK     ( ALL     ) : updater: HEAD https://updates.software-univention.de/4.3/
27.10.18 12:59:19.290  NETWORK     ( ALL     ) : updater: HEAD https://updates.software-univention.de/4.3/maintained/component/4.1-5-errata/Packages.gz
27.10.18 12:59:19.342  NETWORK     ( ALL     ) : Error downloading https://updates.software-univention.de/4.3/maintained/component/4.1-5-errata/Packages.gz: 404
27.10.18 12:59:19.343  NETWORK     ( ALL     ) : updater: HEAD https://updates.software-univention.de/univention-repository/
27.10.18 12:59:19.420  NETWORK     ( ALL     ) : Error downloading https://updates.software-univention.de/univention-repository/: 404
27.10.18 12:59:19.420  NETWORK     ( ALL     ) : updater: HEAD https://updates.software-univention.de/
27.10.18 12:59:19.473  NETWORK     ( ALL     ) : updater: HEAD https://updates.software-univention.de/4.3/
27.10.18 12:59:19.525  NETWORK     ( ALL     ) : updater: HEAD https://updates.software-univention.de/4.3/maintained/component/4.2-4-errata/
27.10.18 12:59:19.575  NETWORK     ( ALL     ) : Error downloading https://updates.software-univention.de/4.3/maintained/component/4.2-4-errata/: 404
27.10.18 12:59:19.575  NETWORK     ( ALL     ) : updater: HEAD https://updates.software-univention.de/4.3/
27.10.18 12:59:19.624  NETWORK     ( ALL     ) : updater: HEAD https://updates.software-univention.de/4.3/maintained/component/4.2-4-errata/Packages.gz
27.10.18 12:59:19.674  NETWORK     ( ALL     ) : Error downloading https://updates.software-univention.de/4.3/maintained/component/4.2-4-errata/Packages.gz: 404
27.10.18 12:59:19.675  NETWORK     ( ALL     ) : updater: HEAD http://appcenter.software-univention.de/univention-repository/current/
27.10.18 12:59:19.697  NETWORK     ( ALL     ) : Error downloading http://appcenter.software-univention.de/univention-repository/current/: 404
27.10.18 12:59:19.697  NETWORK     ( ALL     ) : updater: HEAD http://appcenter.software-univention.de/current/
27.10.18 12:59:19.836  NETWORK     ( ALL     ) : updater: HEAD http://appcenter.software-univention.de/current/4.3/
27.10.18 12:59:19.973  NETWORK     ( ALL     ) : updater: HEAD http://appcenter.software-univention.de/current/4.3/maintained/component/bareos_20180628113044/
27.10.18 12:59:20.107  NETWORK     ( ALL     ) : updater: HEAD http://appcenter.software-univention.de/current/4.3/maintained/component/bareos_20180628113044/all/Packages.gz
27.10.18 12:59:20.246  NETWORK     ( ALL     ) : updater: HEAD http://appcenter.software-univention.de/current/4.3/maintained/component/bareos_20180628113044/am**** Downloading scripts at Sat Oct 27 12:59:21 2018
d64/Packages.gz
27.10.18 12:59:20.380  NETWORK     ( ALL     ) : updater: HEAD http://appcenter.software-univention.de/current/4.3/
27.10.18 12:59:20.535  NETWORK     ( ALL     ) : updater: HEAD http://appcenter.software-univention.de/current/4.3/maintained/component/bareos_20180628113044/Packages.gz
27.10.18 12:59:20.690  NETWORK     ( ALL     ) : updater: HEAD http://appcenter.software-univention.de/current/4.3/maintained/component/bareos_20180628113044/Packages.gz
27.10.18 12:59:20.844  NETWORK     ( ALL     ) : updater: HEAD https://updates.software-univention.de/univention-repository/
27.10.18 12:59:20.896  NETWORK     ( ALL     ) : Error downloading https://updates.software-univention.de/univention-repository/: 404
27.10.18 12:59:20.896  NETWORK     ( ALL     ) : updater: HEAD https://updates.software-univention.de/
27.10.18 12:59:20.949  NETWORK     ( ALL     ) : updater: HEAD https://updates.software-univention.de/4.3/
27.10.18 12:59:21.003  NETWORK     ( ALL     ) : updater: HEAD https://updates.software-univention.de/4.3/maintained/component/4.3-1-errata/
27.10.18 12:59:21.057  NETWORK     ( ALL     ) : updater: HEAD https://updates.software-univention.de/4.3/maintained/component/4.3-1-errata/all/Packages.gz
27.10.18 12:59:21.110  NETWORK     ( ALL     ) : updater: HEAD https://updates.software-univention.de/4.3/maintained/component/4.3-1-errata/amd64/Packages.gz
27.10.18 12:59:21.163  NETWORK     ( ALL     ) : updater: HEAD https://updates.software-univention.de/4.3/
27.10.18 12:59:21.214  NETWORK     ( ALL     ) : updater: HEAD https://updates.software-univention.de/4.3/maintained/component/4.3-1-errata/Packages.gz
27.10.18 12:59:21.265  NETWORK     ( ALL     ) : Error downloading https://updates.software-univention.de/4.3/maintained/component/4.3-1-errata/Packages.gz: 404
27.10.18 12:59:21.271  NETWORK     ( ALL     ) : updater: HEAD https://updates.software-univention.de/4.3/
27.10.18 12:59:21.325  NETWORK     ( ALL     ) : updater: HEAD https://updates.software-univention.de/4.3/maintained/4.3-2/
27.10.18 12:59:21.380  NETWORK     ( ALL     ) : updater: HEAD https://updates.software-univention.de/4.3/maintained/4.3-2/all/Packages.gz
27.10.18 12:59:21.433  NETWORK     ( ALL     ) : updater: GET https://updates.software-univention.de/4.3/maintained/4.3-2/all/preup.sh
27.10.18 12:59:21.497  NETWORK     ( INFO    ) : https://updates.software-univention.de/4.3/maintained/4.3-2/all/preup.sh saved to /tmp/tmp0xsPF4/preupYsMXGo.sh
27.10.18 12:59:21.497  NETWORK     ( ALL     ) : updater: GET https://updates.software-univention.de/4.3/maintained/4.3-2/all/postup.sh
27.10.18 12:59:21.551  NETWORK     ( INFO    ) : https://updates.software-univention.de/4.3/maintained/4.3-2/all/postup.sh saved to /tmp/tmp0xsPF4/postupHsDzo6.sh
27.10.18 12:59:21.552  NETWORK     ( ALL     ) : updater: HEAD https://updates.software-univention.de/univention-repository/
27.10.18 12:59:21.605  NETWORK     ( ALL     ) : Error downloading https://updates.software-univention.de/univention-repository/: 404
27.10.18 12:59:21.605  NETWORK     ( ALL     ) : updater: HEAD https://updates.software-univention.de/
27.10.18 12:59:21.659  NETWORK     ( ALL     ) : updater: HEAD https://updates.software-univention.de/4.3/
27.10.18 12:59:21.714  NETWORK     ( ALL     ) : updater: HEAD https://updates.software-univention.de/4.3/maintained/component/4.1-5-errata/
27.10.18 12:59:21.766  NETWORK     ( ALL     ) : Error downloading https://updates.software-univention.de/4.3/maintained/component/4.1-5-errata/: 404
27.10.18 12:59:21.766  NETWORK     ( ALL     ) : updater: HEAD https://updates.software-univention.de/4.3/
27.10.18 12:59:21.821  NETWORK     ( ALL     ) : updater: HEAD https://updates.software-univention.de/4.3/maintained/component/4.1-5-errata/Packages.gz
27.10.18 12:59:21.874  NETWORK     ( ALL     ) : Error downloading https://updates.software-univention.de/4.3/maintained/component/4.1-5-errata/Packages.gz: 404
27.10.18 12:59:21.875  NETWORK     ( ALL     ) : updater: HEAD https://updates.software-univention.de/univention-repository/
27.10.18 12:59:21.928  NETWORK     ( ALL     ) : Error downloading https://updates.software-univention.de/univention-repository/: 404
27.10.18 12:59:21.930  NETWORK     ( ALL     ) : updater: HEAD https://updates.software-univention.de/
27.10.18 12:59:21.984  NETWORK     ( ALL     ) : updater: HEAD https://updates.software-univention.de/4.3/
27.10.18 12:59:22.035  NETWORK     ( ALL     ) : updater: HEAD https://updates.software-univention.de/4.3/maintained/component/4.2-4-errata/
27.10.18 12:59:22.091  NETWORK     ( ALL     ) : Error downloading https://updates.software-univention.de/4.3/maintained/component/4.2-4-errata/: 404
27.10.18 12:59:22.092  NETWORK     ( ALL     ) : updater: HEAD https://updates.software-univention.de/4.3/
27.10.18 12:59:22.145  NETWORK     ( ALL     ) : updater: HEAD https://updates.software-univention.de/4.3/maintained/component/4.2-4-errata/Packages.gz
27.10.18 12:59:22.197  NETWORK     ( ALL     ) : Error downloading https://updates.software-univention.de/4.3/maintained/component/4.2-4-errata/Packages.gz: 404
27.10.18 12:59:22.198  NETWORK     ( ALL     ) : updater: HEAD http://appcenter.software-univention.de/univention-repository/current/
27.10.18 12:59:22.221  NETWORK     ( ALL     ) : Error downloading http://appcenter.software-univention.de/univention-repository/current/: 404
27.10.18 12:59:22.221  NETWORK     ( ALL     ) : updater: HEAD http://appcenter.software-univention.de/current/
27.10.18 12:59:22.375  NETWORK     ( ALL     ) : updater: HEAD http://appcenter.software-univention.de/current/4.3/
27.10.18 12:59:22.527  NETWORK     ( ALL     ) : updater: HEAD http://appcenter.software-univention.de/current/4.3/maintained/component/bareos_20180628113044/
27.10.18 12:59:22.679  NETWORK     ( ALL     ) : updater: HEAD http://appcenter.software-univention.de/current/4.3/maintained/component/bareos_20180628113044/all/Packages.gz
27.10.18 12:59:22.833  NETWORK     ( ALL     ) : updater: GET http://appcenter.software-univention.de/current/4.3/maintained/component/bareos_20180628113044/all/preup.sh
27.10.18 12:59:22.988  NETWORK     ( INFO    ) : http://appcenter.software-univention.de/current/4.3/maintained/component/bareos_20180628113044/all/preup.sh saved to /tmp/tmp0xsPF4/preuphwpPb7.sh
27.10.18 12:59:22.988  NETWORK     ( ALL     ) : updater: GET http://appcenter.software-univention.de/current/4.3/maintained/component/bareos_20180628113044/all/postup.sh
27.10.18 12:59:23.141  NETWORK     ( INFO    ) : http://appcenter.software-univention.de/current/4.3/maintained/component/bareos_20180628113044/all/postup.sh saved to /tmp/tmp0xsPF4/postupBc4bQ7.sh
27.10.18 12:59:23.142  NETWORK     ( ALL     ) : updater: HEAD http://appcenter.software-univention.de/current/4.3/
27.10.18 12:59:23.294  NETWORK     ( ALL     ) : updater: HEAD http://appcenter.software-univention.de/current/4.3/maintained/component/bareos_20180628113044/Packages.gz
27.10.18 12:59:23.460  NETWORK     ( ALL     ) : updater: HEAD http://appcenter.software-univention.de/current/4.3/maintained/component/bareos_20180628113044/Packages.gz
27.10.18 12:59:23.615  NETWORK     ( ALL     ) : updater: GET http://appcenter.software-univention.de/current/4.3/maintained/component/bareos_20180628113044/preup.sh
27.10.18 12:59:23.771  NETWORK     ( INFO    ) : http://appcenter.software-univention.de/current/4.3/maintained/component/bareos_20180628113044/preup.sh saved to /tmp/tmp0xsPF4/preup3ZIDdY.sh
27.10.18 12:59:23.771  NETWORK     ( ALL     ) : updater: GET http://appcenter.software-univention.de/current/4.3/maintained/component/bareos_20180628113044/postup.sh
27.10.18 12:59:23.923  NETWORK     ( INFO    ) : http://appcenter.software-univention.de/current/4.3/maintained/component/bareos_20180628113044/postup.sh saved to /tmp/tmp0xsPF4/postupF36p_s.sh
27.10.18 12:59:23.924  NETWORK     ( ALL     ) : updater: HEAD https://updates.software-univention.de/univention-repository/
27.10.18 12:59:23.976  NETWORK     ( ALL     ) : Error downloading https://updates.software-univention.de/univention-repository/: 404
27.10.18 12:59:23.976  NETWORK     ( ALL    **** Starting actual update at Sat Oct 27 12:59:24 2018

Starting univention-upgrade. Current UCS version is 4.3-1 errata282

 ) : updater: HEAD https://updates.software-univention.de/
27.10.18 12:59:24.029  NETWORK     ( ALL     ) : updater: HEAD https://updates.software-univention.de/4.3/
27.10.18 12:59:24.082  NETWORK     ( ALL     ) : updater: HEAD https://updates.software-univention.de/4.3/maintained/component/4.3-1-errata/
27.10.18 12:59:24.135  NETWORK     ( ALL     ) : updater: HEAD https://updates.software-univention.de/4.3/maintained/component/4.3-1-errata/all/Packages.gz
27.10.18 12:59:24.187  NETWORK     ( ALL     ) : updater: GET https://updates.software-univention.de/4.3/maintained/component/4.3-1-errata/all/preup.sh
27.10.18 12:59:24.241  NETWORK     ( ALL     ) : Error downloading https://updates.software-univention.de/4.3/maintained/component/4.3-1-errata/all/preup.sh: 404
27.10.18 12:59:24.241  NETWORK     ( ALL     ) : updater: GET https://updates.software-univention.de/4.3/maintained/component/4.3-1-errata/all/postup.sh
27.10.18 12:59:24.294  NETWORK     ( ALL     ) : Error downloading https://updates.software-univention.de/4.3/maintained/component/4.3-1-errata/all/postup.sh: 404
27.10.18 12:59:24.295  NETWORK     ( ALL     ) : updater: HEAD https://updates.software-univention.de/4.3/
27.10.18 12:59:24.348  NETWORK     ( ALL     ) : updater: HEAD https://updates.software-univention.de/4.3/maintained/component/4.3-1-errata/Packages.gz
27.10.18 12:59:24.399  NETWORK     ( ALL     ) : Error downloading https://updates.software-univention.de/4.3/maintained/component/4.3-1-errata/Packages.gz: 404
27.10.18 12:59:24.400  USERS       ( INFO    ) : Calling '/tmp/tmp0xsPF4/preuphwpPb7.sh' 'pre' '4.3-2'
exitcode of univention-updater: 1
ERROR: update failed. Please check /var/log/univention/updater.log

hope that’s help


#20

ok, I delete the 4.2.5 and deaktivate the bareos repo. Now it works. Thank you!