UCS Management Console - Authentication falied

german

#1

Auf der UCS Management Console gibt es die Fehlermeldung “Authentication falied: no response yet :(” wenn ich mich abmelde und danach versuche unter einem anderen Benutzernamen anzumelden.

Der Fehler bleibt erhalten, bis ich den Browser neu starte. (Session Problem?)

Auerdem ist mir aufgefallen, das die Funktion zum Abmelden nur auf der Übersichtsseite verfügbar ist.

Mit freundlichen Grüßen,

Mario Minati


#2

Sehr geehrter Herr Minati,

wir konnten das von Ihnen beschriebene Verhalten hier nicht reproduzieren.
Die Meldung “Authentication failed: no response yet” bedeutet, das der
UMC-Client(das Web-Frontend) auf eine Antwort wartet, die er für die
Anmeldung des Benutzers benötigt. Um dieses Problem weiter analysieren
zu können, gehen Sie bitte wie folgt vor:

Was für einen Browser verwenden Sie?

Kurzfristig die UMC-Loglevel für 3 “univention-config-registry” Variablen auf den Wert 4
erhöhen und nach der Problemsuche wieder auf 1 setzen:
univention-config-registry set umc/module/debug/level=4
univention-config-registry set umc/server/debug/level=4
univention-config-registry set umc/web/debug/level=4

Neustarten des UMC-Servers:
/etc/init.d/univention-management-console-server restart

Prüfen ob der UMC-Server läuft:
ps aux | egrep univention-management-console-server

Ihre zuvor beschriebene Anmeldung erneut versuchen.

Prüfen Sie bitte in folgenden Log-Dateien, ob Sie hier Hinweise finden:
less /var/log/univention/management-console-module.log
less /var/log/univention/management-console-server.log
less /var/log/univention/management-console-web.log

Mit freundlichen Grüßen
Murat Odabas


#3

Mozilla Firefox 2.0.0.13 unter Windows 2000 SP4

Restarting Univention Management Console Server: ok: run: univention-management-console-server: (pid 4765) 0s, normally down
root      2495  0.0  0.0    112    32 ?        Ss   Mar25   0:00 runsv univention-management-console-server
root      4765  1.8  1.3  21272 14172 ?        S    07:56   0:00 /usr/bin/python2.4 /usr/sbin/univention-management-console-server -n -d 4 -l de_DE.utf8

Agemeldet als normaler User, dann wieder abgemeldet und als ‘Administrator’ mit korrektem Paswort angemeldet.

Prüfen Sie bitte in folgenden Log-Dateien, ob Sie hier Hinweise finden:

09.04.08 07:54:32  DEBUG_INIT

Ist angehängt.

Ist angehängt.

Es sind einige Fehler vorhanden, aber ich kann nicht erkennen woran der Verbindungsaufbau scheitert.

Mit freundlichen Grüßen,

Mario Minati
management-console-web.log.tar.gz (3.49 KB)
management-console-server.log.tar.gz (2.88 KB)


#4

Sehr geehrter Herr Minati,

könnten Sie uns zur weiteren Eingrenzung des
Problems bitte noch die folgenden Informationen zukommen lassen.

  • Um was für eine UCS Systemrolle handelt es sich?

  • Welche UCS Version wird auf dem UCS System verwendet, 2.0-0 oder 2.0-1?

  • Können Sie sich mit einem Benutzer als erster am
    Univention Management Console(UMC) anmelden, d.h.
    beim ersten Aufruf des Univention Management Console
    mit dem Benutzer Anmelden der sonst die Fehlermeldung bekommt?

  • Können Sie die Anmeldung des Benutzers am Univention Management Console
    (UMC) auf einem anderen UCS System ausführen, falls Sie in Ihrer
    Umgebung weitere UCS Systeme betreiben?

  • Ist das UCS System direkt in der jetzt aktuellen Version installiert worden oder
    wurde es Aktualisiert, z.B. von UCS 1.3-2 auf UCS 2.0-0?
    Falls es Aktualisiert wurde, gab es Probleme beim update?

Mit freundlichen Grüßen
Murat Odabas


#5

Sehr geehrter Herr Odabas,

hier die gewünschten Informationen:

UCS Domain Controller Master

Installiert wurde Version 2.0-0, anschliesend das Update auf Version 2.0-1.

ja,
wenn ich mich als dieser Benutzer (Administrator) dann wieder abmelde und erneut versuche mich als gleicher Benutzer (Administrator) anzumelden, erhalte ich ebenfalls die Fehlermeldung “Athentication falied: no response yet :(”

Wenn ich den Tab (Registerkarte) im Browser schliesse und in einem neuen Tab die UMC aufrufe kann ich mich wieder (einmal) anmelden.

Auf einem zweiten UCS System (UCS Domain Controller Backup) das ich erst kürzlich installiert habe (noch Version 2.0-0), kann ich mich als Administrator anmelden. Nach Abmelden und wieder anmelden als normaler Benutzer stehen alle UCS Module (die für den Benutzer Administrator freigegeben sind) auch dem normalen Benutzer (der eigentlich überhaupt keine UCS Module sehen sollte) zur Verfügung. Ein Aufrufen dieser Module ergibt dann folgende Fehlermeldung: “Ein Fehler ist aufgetreten: Unbekanntes Kommando oder fehlende Berechtigungen”.
Erst nach schließen des Browser-Tabs und erneutem aufrufen der UMC werden die Module richtig angezeigt.
Umgekehrt sieht der Administrator keine Module, wenn ich vorher als normaler Benutzer angemeldet war.

Was mir dabei auffällt, ist das versteckte Formfeld session_id, das immer gleich bleibt, auch wenn ich mich als anderer Benutzer anmelde. Sollte beim Abmelden diese Variable nicht zurückgesetzt werden?

Die Systeme sind gleich als Version 2.0-0 installiert worden.

Mit freundlichen Grüßen
Mario Minati


#6

Sehr geehrter Herr Minati,

bzgl. des Problems[ul]
[li]Auf einem zweiten UCS System (UCS Domain Controller Backup) das ich erst kürzlich installiert[/li]
[li]habe (noch Version > 2.0-0), kann ich mich als Administrator anmelden. Nach Abmelden und wieder[/li]
[li]anmelden als normaler Benutzer stehen alle UCS Module [/li]
[li](die für den Benutzer Administrator freigegeben sind) …[/li][/ul]
Das beschriebene Verhalten konnten wir hier reproduzieren. Wir gehen davon aus, das es sich hier um
ein Caching Problem des Browsers handelt. Das Fehlverhalten der Univention Management Console wird
auch auf Ihr eigentliches Problem (Authentication falied: no response yet :slight_smile: zurückzuführen sein.
Wir haben diesbezüglich einen Eintrag in unserer internen Fehlerdatenbank vorgenommen.
Dieses Problem wird in einer der nächsten UCS Versionen behoben sein.

Mit freundlichen Grüßen
Murat Odabas