Ucs <-> ad sync Authentication failed

german

#1

Hi,

Änderungen in den “Admin Tools” von MS werden nicht ins UCS übernommen.

Hier die Fehlermeldung aus /var/log/univention/connector-s4-status.log:

[quote]Thu Jan 19 15:42:02 2017
— connect failed, failure was: —

Traceback (most recent call last):
File “/usr/lib/pymodules/python2.7/univention/s4connector/s4/main.py”, line 282, in main
connect()
File “/usr/lib/pymodules/python2.7/univention/s4connector/s4/main.py”, line 167, in connect
baseConfig[’%s/s4/listener/dir’ % CONFIGBASENAME]
File “/usr/lib/pymodules/python2.7/univention/s4connector/s4/init.py”, line 790, in init
univention.s4connector.ucs.init(self, CONFIGBASENAME, property, baseConfig, listener_dir)
File “/usr/lib/pymodules/python2.7/univention/s4connector/init.py”, line 483, in init
self.open_ucs()
File “/usr/lib/pymodules/python2.7/univention/s4connector/init.py”, line 517, in open_ucs
self.lo = univention.admin.uldap.access(host=host, port=port, base=self.baseConfig[‘ldap/base’], binddn=binddn, bindpw=bindpw, start_tls=2, follow_referral=True)
File “/usr/lib/pymodules/python2.7/univention/admin/uldap.py”, line 308, in init
raise univention.admin.uexceptions.authFail(_(“Authentication failed”))
authFail: Authentication failed

— retry in 30 seconds —[/quote]

Was läuft das schief?


#2

Kann vielleicht mein Eintrag von kurzem beim Problem helfen?

[url]AD -> UCS Sync = Failed to lookup S4 LDAP base]


#3

wenn ich das hier ausführe:

sdb.univention.de/content/6/223/ … ieren.html

funktioniert der sync wieder. Problem ist aber das man sich dann an allen Computer nicht mehr anmelden kann mit der Meldung: “Die Vertrauensstellung zwischen dieser Arbeitsstation und der primären Domäne konnte nicht hergestellt werden”

ratlos :frowning:


#4

ggf. reicht es schon den computeraccount zu aktualisieren: http://www.networknet.nl/apps/wp/archives/1938


#5

ja das würde funktionieren, sind aber 160 rechner :frowning: sehr sehr aufwendig


#6

Naja, ich würde das wohl erstmal an einem betroffenen Rechner testen, ob das bereits ausreichend ist und dann darauf aufbauend weitere Schritte überlegen.


#7

hi, also ein rejoin funktioniert wie erwartet… gibt es jetzt irgendeine “elegante” methode sämtliche rechner “remote” aus der domain zu entfernen und wieder einzufügen?


#8

Okay ein rejoin sollte in dem Link den ich gepostet habe eigentlich gerade nicht vorkommen. Das dieser funktioniert ist nicht überraschend. Ich poste den Inhalt nochmal:

[quote]Out of the box netdom.exe tool is not available on Windows 7 (I am using 32bit enterprise version). To get the command utility I had to install Remote Server Administration Tools (KB958830) and copy that on a network share.

I found out that the netdom.exe utility needs to stored in C:WindowsSystem32 and netdom.exe.mui file should be copied to C:WindowsSystem32en-US folder. If the netdom.exe location is wrong or the mui file is missing netdom.exe won’t show anything when started.

[…]

Make sure the netdom.exe and netdom.exe.mui files are stored in the mentioned folder locations
[ul]Open an elevated command prompt
Run: netdom.exe resetpwd /server: /userD: /passwordD *
Enter password
Reboot the machine[/ul][/quote]

Das heisst, wenn das funktioniert, könnte man die Netdom.exe und .mui an die entsprechenden Orte im Windows Client kopieren und dann gescriptet die obigen Schritte ausführen, das müsste eigentlich auch automatisiert möglich sein. Damit ist kein Rejoin nötig.