UCS 5 install from ISO cannot reboot

Hello There,

yesterday I spent a whole day in failing to install UCS 5 from an ISO (UCS-Installation-amd64.iso) which I just downloaded yesterday.

I want to install on a computer with this Mainboard: MSI B365M PRO-VDH (MS-7C39) an SSD (/dev/nvme0n1) and an intel i3-9100F.

I have tried several combinations of Secure Boot On/Off and other Settings, but the result is always the same. In best case the installation succeeds without any error, but rebooting just brings me back to the BIOS Settings.

I have installed ubuntu on the same machine and that just worked. I could manage to install Debian, but in order to run it, I needed to disable Secure Boot.

Is that a know Issue? For UCS 4.x I found several posts, but not for 5. What’s the fix for that?

Best Karl

Chances are it is the boot loader.
maybe the name of the SSD?

but on the ISO when you boot it , there is a recovery option.
boot into that & mount the SSD, to see where it is failing, as per standard linux
I do know the the UCS partitioning is “flakey”, reported it years ago… and still not fixed

you also did not say HOW you installed it as regards partitioning…

you also did not say HOW you installed it as regards partitioning

True. But I tried with all on one disk and with LVM and separated partitions.

but on the ISO when you boot it , there is a recovery option

I actually did that after I just posted here. the result of lsblk did look like that:


So while all other disks printed a usual, the ones for the ssd appeared like so, with some type jibberish … The exact jibberish was a bit different, I just tried to recreate that, since I forgot to take a picture.

OK… that may cause a problem… (unrelated)
specifically trigger a buried problem…

when you use a single disk, but break the things like “tmp” , “/home” out into it’s own partition , it has a fixed & limited size.
that WILL break quite a few things , including potentially version upgrades, and backup tools, specifically because they make the partitions too small…
far better to keep all the folders under one tree, monitor , then split out any large ones to a secondary volume

I filed a bug back in 4.6 something, and the problem is STILL around in 5.0.3, and still catching me out.

Maybe try and map the ssd as sda1 or sdb1 , that sort of thing…,
Get it to the most basic case…
All the partitions on one root directory.

UCS-5.0-3 should work with secure-boot; If you got not error message during installation you might want to check your BIOSUEFI-Firmware to see, if you can manually boot the right files in /boot/efi/EFI/univention/shimx64.efi and/or /boot/efi/EFI/BOOT/BOOTX64.EFI. Both should chain-load GRUB2, which then boots UCS.
In some cases efibootmgr fails to set the EFI-variables correctly, which tell EFI what to boot. (This sometimes fails if previously Debian was installed on the same system). Most EFI-Firmwares allow you to walk the EFI-Filesystem which should help you in finding out, what’s there and what’s missing.

Thanks a lot for that! Gonna look into it!