UCS 5 Domain Controller DNS issues


i have installed a fresh USC5 Server as a domain controller, but i cannot join a windows client to that new
domain because there are a lot of dns entries missing so the windows client cannot find the domain

I compared the dns settings with a fresh setup of a server with ucs 4. There are a lot more entries in the
dns server and joining a client is no problem.

I hope someone can give me a hint how to solve this issue or maybe there is an update.

Best regards,


First and most important things to consider:

  • Do you have the Win-AD server installed on UCS?
  • Are your Win10 clients using the new (!) UCS as DNS-server? Are you sure? Your are REALLY sure?



During the system setup there comes the question to create a new domain controller or join one.

I always choose to create a complete new one.

In the result there are a few DNS entries in version 5 but if i do the same in version 4 there a lot more
entries in the DNS server of ucs.

Do you know why?

I did a wireshark diag to get to know why the windows clients won’t join the domain and its because of
the missing entries.

Don’t know how to get them into the DNS server.

Best regards,


Looks like you are doing shotgun troubleshooting. One of the bullets (Wireshark) might randomly hit the target…

You have not answered any of my two questions seriously. At least for the first one it seems to be a “yes”, but this is just a guess.

However. Re-read the second question and answer it. You might to read and understand(!) this article. Once done, please answer:

  • Are your Win10 clients using the new (!) UCS as DNS-server? Are you sure? Your are REALLY sure?

And give proof in case you are sure they do. nslookup on Windows might be a good starting point to verify.



You brought me on the right track.

I mean it wasn’t the DNS on the client side. There everything was OK.

But i screwed myself completly up.

If you setup up UCS version 4 and choose to setup a new domain, the domain controller option in the
software list is preselected. So it gets installed right away and everythings works as it should.

But in UCS version 5 it is different.

There you choose also to setup a new domain, but no software package is installed at all.
You have to install everything after the setup finished. Also the domain controller.

So i tried the whole time to join a windows client to the domain without the domain controller software
package. After i installed the package, all the dns entried are there and the join process worked like a

Yeah, so you brought me in any case on the right track.

Thank you very much.

Best regards,




great to hear and thanks for posting the solution.