UCS 5.0 upgrade failed: solve pre-update check python-ucr-template-compatibility: univention-samba4

Hallo,

bei einem versuchten Upgrade auf den UCS 5.0 erhalte ich die folgende Fehlermeldung:


The system can not be updated to UCS 5.0 due to the following reasons:

python_ucr_template_compatibility:
The following UCR templates are not compatible with Python 3:
	 /etc/univention/templates/files/etc/samba/smb.conf.d/10global (package: univention-samba4)
See <https://help.univention.com/t/17948> for information on how to proceed with each template.

Error: Update aborted by pre-update script of release 5.0-0

Ich habe schon einige Posting zu diesem Thema gefunden, das Paket univention-samba4 war aber bisher nicht dabei.

Viele Grüße,

Stefan

Welche Version ist denn installiert?

apt-cache policy univention-samba4

univention-samba4:
Installiert: 8.0.0-37A~4.4.0.202201181413
Installationskandidat: 8.0.0-37A~4.4.0.202201181413
Versionstabelle:
*** 8.0.0-37A~4.4.0.202201181413 500
500 updates.software-univention.de 4.4-8-errata/amd64/ Packages
100 /var/lib/dpkg/status

Scheint aktuell zu sein. Die Datei /etc/univention/templates/files/etc/samba/smb.conf.d/10global ist auch aktuell und wurde nicht verändert?

univention-check-templates

Sieht gut aus:

root@ucs:~# univention-check-templates
WARNING: The following UCR files are modified locally.
Updated versions will be named FILENAME.dpkg-*.
The files should be checked for differences.

/etc/univention/templates/files/etc/bash.bashrc
/etc/univention/templates/files/etc/samba/smb.conf.d/95univention-samba_local_config

Das würde ich mal fixen. Ggf. erledigt sich das Problem mit dem Upgrade dann.

Ich habe auf einem zweiten Server ein ähnliches Problem:


univention-check-templates
WARNING: The following UCR files are modified locally.
Updated versions will be named FILENAME.dpkg-*.
The files should be checked for differences.

/etc/univention/templates/files/etc/samba/smb.conf.d/10global

Die Datei 10global wurde verändert und in dem Verzeichnis habe ich dazu die Datei 10global.dpkg-dist gefunden, die wohl im Rahmen eines Updates hätte installiert werden sollen.
Ersetze ich nun 10global durch 10global.dpkg-dist, dann erhalte ich trotzdem die Fehlermeldung.
Ich gehe davon aus, dass univention-check-templates die Datei anhand eine Hash überprüft, der irgendwo gespeichert ist. Habe ich die Möglichkeit, diesen Hash zu aktualisieren? Es gibt auch weitere Dateien, bei denen wir für Kunden kleine Änderungen vorgenommen haben und bei denen dieses Problem auch auftreten wird.

Gruß,

Stefan