UCS 5.0 Update failed

Hi, what must be done if the following issue occurs:

The system can not be updated to UCS 5.0 due to the following reasons:

python_ucr_template_compatibility:
The following UCR templates are not compatible with Python 3:
/etc/univention/templates/files/usr/share/univention-web/js/umc/hooks/appliance.json (package: univention-app-appliance)

Error: Update aborted by pre-update script of release 5.0-0

Hi, got the same Error:
The system can not be updated to UCS 5.0 due to the following reasons:

python_ucr_template_compatibility:
The following UCR templates are not compatible with Python 3:
/etc/univention/templates/files/usr/share/univention-web/js/umc/hooks/appliance.json (package: univention-app-appliance)

Error: Update aborted by pre-update script of release 5.0-0

Did you install the latest UCS 4.x errata? As far as I know, the latest UCS 4.4.8 errata updates contain a few elements to prepare for 5.0 upgrade.

This is the installed version:

4.4-8 errata992

do we have to uninstall the package univention-app-appliance ?

What happens with the installed apps ?

or is there a package which works with the new version ?

i found this:

  • Internal change: the UCR templates of univention-appcenter are now python3 compatible (Bug 51101).
    So it should work with my installed 4.4-8. But it doesn’t…

In the current state of development of UCS 5, it is better to wait with installation/upgrade, if you are not an expert. There seem to be too many major bugs for non-experts.

1 Like

Is there any news ? I tried it today again, but i got the same error again. Any idea ?

Do you found any solution for this issue ?

I wish i had seen this earlier before upgrade.